Reply
 
Thread Tools Display Modes
Old 06-16-2015, 11:41 AM   #1
Junior Member
 
Join Date: Jun 2015
Posts: 2
Sabre 2012

We are having a heck of a time with the Genesis 3.0 combo in our fiver. Sometimes it works, sometimes it doesn't. the dealer says there is power going to the unit but it won't turn on. The remote lights up but the unit itself does not. Is there a reset button on this player or is it just shot?
__________________

__________________
linero is offline   Reply With Quote
Old 06-16-2015, 10:39 PM   #2
Member
 
Join Date: Apr 2012
Location: Calgary
Posts: 67
With the unit on (if you can get it on), press and hold the mode button for 10 seconds. The unit will turn off. Press the power button to restart.

Try pulling the fuse in the converter panel, waiting a few minutes , then put it back in.
__________________

__________________
NeilM108 is online now   Reply With Quote
Old 06-17-2015, 09:27 AM   #3
Senior Member
 
Join Date: Mar 2015
Location: CT
Posts: 291
I say this with all due respect, since the rep is somewhat active on here and at least tries to be helpful.

You are having problems with it because it is a piece of ****.
__________________
2015 Ram 3500 CC SRW SB 6.7 Diesel Powered Baby!
2015 Sabre 36QBOK-7

2015 Nights Camped: 23
2016 Nights Camped: 27
2017 Nights Camped: 28
mikeysotp is offline   Reply With Quote
Old 06-17-2015, 09:38 AM   #4
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
Pull the unit out of the cabinet, there is also a fuse behind it.
Altho I've seen plenty of issues here on the forum I've not had any problems with mine.


TURBS
08 duramax tuned n modded
2011 32bhok Sabre
2015 camping "9 nights"
__________________
TURBS is offline   Reply With Quote
Old 06-17-2015, 09:41 AM   #5
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
See the fuse?
Click image for larger version

Name:	uploadfromtaptalk1434548492147.jpg
Views:	75
Size:	135.6 KB
ID:	80240Click image for larger version

Name:	uploadfromtaptalk1434548500749.jpg
Views:	80
Size:	167.9 KB
ID:	80241

TURBS
08 duramax tuned n modded
2011 32bhok Sabre
2015 camping "9 nights"
__________________
TURBS is offline   Reply With Quote
Old 06-17-2015, 11:43 AM   #6
Senior Member
 
LaydBack's Avatar
 
Join Date: Dec 2012
Posts: 320
This may not be your case, but I found with ours that apparently someone was taking the remote off of controlling the unit. It's a universal remote, and you have to make sure it's on the right device. I think that group of buttons is somewhere in the center...
__________________

__________________
LINK TO MY MODS

2012 F350 King Ranch DRW 6.7L
2013 Sabre 36QBOK-7 Platinum Package
LaydBack is offline   Reply With Quote
Reply

Tags
2012, sabre

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:58 AM.