Thread Tools Display Modes
Old 08-15-2012, 07:54 PM   #1
Junior Member
Join Date: Aug 2012
Posts: 2
slide out problem

Hi when I close the slide out since a short time, sometime the fuse 30amp. Blow out at the end of the opertation'its appen 3 times now ,I replace whit a new one and it's running good .I check under ,nothing broken or loose,lubrication is ok .I have a 2010 sabre 28rets 6 . Thank's

yroberge is offline   Reply With Quote
Old 08-15-2012, 09:23 PM   #2
Junior Member
themiddletonz's Avatar
Join Date: Aug 2011
Location: Maple Ridge, BC
Posts: 8
I had the same issue with my slide, the problem was a pinch in the electrical wire to the slide motor grounding on the frame when slide in motion.

themiddletonz is offline   Reply With Quote
Old 08-16-2012, 05:40 PM   #3
Junior Member
Join Date: Aug 2012
Posts: 2
I have check that to ,nothing wrong about strapped tight . Thank's
yroberge is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:11 AM.