Reply
 
Thread Tools Display Modes
Old 06-08-2013, 12:30 PM   #1
Member
 
Join Date: Nov 2012
Location: Monroe Wa.
Posts: 47
Television goes out when you turn on lights

We are one month out with the new 295RL and here at the latest rv park, there is no cable. We are using the antenna and getting over the air tv.

When we turn on any light switch, the tv picture and sound goes out. As soon as you turn the lights out, the tv goes back on.

What is going on?

Thanks.

Jon
__________________

__________________
2001 Dodge 3500 4x4 dually
Exhaust brake, 4" SS exhaust
DDP injectors, Edge chip
B&W hitch
2013 Columbus Palomino 295RL
Jon_Celia is offline   Reply With Quote
Old 06-08-2013, 12:41 PM   #2
Senior Member
 
Road-King's Avatar
 
Join Date: Jul 2012
Location: TN
Posts: 645
Do you have your antenna booster switch "on"?
__________________

__________________
Russ & Kim
2014 Alpine 3600RS
2007 Dodge Ram 3500 5.9 4X4
2008 Harley Davidson Road King 105th Anniversary
(2011-5 bad year)(2012-40)(2013-45)(2014-23)
Road-King is offline   Reply With Quote
Old 06-08-2013, 02:17 PM   #3
Senior Member
 
jtstromsburg's Avatar
 
Join Date: Jul 2011
Location: Stromsburg, Nebraska
Posts: 1,654
Quote:
Originally Posted by Jon_Celia View Post
We are one month out with the new 295RL and here at the latest rv park, there is no cable. We are using the antenna and getting over the air tv.

When we turn on any light switch, the tv picture and sound goes out. As soon as you turn the lights out, the tv goes back on.

What is going on?

Thanks.

Jon
Watching this closely as my tbok does the same thing. At least the hall light, which is nearest to the antenna...guessing the coax is next to the12 volt line.
__________________
Joel and Teresa
2016 Sabre 34TBOK
2006 GMC 3500 CC LB DRW 4X4
jtstromsburg is offline   Reply With Quote
Old 06-08-2013, 02:34 PM   #4
Senior Member
 
Join Date: Feb 2012
Posts: 130
I have/had the same issue in my tt. Had it looked at when in for warranty work. They said it was a bad ground in the 12 volt system, the specific location in my unit where the fault occurred was the bathroom vent fan. It still happens everyonce and a while even though the dealer "fixed" it, but it is much better and I'm just not that concerned about watching TV to chase it down further.
__________________
Kf4mnc is online now   Reply With Quote
Old 06-09-2013, 12:15 AM   #5
Senior Member
 
amxpress's Avatar
 
Join Date: Nov 2007
Location: Clayton, NC
Posts: 683
Check your antenna booster. Remove it from the wall and inspect the co-ax cable ends. Some cables had connector ends that pulled out or were loose making poor connections. Also make sure the wires to the booster are connected properly. You'll have to get the correct wiring schematic online.
__________________
2013 Palomino Columbus 320RS
2007 Dodge RAM 2500 6.7 Cummins
Reese 15K manual slider
Prodigy
M.I.L. in Florida for good!!
amxpress is offline   Reply With Quote
Old 06-09-2013, 08:26 AM   #6
Member
 
Join Date: Nov 2012
Location: Monroe Wa.
Posts: 47
Thank you.

I will check it all out when we get home.

Jon
__________________
2001 Dodge 3500 4x4 dually
Exhaust brake, 4" SS exhaust
DDP injectors, Edge chip
B&W hitch
2013 Columbus Palomino 295RL
Jon_Celia is offline   Reply With Quote
Old 07-08-2013, 03:06 PM   #7
Junior Member
 
TopGunz's Avatar
 
Join Date: Jun 2013
Location: SW Missouri
Posts: 17
I have the exact same issue in my new 340RK. When watching the bedroom TV, anytime you turn on the bedroom light you lose reception. I have it at the dealer now. Hopefully they will find the problem.
__________________

TopGunz
SW Missouri
2013 Columbus 340RK
2011 Ford F350 DRW
King Ranch 6.7L Diesel
TopGunz is offline   Reply With Quote
Old 07-08-2013, 03:24 PM   #8
Member
 
Join Date: Nov 2012
Location: Monroe Wa.
Posts: 47
Topgunz:

We just got home and have not had time to look into it yet.

Would you please let us know what you find out.

Thanks.

Jon
__________________
2001 Dodge 3500 4x4 dually
Exhaust brake, 4" SS exhaust
DDP injectors, Edge chip
B&W hitch
2013 Columbus Palomino 295RL
Jon_Celia is offline   Reply With Quote
Old 07-08-2013, 03:38 PM   #9
Site Team
 
wmtire's Avatar
 
Join Date: Nov 2010
Location: Northeast Louisiana
Posts: 15,040
Quote:
Originally Posted by Jon_Celia View Post
Topgunz:

We just got home and have not had time to look into it yet.

Would you please let us know what you find out.

Thanks.

Jon
Do you have LED lights, as some will cause Radio Frequency Interference (RFI) when used?

If you do have LED lightbulbs, try using a regular incandescent bulb(s) in any fixture you know to cause problems with TV reception and see if it fixes it.

We have been discussing this same thing here:

Lose T.V. reception when we turn on lights.
__________________
2011 Flagstaff 831 RLBSS

Ducks are just all-terrain chickens
wmtire is online now   Reply With Quote
Old 07-08-2013, 09:40 PM   #10
Member
 
Join Date: Nov 2012
Location: Monroe Wa.
Posts: 47
Yes, our entire trailer lights are LED's. I really like the lights vs the halogens on our old trailer.

I will still check the connections.

Thanks.

Jon
__________________

__________________
2001 Dodge 3500 4x4 dually
Exhaust brake, 4" SS exhaust
DDP injectors, Edge chip
B&W hitch
2013 Columbus Palomino 295RL
Jon_Celia is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:14 AM.