fella10 will become famous soon enough

fella10 fella10 is offline

Senior Member

Profile Comments

Showing Profile Comments 1 to 6 of 6
  1. CastletonRVers
    As it turned out, the tubing was snapped off, not the weld. I totally removed the platform and loosened the paneling enough to get to the broken rail. I then used clamps and 2X4s to torque the bend out of the rail that occurred during the breaking process. I then sandwiched nearly the entire rail in two pieces of 1/8" angle aluminum and used 5 worm gear hose clamps to hold them tight to the rail. Next I put the paneling and plastic trim back. You can't see the repair unless you remove the mattress.
    In analyzing what went wrong, I discovered many screw and staple holes created during the original build. The break occurred where a number of holes were drilled close together and the rail strength was compromised. In my opinion, the material Forest River used (1/16" aluminum tubing) was way too thin for the job. I elected to reattach the panels with automotive double-sided tape and a minimum number of screws.
    I only fixed the broken rail. The other was straight and looked OK.
  2. CastletonRVers
    I noted that you tore the Murphy Bed apart to make repairs. Is it as grueling a job as I imagine? How well did it go back together? Do you have pictures? I have a broken tube (not just a weld) to fix.
  3. Shawetc
    02-19-2017 09:21 AM
    Shawetc
    We just purchased a 2503s Could you please send me a list of mods that you have done on yours
  4. fella10
    05-11-2015 09:00 PM
    fella10
    there may be other ways of getting a photo to show in a post here, like copy and paste, or drag from PhotoBucket, or some other way, BUT, doing any of those OTHER ways is not necessary in the other forums on this website(Forest River Forums),

    when I click on "post reply" or "go advanced" in the other forums, there are many more options available to use with that post and one of those options is the "paper clip", which is necessary to add a file/photo,

    in this forum, when I click on "post reply" or "go advanced", the options are not the same, there are much fewer to use and the "paper clip" is not one of them, thus, it is not possible to add a file/photo, like I can on the other Forest River Forums,

    would like to be able to post photos and for some reason, this forum is different and won't allow it, just trying to find out why?
  5. SkipBest
    05-11-2015 04:50 PM
    SkipBest
    I messed up... Kevin is 220Chap I had it backwards
  6. SkipBest
    05-11-2015 04:47 PM
    SkipBest
    Thanks! I also can't seem to get the hang of posting photos. Kevin, chap220, has been able to post some great shots... let's ask him his system.

    We pick up our new Mini Lite 2503s,which is a twin to the 25KS, next week... I'll try to post some photos when we return home.

About Me

  • About fella10
    Location
    eastern NC
    City
    Newport
    State/Province
    North Carolina
    RV Year and Model
    2015 Micro Lite 25KS
    My Tow Vehicle
    2002 Ford F150 ext. cab
    Gender
    Male
  • Signature


Statistics

Total Posts
Profile Comments
General Information
  • Last Activity: Yesterday 11:56 PM
  • Join Date: 01-07-2015
  • Referrals: 0


ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:48 AM.