Forest River Forums

Forest River Forums (http://www.forestriverforums.com/forums/)
-   Palomino (http://www.forestriverforums.com/forums/f96/)
-   -   Electric fireplace won't turn on (http://www.forestriverforums.com/forums/f96/electric-fireplace-wont-turn-on-100518.html)

mikejm 02-05-2016 06:53 PM

Electric fireplace won't turn on
 
2014 palomino 320ts

bob caldwell 02-05-2016 06:56 PM

Plugged in?.....power to plug?

mikejm 02-05-2016 07:00 PM

It worked this morning won't turn on this afternoon

bob caldwell 02-05-2016 07:10 PM

Check circuit breaker...plug a lamp into wall outlet...

TURBS 02-05-2016 07:26 PM

Remote battery dead?


2015 Columbus 320RS
2008 2500HD Duramax
2015 nights camped "34"

rapper 02-05-2016 07:58 PM

The fireplace doesn't turn on at all or just isn't blowing heat? If it turns on & no heat, the thermostat may not be calling for heat. There is a manual panel on top of unit (Greystone unit) & try that to turn on.

mikejm 02-05-2016 08:36 PM

It doesn't turn on.

mikejm 02-05-2016 08:38 PM

Quote:

Originally Posted by TURBS (Post 1095507)
Remote battery dead?


2015 Columbus 320RS
2008 2500HD Duramax
2015 nights camped "34"

Not using remote. Thanks

mikejm 02-05-2016 08:39 PM

Quote:

Originally Posted by bob caldwell (Post 1095487)
Check circuit breaker...plug a lamp into wall outlet...

Dark out will try in morning. Thanks.

TURBS 02-05-2016 08:47 PM

Electric fireplace won't turn on
 
It's possible it could be the gfci need to double check that the outlet has power " in the morning " of course.


2015 Columbus 320RS
2008 2500HD Duramax
2015 nights camped "34"


All times are GMT -5. The time now is 01:08 AM.