Forest River Forums

Forest River Forums (http://www.forestriverforums.com/forums/)
-   FR3 (http://www.forestriverforums.com/forums/f232/)
-   -   Stupid Human (http://www.forestriverforums.com/forums/f232/stupid-human-125813.html)

Lexi2007 01-28-2017 07:40 PM

Stupid Human
 
:crying::crying:

I let time get away from me after the holidays, other than that, no excuses. I went to start the generator today and nothing. No priming light, no hours showing on display,,,nothing on the inside control board. It has been sitting for a while but plugged into shore power. [We already knew the engine batteries were weak as the steps had problems coming down and retracting.] After numerous attempts and workarounds, we tried starting on the gennie while also plugged into shore power. The priming light came on but when I tried to start it, the gennie made a sound similar to a starter when the battery is dead. [We did check oil level and it's full]. Can anyone suggest anything before we drag the rig to the local RV repair shop? :crying:

Homebrew 01-28-2017 09:10 PM

Replace the battery with new one.

wana65stang 01-28-2017 09:17 PM

Charge the battery and try again before taking it in.

bubbles 01-28-2017 09:21 PM

I believe you'll find that your steps are fused off the coach batteries not the chassis (engine) battery. Sounds like a weak coach battery bank.


All times are GMT -5. The time now is 09:54 PM.