Forest River Forums

Forest River Forums (http://www.forestriverforums.com/forums/)
-   FR3 (http://www.forestriverforums.com/forums/f232/)
-   -   Awning stopped working (http://www.forestriverforums.com/forums/f232/awning-stopped-working-166430.html)

Jim Wiemels 07-25-2018 08:56 PM

Awning stopped working
 
Tonight as we attempted to retract the power awning it stopped about 1/3 of the way to closing. The motor seemed to run very slow then stopped. The 15 amp fuse was good and using a tester the switch appears to be providing power. We applied 12 volt power directly to the motor and no movement. We than did a manual retraction with a power drill. Our 2016 FR3 30DS has had a lot of use with 33,000 miles and over 450 nights. Just wondering if anyone has had trouble with their awning motor or switch ? Thank you for your input
Jim

Gdub2 07-25-2018 09:48 PM

Our awning did the same thing. It's a LCI solera power awning.
The motor was bad replaced motor works fine.

shortkid 07-26-2018 08:23 PM

About a month ago, the awning on our Coachmen would not retract. It seemed to be binding so I helped it along while DW retracted it. when we got home, I took the end caps off cleaned and lubed the moving parts. It seemed as though the factory lube had dried up and with the dust and pollen corroded everything. Put it all back together and has been O K and much quieter wile operating. Hope this helps you.

Jim Wiemels 07-26-2018 09:11 PM

Today I purchased a new motor, installed it and the power awning now runs fine.


All times are GMT -5. The time now is 07:16 PM.