Forest River Forums

Forest River Forums (http://www.forestriverforums.com/forums/)
-   Flagstaff (http://www.forestriverforums.com/forums/f33/)
-   -   Electric Jacks (http://www.forestriverforums.com/forums/f33/electric-jacks-175233.html)

Regthehabsfan 12-03-2018 10:13 AM

Electric Jacks
 
Is there a fuse and if yes where for the jacks. I changed the battery and the jacks will only work when plug into shore power. I have a classic super lite 5th wheel. Thanks

5picker 12-03-2018 10:16 AM

Is your battery disconnect, disconnected?
Do any other 12v items work without being plugged into shore power?

Regthehabsfan 12-03-2018 04:38 PM

Yes the battery is connected. Everything else works ie the slides. I have checked the fuse in the converter and it’s good. Can,t seem to fine any other fuses so not sure what to do next.

allenb12 12-03-2018 07:27 PM

Mine is under the trailer close to the front. Two fuses one for front and one for the rear.

Regthehabsfan 12-04-2018 01:43 PM

Thanks for all the input. We(my wife and google) found the resets on the switches. It seems that everything is working find.

5picker 12-04-2018 02:19 PM

Quote:

Originally Posted by Regthehabsfan (Post 1984650)
Thanks for all the input. We(my wife and google) found the resets on the switches. It seems that everything is working find.

Could you possibly be referring to the resets on 12v circuit breakers?

I've not seen resets on switches.

Did the thing(s) you reset look like this?

If so, they are reset style circuit breakers designed to give the circuit protection similar to a fuse but with the ability to be reset and reused.

On my 5th wheel these circuit breakers are located in the front storage near the battery and the battery disconnect switch. I have several and they are NOT connected through the disconnect.

https://i.ebayimg.com/images/g/aUgAA...hN1/s-l300.gif

Regthehabsfan 12-04-2018 04:51 PM

Yes those are the ones my wife found on google and we found them in the battery compartment. Small reset buttons but thankfully we saw them and everything seems to be working fine

5picker 12-04-2018 05:20 PM

Quote:

Originally Posted by Regthehabsfan (Post 1984775)
Yes those are the ones my wife found on google and we found them in the battery compartment. Small reset buttons but thankfully we saw them and everything seems to be working fine

Super! Thanks for reporting back. It will help others with similar issues.
:trink39: :campfire: :signhavefun:


All times are GMT -5. The time now is 11:31 PM.