Forest River Forums

Forest River Forums (http://www.forestriverforums.com/forums/)
-   Windows, Awnings & Doors (http://www.forestriverforums.com/forums/f228/)
-   -   Help, Awning not working! (http://www.forestriverforums.com/forums/f228/help-awning-not-working-39230.html)

10x 05-05-2013 09:02 AM

Help, Awning not working!
 
I have a 2014 xlr27hfs toyhauler with a Dometic power awning. The awning stopped working. I hear clicking sound outside by the motor when I press the switch but it does not move. Checked the fuses OK. Is there something I should check before I take it back for service? It is 80 mile trip to the dealer. Thanks:crying:

OldCoot 05-05-2013 09:06 AM

Quote:

Originally Posted by 10x (Post 368057)
I have a 2014 xlr27hfs toyhauler with a Dometic power awning. The awning stopped working. I hear clicking sound outside by the motor when I press the switch but it does not move. Checked the fuses OK. Is there something I should check before I take it back for service? It is 80 mile trip to the dealer. Thanks:crying:

Check that it is not bound up. Have someone intermittently hit the switch while you pull on the arms. Also check that the battery is full charged.

camper1999 05-05-2013 09:10 AM

Is your battery good, I am assuming it is since it is a newer trailer. If it is clicking sounds like it is getting power. Unless someone else has any other ideas sounds like a warranty item.

10x 05-05-2013 09:10 AM

Quote:

Originally Posted by OldCoot (Post 368060)
Check that it is not bound up. Have someone intermittently hit the switch while you pull on the arms. Also check that the battery is full charged.

I have plugged it plugged in to shore power. I will try having someone pull on it

Picked it up yesterday from dealer. I went to deploy the awning to install the support poles you sent and all I hear is clicking. Worked fine before.

OldCoot 05-05-2013 09:13 AM

Quote:

Originally Posted by 10x (Post 368066)
I have plugged it plugged in to shore power. I will try having someone pull on it

Did you get your poles?

camper1999 05-05-2013 09:21 AM

Even if you have it plugged into shore power if your battery is no good it will not work. But could be a binding issue

rattleNsmoke 05-05-2013 09:26 AM

Not sure, but when you hear a 'clicking' there's usually a relay involved.

10x 05-05-2013 09:29 AM

Quote:

Originally Posted by OldCoot (Post 368067)
Did you get your poles?

Yes I got them, I was going to install them when this happened

10x 05-05-2013 09:32 AM

I just tried to nudge on it while wife pressed switch. Still have the clicking noise. I am able to unroll and roll it by turning the roller by hand, Should I be able to do this. I thought there is spring tension to hold it back.

garbonz 05-05-2013 09:33 AM

Bound up or warranty. Maybe the fabric has become miss aligned. Check to see if the fabric is centered on the track both at the wall and at the arm,


All times are GMT -5. The time now is 04:21 AM.