Forest River Forums

Forest River Forums (http://www.forestriverforums.com/forums/)
-   FR3 (http://www.forestriverforums.com/forums/f232/)
-   -   Low Pressure When Flushing Toilet (http://www.forestriverforums.com/forums/f232/low-pressure-when-flushing-toilet-67978.html)

hillcountry 09-07-2014 07:11 PM

Low Pressure When Flushing Toilet
 
The water flow when flushing the toilet has gotten noticeably lower. This is true whether connected to city water or pumping from the fresh water tank. I just noticed this problem. Water flow from sinks is fine. Anyone else had and fixed this problem?

Thanks.

cucamelsmd15 09-07-2014 07:13 PM

Yes. Clean out the filter in the foot valve and you'll be flushing with the best of them in no time.

tracyp 09-10-2014 06:42 PM

How do you clean out the filter?


Sent from my iPad using Forest River Forums

ependydad 09-10-2014 07:45 PM

I'd try uninstalling it and flushing it both ways with water.

OldCoot 09-10-2014 08:03 PM

You will have to remove the valve, disassemble and clean the debris out of it.

cucamelsmd15 09-11-2014 07:13 AM

Quote:

Originally Posted by OldCoot (Post 698955)
You will have to remove the valve, disassemble and clean the debris out of it.

Yes. There is a bayonet mount where the water line comes into the toilet. Remove the water line and depress the bayonet fittings to get the filter assembly out.

Rolling Magic 09-13-2014 11:16 PM

Ya, been having this problem. Took it twice to fix. Warranty expiring soon, so will need to fix my self!


Sent from my iPad using Forest River Forums

Rolling Magic 03-12-2015 06:45 PM

Well it happen again, almost no water flow. So I youtubed Dometic 300 toilets and found a video on exchanging the water valve attached to the foot pedal. Well it was easy to disassemble. Turns out the screen inside the valve was clogged with filter carbon from my outside water filter. I blew the accumulation out replaced it and it's flushing like a champ. Wife is happy!


Sent from my iPad using Forest River Forums

drivmsafe 03-13-2015 11:10 AM

Just a FYI. Dometic was having problems with their 300 toilets early on and was replacing quite a few of them. There was some chatter on this forum regarding it a few months back. Not sure exactly which ones but, you might want to check with them. FR warranty mgr. may be able to help with this also.
I had to have my valve replaced, under warranty, and so far it's working ok.

Kaadk 03-13-2015 11:17 AM

Quote:

Originally Posted by drivmsafe (Post 805009)
Just a FYI. Dometic was having problems with their 300 toilets early on and was replacing quite a few of them. There was some chatter on this forum regarding it a few months back. Not sure exactly which ones but, you might want to check with them. FR warranty mgr. may be able to help with this also.
I had to have my valve replaced, under warranty, and so far it's working ok.


The problem with the 300's was a leak between the bowl and the black tank. Basically your 'stuff' wasn't going where it was supposed to be going resulting in some major stinking.




Sent from my iPhone using Forest River Forums


All times are GMT -5. The time now is 11:37 PM.