Forest River Forums

Forest River Forums (http://www.forestriverforums.com/forums/)
-   Forester (http://www.forestriverforums.com/forums/f15/)
-   -   TV (http://www.forestriverforums.com/forums/f15/tv-68432.html)

coldj 09-15-2014 09:47 PM

TV
 
My outdoor Jensen TV won't turn on but the power source is on. TV won't turn on remotely or manually. Any thoughts out there!


Sent from my iPad using Forest River Forums

mcnabbwr 09-15-2014 09:54 PM

Have you plugged anything else in to verify outside power? Maybe tripped GFI.

coldj 09-15-2014 10:05 PM

The lights and refrigerator are working and the red light on the plug in is lit.


Sent from my iPad using Forest River Forums

mcnabbwr 09-15-2014 10:13 PM

Quote:

Originally Posted by coldj (Post 702009)
The lights and refrigerator are working and the red light on the plug in is lit.


Sent from my iPad using Forest River Forums

Are they plugged into the same outlet? If not plug a light, fan or other into outlet to verify power. I am assuming its 110v.

VinceU 09-15-2014 10:18 PM

Quote:

Originally Posted by coldj (Post 701998)
My outdoor Jensen TV won't turn on but the power source is on. TV won't turn on remotely or manually. Any thoughts out there!


Sent from my iPad using Forest River Forums

Is it still under warranty? If not you can call and ask tech support if there is a fuse inside the TV cabinet. Otherwise its off to a TV shop, its the power supply, the most failed section of all.

coldj 09-15-2014 10:23 PM

I plugged in my GPS since it has the cigarette lighter type plug in and it worked. TV was working fine the other day. It is still under warranty.


Sent from my iPad using Forest River Forums

bclemens 09-18-2014 04:03 PM

TV is 12V. Sometimes low batteries will not permit the TV to operate. Might just be the power cord too.

coldj 09-19-2014 12:26 PM

Thanks Mr. Clemens. I applaud and admire your participation, help and information you provide for FR. Will check the cord. I do hear something rattling at the plug in end when I shake it. Sounds like something came loose.


Sent from my iPhone using Forest River Forums

bgilly 09-20-2014 09:48 AM

My center tv (bunk area) stopped working. No blue light on the tv so I figured it had to be power related. Investigated and found the inline fuse was loose. I think it is missing the internal spring in the fuse cartridge - there's no pressure on the fuse from the leads and to make it work I have place the fuse holder in such a way to apply enough pressure to make contact.

Bobby

VinceU 09-20-2014 09:53 AM

Replacement in radio shack for a couple bucks. Good invest if bunks are used.


Sent from my iPhone using Forest River Forums


All times are GMT -5. The time now is 11:55 PM.