Reply
 
Thread Tools Display Modes
Old 06-11-2017, 04:52 PM   #1
Senior Member
 
Join Date: Jul 2015
Posts: 113
Question engine on legacy turns off with ? high load

I start my motor home engine and it turns off. I try to start a minute or to later and the panel lights up and it starts. I t runs for a few minutes and if I release the parking brake, or put in gear it stalls? could the engine batteries be low and with the load it shuts off?
I started the motor home this AM and I had the start/stall sequence x3. I then checked to see if the ADS was inverting or charging. I switched to charge and it ran all day until I turned on the air conditioners?
necasperaterrent is offline   Reply With Quote
Old 06-12-2017, 10:36 PM   #2
Senior Member
 
Join Date: Jul 2015
Posts: 113
bump
necasperaterrent is offline   Reply With Quote
Old 06-13-2017, 06:15 PM   #3
Senior Member
 
Join Date: May 2017
Posts: 316
Not much info to work with, it would be useful to know what drivetrain your motorhome has, how many batteries and how old etc.

Very generally speaking, yes a failed battery can make an engine not idle correctly and stall. However then you wouldn't be able to start the engine without a jump, so it could be loose or corroded connections at the battery, starter or alternator.
TheGerman is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



All times are GMT -5. The time now is 05:37 AM.