Reply
 
Thread Tools Display Modes
Old 06-28-2020, 04:48 PM   #1
Senior Member
 
Join Date: Dec 2013
Posts: 440
2102 390BH starting issue

Over the winter I had a slight starting issue- that I assumed was low battery voltage. I would turn the key on- let the glow plugs warm- battery voltage would drop to 11.7-12 volts and when I turned the key to engage the started nothing would happen. So i would turn the key off and then back on right to the starter and it would start fine.
But to day I have the same problem but the voltage was 12.6- 12.7. ( on dash display) and it took several time to get it started ( engine not tuning over).


do you think it could be a simple as a the ignition switch? of off to freightliner?
__________________

__________________
2012 390BH
dave-g is offline   Reply With Quote
Old 06-29-2020, 09:15 AM   #2
Senior Member
 
ceedog's Avatar
 
Join Date: Sep 2013
Posts: 283
Did you try battery boost when the engine wouldn't turn over? If it starts with battery boost, you may need chassis batteries.
__________________

__________________
It ain't easy being me...I've tried.

ceedog is offline   Reply With Quote
Old 07-11-2020, 04:35 AM   #3
Senior Member
 
Join Date: Dec 2013
Posts: 440
2012 39bh



So rv is at freightliner service center- 1st they tell me its a turbo actuator- then the turbo- now they have moved on to the tcm needs to be reprogrammed. I do not have a good feeling.
__________________
2012 390BH
dave-g is offline   Reply With Quote
Old 07-23-2020, 04:25 AM   #4
Senior Member
 
Join Date: Dec 2013
Posts: 440
Well freightliner was correct . It was the tcm.


They put a different tech on it, He found the neutral lock out relay chattering. Wiring was ok- and it gets the signal from the tcm.


New tcm- programing and labor $2500 +, but just took a 600 mile trip and it started every time.
__________________
2012 390BH
dave-g is offline   Reply With Quote
Old 07-23-2020, 11:27 AM   #5
Diesel Rep West Coast
 
Join Date: Apr 2020
Posts: 44
Quote:
Originally Posted by dave-g View Post
Well freightliner was correct . It was the tcm.


They put a different tech on it, He found the neutral lock out relay chattering. Wiring was ok- and it gets the signal from the tcm.


New tcm- programing and labor $2500 +, but just took a 600 mile trip and it started every time.
Good To hear they were able to find the issue...
Eric B FR Diesel is offline   Reply With Quote
Reply

Tags
390bh

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



All times are GMT -5. The time now is 07:30 AM.


×