Reply
 
Thread Tools Display Modes
Old 07-18-2015, 02:52 PM   #1
Senior Member
 
dan-nickie's Avatar
 
Join Date: Feb 2014
Location: Dallas TX
Posts: 1,672
Equalizer Jack Problem on Berkshire

I read pretty much all of the posts that I can on here and typically at least have an idea what to do when something goes wrong but this time I'm stuck.

My Equalizer Jacks are not working. The problem is the keypad panel will not respond to any buttons being pushed. Lights will not light up when button pushed, although the lights will flash when ignition turned on.

This started a few days ago and have already done much troubleshooting, both on my own and with phone support but maybe someone has had a similar issue.

1. Looked for fuses. Only those in the control box found. None blown.
2. Checked voltage at keypad. Voltage good.
3. Jumpered solenoid on pump motor. Motor runs.
4. Changed out keypad. Equalizer sent to me.
5. Changed out control box under floor. Equalizer sent to me.
6. Slides work fine BTW.

Since I have already chased this with help from Equalizer I'm not sure if any of you guys can help but you never know. There is a lot of experience on here.
Maybe I'm just hoping for some sympathy since support is closed on the weekend and we are trying to get out of town.
I knew we should not have cancelled that Goshen trip.

Dan
__________________

__________________
Dan
2014 Berkshire 390RB-60
dan-nickie is offline   Reply With Quote
Old 07-18-2015, 03:09 PM   #2
Senior Member
 
ernest917's Avatar
 
Join Date: Jun 2011
Location: Woodville, Texas
Posts: 2,230
FYI: had issues with mine and after talking with Equalizer tech was told to put a plastic shim between the wires because they are too close together and get too hot... Did that and works great......



Sent from my iPad using Forest River Forums
__________________

ernest917 is offline   Reply With Quote
Old 07-18-2015, 03:41 PM   #3
Senior Member
 
Join Date: Apr 2012
Location: West Michigan/Fort Myers
Posts: 3,927
Dan I have no idea what I could be but I'm here for support. That and 2.25 will get a cup of coffee. Sorry. What the heck no Goshen this year. I just told Dianna and she's not happy either. I guess we will catch up later. Good luck with the jacks.



Phil57 is offline   Reply With Quote
Old 07-18-2015, 03:48 PM   #4
Senior Member
 
dan-nickie's Avatar
 
Join Date: Feb 2014
Location: Dallas TX
Posts: 1,672
Quote:
Originally Posted by ernest917 View Post
FYI: had issues with mine and after talking with Equalizer tech was told to put a plastic shim between the wires because they are too close together and get too hot... Did that and works great......



Sent from my iPad using Forest River Forums
Ernest, I had seen your posts on this in past threads.
I believe our keypads are quite different in the 2014 though.
__________________
Dan
2014 Berkshire 390RB-60
dan-nickie is offline   Reply With Quote
Old 07-18-2015, 03:57 PM   #5
Senior Member
 
dan-nickie's Avatar
 
Join Date: Feb 2014
Location: Dallas TX
Posts: 1,672
Quote:
Originally Posted by Phil57 View Post
Dan I have no idea what I could be but I'm here for support. That and 2.25 will get a cup of coffee. Sorry. What the heck no Goshen this year. I just told Dianna and she's not happy either. I guess we will catch up later. Good luck with the jacks.
We just cancelled a few days ago. We have had some issues with our family that has caused delays. It is so unfortunate as we have been looking forward to it for a year of course. And you know we loved the Michigan area last year too.
Looks like we are just going to go to New Mexico and Colorado end of July and through August for some cooler weather.

And I have been thinking we would not have anything to fix in Goshen. Hah.
We sure will miss all the friends we met last year.
__________________
Dan
2014 Berkshire 390RB-60
dan-nickie is offline   Reply With Quote
Old 07-18-2015, 05:28 PM   #6
Senior Member
 
tmmar's Avatar
 
Join Date: Apr 2008
Location: Long Island (Nassau County), NY
Posts: 4,325
Dan,
We will miss you and Nickie as well. Sorry to hear that you are having family issues that prevents you from attending the rally this year. Also sorry that you are having problems with your leveling system. Hopefully you will be able to get your problem fixed and fixed quickly.
Good luck,
Tom
__________________
Tom and Margaret
2014 Berkshire 390bh-60

tmmar is offline   Reply With Quote
Old 07-18-2015, 05:44 PM   #7
Senior Member
 
dan-nickie's Avatar
 
Join Date: Feb 2014
Location: Dallas TX
Posts: 1,672
Phil and Tom, thanks for taking pity on me.
I'm thinking I may have a low voltage/loose wire someplace that is not getting enough juice to the keypad. Batteries are 12.5 but reading behind keypad reads about 11.6. Equalizer says that's enough voltage but why is it not reading at least 12 since the batteries are up? I'm going to take my little battery jumper power box and hook it direct to the panel for my next test.

We are so ready to get outta here. The 100 degree days start tomorrow and last the rest of the summer.
__________________
Dan
2014 Berkshire 390RB-60
dan-nickie is offline   Reply With Quote
Old 07-18-2015, 05:59 PM   #8
Senior Member
 
Join Date: Nov 2012
Location: Home is where I park it
Posts: 1,503
I don't have anything to add here that might be helpful .....

But having been "in to" mine a couple of times, one thing that always amazed me is that the solenoid which is usually directly attached to the motor, in my unit is just sorta "hanging on by a thread". The only real support that the solenoid has is the wires themselves; nothing more.

Phil, since our coaches are only 6 numbers (or so) apart, I was wondering if you've noticed this strange malady. So far it hasn't caused any problems, but I still marvel that they let the coach out the door with such a flaw.

Boowho??
boowho is offline   Reply With Quote
Old 07-18-2015, 06:47 PM   #9
Senior Member
 
Mmnsc's Avatar
 
Join Date: Sep 2012
Location: Charleston County SC
Posts: 686
Dan
Is your issue that you cannot get the jacks to retract? 2 weeks ago when my controller went out I was able to get the one jack up by turning the screw on end of the solinoid 2 to 2 1/2 turns to the right and then run the hydralic pump by pressing any button to retract and sure enough the jack retracted. Since you said the pump does run you might want to try one solenoid at a time and press one of the slide switch to retract and see if the one jack comes up. If that works do it for the rest of the four solenoids. The first solenoid from the front is the front left jack. I hope this helps and sorry to hear you will not be joining us in Goshen.
Marty


Sent from my iPhone using Forest River Forums
Mmnsc is offline   Reply With Quote
Old 07-18-2015, 07:49 PM   #10
Senior Member
 
dan-nickie's Avatar
 
Join Date: Feb 2014
Location: Dallas TX
Posts: 1,672
Tom, I also read about your issue when you were troubleshooting it.
Mine are in the UP position and none of them will go down.
It seems to be something electronic as the keypad won't light up or respond to pushing buttons.

This first started about a week and half ago as we were going to a local lake.
Picked up at storage and keypad would not respond (they were up).
I messed with them all day Sunday and nothing.
As soon as I got Equalizer on the phone they started working. Typical.

Couple days later I retracted them just fine and took it back to storage.
A week later I go back to storage to have it waxed and the keypad no longer responds.

Talk to Randy at Equalizer which sent me all the parts under warranty but it didn't help.

Tom, before we leave town I am going to print out your posts on the subject and take with me as I expect to get in the same situation at some point.
Oh, you just brought the jack up using the switches and didn't have to use a drill as the pump motor still worked?
__________________
Dan
2014 Berkshire 390RB-60
dan-nickie is offline   Reply With Quote
Old 07-18-2015, 08:19 PM   #11
Senior Member
 
Mmnsc's Avatar
 
Join Date: Sep 2012
Location: Charleston County SC
Posts: 686
Dan
I wrote you the post (Marty MMNSC). I know Tom and I hang out together but there is no mistaking the two of us.

I did NOT have to use the drill since the motor on the pump still works. I hope you get your issues resolved. I have some family tree documents I was hoping to review with Nickie to see if we are distant cousins through the New Orleans ancestry. Oh well, may be next year. Travel safe.


Sent from my iPhone using Forest River Forums
Mmnsc is offline   Reply With Quote
Old 07-18-2015, 09:12 PM   #12
Senior Member
 
dan-nickie's Avatar
 
Join Date: Feb 2014
Location: Dallas TX
Posts: 1,672
OK Marty. I thought you guys were twins as I can't tell who is the most handsome.
Oh gosh, I know Nickie is really going to miss all of you.
She does have some very interesting ancestors.

We are planning on Florida some time Feb-Mar also.
I figure a lot of you will be around there then.
__________________
Dan
2014 Berkshire 390RB-60
dan-nickie is offline   Reply With Quote
Old 07-18-2015, 09:52 PM   #13
Senior Member
 
Join Date: Apr 2012
Location: West Michigan/Fort Myers
Posts: 3,927
Dan we are at Cypress Trail in Fort Myers. If you get any where close lets get together. I know Marty and Tom are at Cypress Trail sometime in Feb but don't remember what week.



Phil57 is offline   Reply With Quote
Old 07-19-2015, 06:53 AM   #14
Senior Member
 
dan-nickie's Avatar
 
Join Date: Feb 2014
Location: Dallas TX
Posts: 1,672
Phil, I knew where you would be. I have seen some pictures of the landscaping and updates you guys were doing before you headed north. Looks like a great place.
So, they do nightly/weekly rentals at Cypress Trail also.
__________________
Dan
2014 Berkshire 390RB-60
dan-nickie is offline   Reply With Quote
Old 07-19-2015, 09:02 AM   #15
Senior Member
 
Join Date: Apr 2012
Location: West Michigan/Fort Myers
Posts: 3,927
Yes they do. Last I heard they were filling up fast but I find that hard to believe. If I remember correctly they added 75 lots over the summer.



Phil57 is offline   Reply With Quote
Old 07-19-2015, 10:07 AM   #16
Senior Member
 
tmmar's Avatar
 
Join Date: Apr 2008
Location: Long Island (Nassau County), NY
Posts: 4,325
Quote:
Originally Posted by dan-nickie View Post
OK Marty. I thought you guys were twins as I can't tell who is the most handsome.
Oh gosh, I know Nickie is really going to miss all of you.
She does have some very interesting ancestors.

We are planning on Florida some time Feb-Mar also.
I figure a lot of you will be around there then.

Dan,
Oh, c'mon! No contest as to who is the most handsome!!

We will be visiting Phil and Dianna at Cypress Trail 2/11-2/18. Why don't you see if you can make it work.
Tom
__________________
Tom and Margaret
2014 Berkshire 390bh-60

tmmar is offline   Reply With Quote
Old 07-19-2015, 11:02 AM   #17
Senior Member
 
accumack's Avatar
 
Join Date: Sep 2011
Posts: 522
On our unit I had similar problem I found the dealer repaired a wire in the plug at the control panel by pushing it in. I took it apart and fixed it properly. It sounds like you may have already check that though.
accumack is offline   Reply With Quote
Old 07-19-2015, 03:27 PM   #18
Senior Member
 
dan-nickie's Avatar
 
Join Date: Feb 2014
Location: Dallas TX
Posts: 1,672
Quote:
Originally Posted by accumack View Post
On our unit I had similar problem I found the dealer repaired a wire in the plug at the control panel by pushing it in. I took it apart and fixed it properly. It sounds like you may have already check that though.
BINGO!
Although you are a couple hours late, that is my issue. I found it this morning.
Mine was in the coach wiring harness that plugs into the control box in the storage bay under the floor.
I haven't figured out how to get the 'pin' out to fix it properly yet.

Thanks for everyone's help and support.

For future reference, there are quite a number of wires to that control box. I would imagine it could cause issues with just one jack also.
__________________
Dan
2014 Berkshire 390RB-60
dan-nickie is offline   Reply With Quote
Old 07-19-2015, 03:38 PM   #19
Senior Member
 
dan-nickie's Avatar
 
Join Date: Feb 2014
Location: Dallas TX
Posts: 1,672
Quote:
Originally Posted by tmmar View Post
Dan,
Oh, c'mon! No contest as to who is the most handsome!!
Of course

We will be visiting Phil and Dianna at Cypress Trail 2/11-2/18. Why don't you see if you can make it work.
Tom
Well, Nickie had told me she wanted to go to the Daytona 500 Speedweeks to kickoff the Florida trip.
I just checked the calendar and sure enough it is Feb 13-21.
So we have some dis-cussing to do.
__________________
Dan
2014 Berkshire 390RB-60
dan-nickie is offline   Reply With Quote
Old 07-19-2015, 05:10 PM   #20
Senior Member
 
accumack's Avatar
 
Join Date: Sep 2011
Posts: 522
If there is a Fry's electronic store near they have the tool and pins.
__________________

accumack is offline   Reply With Quote
Reply

Tags
berkshire, equalizer

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



All times are GMT -5. The time now is 12:00 PM.


×