Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×


Reply
 
Thread Tools Display Modes
Old 09-19-2021, 07:02 PM   #1
Junior Member
 
Join Date: May 2021
Posts: 24
Equalizer System

Has anyone run into the problem where the system beeps excess slope when we are on completely flat ground and then the system does not deploy. I tried "resetting" the system by turning off chassis battery and house batteries but still the system will not deploy. I cannot even deploy the jacks by front or rear. Nothing happens other than the air releasing. The jacks dont deploy. And of course we cannot open the 18 foot side either. Very frustrating. Any suggestions?

Stan Miele
StanNSandi is offline   Reply With Quote
Old 09-19-2021, 07:36 PM   #2
Senior Member
 
Nightshifter's Avatar
 
Join Date: Apr 2019
Location: New Tripoli PA
Posts: 104
Did you check if there is 12 volt going to the hydraulic pump.
__________________
2019 Berkshire XLT 45A
2019 Jeep Rubicon JL
Sold prior to buying the Berkshire
2016 Ford F350 Platnium
2017 Heartland Landmark 365
1989 Winnebago Super Chief
Nightshifter is offline   Reply With Quote
Old 09-19-2021, 07:44 PM   #3
Junior Member
 
Join Date: May 2021
Posts: 24
equalizer

i did check the back area and it appears the 12 volt is going to the pump but i cannot confirm. i need to get my voltage meter out but not exactly sure what to check back there for power to the "pump" itself. There are lot of wires coming in and out. Sadly i am not mechanically inclined whatsoever. thanks for responding.
StanNSandi is offline   Reply With Quote
Old 09-19-2021, 09:10 PM   #4
Senior Member
 
zs325RES's Avatar
 
Join Date: Jan 2013
Location: Byron Center, MI
Posts: 419
Try retract all first so they find ‘home’ then see if they deploy - worked on my 5er with the Equalizer System 6 point setup
__________________
2020 SOB - Jayco North Point 387RDFS
2013 Crusader 325RES Touring Edition - SOLD
TV: 2018 GMC Sierra Denali HD CC SRW L5P Duramax
Curt Q20

zs325RES is offline   Reply With Quote
Old 09-19-2021, 09:19 PM   #5
Senior Member
 
Nightshifter's Avatar
 
Join Date: Apr 2019
Location: New Tripoli PA
Posts: 104
There should ba a resettable circuit breaker for the hydraulic pump in the battery compartment. Try and locate that and see if it is tripped.
Nightshifter is offline   Reply With Quote
Old 09-20-2021, 08:54 AM   #6
Commercial Member
 
Join Date: Nov 2019
Posts: 226
There is fuse for the inside the coach on the Precision Plex panel at the foot of bed for the retract/extend function on the hydraulic pump. It is fuse #FM01 and FM02.Those are 10 amp fuses. There is also a fuse on the pump itself.
Attached Files
File Type: pdf P-PLEX LAYOUT 1.1.pdf (256.6 KB, 31 views)
Lincman983 is offline   Reply With Quote
Reply

Tags
equalizer

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



All times are GMT -5. The time now is 01:22 PM.