RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×


Reply
 
Thread Tools Display Modes
Old 07-10-2014, 06:02 PM   #21
2011 Berkshire 390BH
 
Superchief's Avatar
 
Join Date: Aug 2011
Location: Lancaster, NY
Posts: 1,063
Just thinking out loud here - did you check the valve in the outside water compartment to make sure it was all the way open?


Sent from my iPad using Forest River Forums
__________________
Craig



Finally completed all State visits in August 2011 with a trip to North Dakota.
Superchief is offline   Reply With Quote
Old 07-10-2014, 06:22 PM   #22
Senior Member
 
klucas's Avatar
 
Join Date: Sep 2010
Posts: 376
Quote:
Originally Posted by Superchief View Post
Just thinking out loud here - did you check the valve in the outside water compartment to make sure it was all the way open?


Sent from my iPad using Forest River Forums

Yes sir. Thanks for suggesting.


Sent from my iPhone using Forest River Forums
klucas is offline   Reply With Quote
Old 07-10-2014, 08:40 PM   #23
Senior Member
 
I-RV's Avatar
 
Join Date: Jun 2013
Location: Mount Laurel, NJ
Posts: 1,024
I reported on this earlier. On my 12, my water was so slow that the tankless heater kept shutting down because of over-temp. I measured the flow to be 0.6 gal/ min.

I found a one-way valve at the very end of the spigot hose; the end that attaches to the faucet, way underneath the sink. I do not know the purpose of the valve, but after I got it off, I tried blowing in the flow direction. It took some pressure to overcome the spring in it. This is what robs the flow. After removing it, the flow went up to 1.6 gal/min.

You probably won't recognize the valve. It is silver and barrel shaped, and looks to be part of the hose. Good luck finding it.

Hank
__________________
Gale & Hank- 2012 Berkshire 390BH
I-RV is offline   Reply With Quote
Old 07-10-2014, 08:47 PM   #24
2011 Berkshire 390BH
 
Superchief's Avatar
 
Join Date: Aug 2011
Location: Lancaster, NY
Posts: 1,063
I just replaced the valve assembly ball/handle on mine, as it broke in two. I did notice when I took it out, that there were two O-ring assemblies with springs under it. Here is a Delta schematic of what my faucet looked like. There maybe something plugging one of the holes (3 of them, but only 2 with O-rings). Hope this might help... Craig
Click image for larger version

Name:	ImageUploadedByForest River Forums1405043268.997938.jpg
Views:	113
Size:	255.4 KB
ID:	57892


Sent from my iPad using Forest River Forums
__________________
Craig



Finally completed all State visits in August 2011 with a trip to North Dakota.
Superchief is offline   Reply With Quote
Old 07-11-2014, 06:46 AM   #25
Senior Member
 
klucas's Avatar
 
Join Date: Sep 2010
Posts: 376
Quote:
Originally Posted by I-RV View Post
I reported on this earlier. On my 12, my water was so slow that the tankless heater kept shutting down because of over-temp. I measured the flow to be 0.6 gal/ min.

I found a one-way valve at the very end of the spigot hose; the end that attaches to the faucet, way underneath the sink. I do not know the purpose of the valve, but after I got it off, I tried blowing in the flow direction. It took some pressure to overcome the spring in it. This is what robs the flow. After removing it, the flow went up to 1.6 gal/min.

You probably won't recognize the valve. It is silver and barrel shaped, and looks to be part of the hose. Good luck finding it.

Hank

Click image for larger version

Name:	ImageUploadedByForest River Forums1405079121.285266.jpg
Views:	112
Size:	450.5 KB
ID:	57919

Is this what your referring to? The silver end that attaches to a copper line? In the picture the one higher and a bit hidden.


Sent from my iPhone using Forest River Forums
klucas is offline   Reply With Quote
Old 07-11-2014, 02:39 PM   #26
Senior Member
 
klucas's Avatar
 
Join Date: Sep 2010
Posts: 376
Ok guys. Thank you! It worked. Both ends of that hose has a valve in it. After I removed them both it is much better. No need to replace it now. Thank you all for your input. Ken.


Sent from my iPhone using Forest River Forums
klucas is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



All times are GMT -5. The time now is 07:28 AM.