Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×


Reply
 
Thread Tools Display Modes
Old 03-10-2017, 03:48 PM   #1
Junior Member
 
Join Date: Mar 2017
Posts: 4
Atwood heat pump problems

Bought new FR3 with an attwood heat pump ac. The temperature on the thermostat jumps 10 degrees in 2 minutes and shuts the unit off. The fan then comes on every 2 minutes then compressor starts again for only 2 to 3 minutes. The coach temp is 68 but the unit thinks it's 78. Attwood said this is normal so won't pay for troubleshooting under warranty. Anyone else have this issue?
Rjha11 is offline   Reply With Quote
Old 03-13-2017, 10:34 PM   #2
Senior Member
 
Crockett's Avatar
 
Join Date: Feb 2015
Posts: 847
pop the air filter off the grill and see if there is a divider between the return air and intake air or not. there should be a partition between grill and upper unit, half way back. thought maybe the sensor for temp may be on the upper board and not the thermostat.
Crockett is offline   Reply With Quote
Reply

Tags
pump

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



All times are GMT -5. The time now is 08:37 PM.