Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×


Reply
 
Thread Tools Display Modes
Old 11-04-2020, 01:26 PM   #1
Junior Member
 
Join Date: Aug 2019
Posts: 13
Both AC Not Working

We have a 2014 Forest River Georgetown 360XL. The Dometic AC units have always worked - both the unit above the bedroom and the unit above the living room. (There have been times where a breaker popped or a fuse blew, but I've learned where they are and how to fix them.)

This time NEITHER of the AC units is working. The thermostats look okay. I push the button to set it for "Cool" - the little green light says it should start cooling, but neither the fan nor the compressor comes on.

I have tried it using the generator (with and without the inverter on) and with and without the key in the ignition and with and without the engine on. Then I plugged the RV into 50 amp shore power and tried again. Still Nothing.

I've examined all the breakers in the bedroom, and all the fuses and breakers by the House batteries (under the steps), and the breakers on the Onan 5500 generator. All of them look good.

Does anyone have any ideas?
swolfer is offline   Reply With Quote
Old 11-04-2020, 04:47 PM   #2
Commercial Member
 
ES_FR's Avatar
 
Join Date: May 2018
Posts: 376
Quote:
Originally Posted by swolfer View Post
We have a 2014 Forest River Georgetown 360XL. The Dometic AC units have always worked - both the unit above the bedroom and the unit above the living room. (There have been times where a breaker popped or a fuse blew, but I've learned where they are and how to fix them.)

This time NEITHER of the AC units is working. The thermostats look okay. I push the button to set it for "Cool" - the little green light says it should start cooling, but neither the fan nor the compressor comes on.

I have tried it using the generator (with and without the inverter on) and with and without the key in the ignition and with and without the engine on. Then I plugged the RV into 50 amp shore power and tried again. Still Nothing.

I've examined all the breakers in the bedroom, and all the fuses and breakers by the House batteries (under the steps), and the breakers on the Onan 5500 generator. All of them look good.

Does anyone have any ideas?
swolfer,

We would be happy to assist you with this question regarding your Georgetown's AC units. Please contact Nicholas Hoover in our Customer service department through the following personalized and direct link: https://www.forestriverinc.com/Direc...01051651891928.

This direct link is provided for your convenience in order that we may resolve your concerns as quickly as possible. We will strive to respond to you within 24 hours of receiving your correspondence.

Respectfully,
Forest River
ES_FR is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



All times are GMT -5. The time now is 09:24 PM.