Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×


Reply
 
Thread Tools Display Modes
Old 02-16-2024, 05:24 PM   #1
Junior Member
 
Join Date: Sep 2020
Posts: 23
Dometic refrigerator freezer problem

Have 2016 dometic 110v,gas. On gas it lights fine, then the ignitor comes on again after about a half minute keeps clicking then refrigerator shuts off will not stay on. So far no luck in finding the problem. Thanks for any information.
K Forbes is offline   Reply With Quote
Old 02-16-2024, 05:51 PM   #2
Site Team
 
bikendan's Avatar
 
Join Date: Jan 2007
Location: Goodyear, Arizona
Posts: 34,030
Moved thread from the General Community Discussion section to the Appliances and Electronics sub-forum since the OP's questions are specific to that sub-forum and not general questions.
__________________
Dan-Retired California Firefighter/EMT
Shawn-Musician/Entrepreneur/Wine Expert
and Zoe the Wonder Dog(R.I.P.)
2016 PrimeTime TracerAIR 255, pushing a 2014 Ford F150 SCREW XTR 4x4 3.5 Ecoboost w/Max Tow Package
4pt Equal-i-zer WDH and 1828lbs of payload capacity
bikendan is online now   Reply With Quote
Old 02-16-2024, 07:16 PM   #3
D W
Senior Member
 
D W's Avatar
 
Join Date: Sep 2016
Location: ALASKA (World's Biggest Campground)
Posts: 6,863
Here's a manual for you:
Attached Files
File Type: pdf Dometic Refrig Diagnostics.pdf (2.42 MB, 58 views)
__________________
'07 K3500 Silverado LT Crew Duramax (LBZ)
2016 Salem 27RKSS
1984 CHEV SCOTTSDALE K20 2GCGK24J0E1XXXXXX (Chevrolet Legends-Class of 2019)
"...exhaust fluid? We don't need no stinkin' exhaust fluid"
D W is online now   Reply With Quote
Old 02-16-2024, 08:23 PM   #4
Senior Member
 
Join Date: Apr 2021
Posts: 2,413
Seems that you have gas and ignition but does not stay on. That says lack of airflow via the combustion system. Make sure the trailer is level, left to right, and front to rear. This is very important. Also outside check for insect webs and wasp nests around the combustion tube.

There are LOTS of protection features on these systems. Be thankful they exist, although it makes troubleshooting a bit of a challenge.

The manual as suggested earlier is necessary to have on board.

Bob
Bob K4TAX is online now   Reply With Quote
Old 02-16-2024, 08:39 PM   #5
Senior Member
 
Join Date: Mar 2014
Location: Mountain Foothills of Southern Alberta
Posts: 2,018
Could also be a inoperative thermocouple/flame sensor.
__________________

2007 Surveyor SV230
- 200 Watts Solar/MPPT Controller - 220 AH Battery Bank (Two-GC2) - 600 watt PSW Inverter - (2) 2000 watt Inverter Generators - LED Lighting
2009 F150 - 5.4 Litre with Tow Package

Boon Docking 99% of the time.
boondocking is offline   Reply With Quote
Old 02-17-2024, 03:49 PM   #6
Senior Member
 
Join Date: Apr 2017
Location: 8300 Feet - Rocky Mountains
Posts: 2,496
Supporting Bob's comment.
The burner tubes on gas appliances are ideal places for spiders and other bugs.
It's a very easy job to clean the burner tube.


This isn't all there is to it, but the burner tube is a great place to start.
__________________
Jim & Renee
2020 Jayco Jay Feather X-213
previously 2014 Forest River/Rockwood HW 277
2006 Ram 1500 4WD Crew with Firestone Airbags
Every weekend boondocking in the National Forests or at Lake Vallecito.
jimmoore13 is offline   Reply With Quote
Old 02-17-2024, 04:03 PM   #7
Senior Member
 
rracer5's Avatar
 
Join Date: Jan 2011
Location: Part Timing It Now
Posts: 3,465
Quote:
Originally Posted by K Forbes View Post
Have 2016 dometic 110v,gas. On gas it lights fine, then the ignitor comes on again after about a half minute keeps clicking then refrigerator shuts off will not stay on. So far no luck in finding the problem. Thanks for any information.

Sounds like the flame is going out and the igniter keeps trying to light the burner (3 cycles before shutting system down). Sounds like the gas is being interrupted (gas valve, 12volts). I would have the 12v feed & propane flow checked. Something is sending a signal to shut off the gas valve. I believe if there were and obstruction in the venture tube (insect web or nest) then you wouldn't even get the initial startup. The thermocouple which is located in the chimney flew, if tripped, would shut off ALL power to the refrigerator until the thermocouple is either replaced or reset (similar to a resettable circuit breaker) so, I doubt that is the issue.
__________________
"PT Crew Members Since 9/2010"
2011 RAM 2500 HD 6.7L CTD Crew
2014 Prime Time Sanibel 3250
rracer5 is offline   Reply With Quote
Old 02-17-2024, 05:51 PM   #8
Senior Member
 
Join Date: Mar 2014
Location: Mountain Foothills of Southern Alberta
Posts: 2,018
Quote:
Originally Posted by rracer5 View Post
Sounds like the flame is going out and the igniter keeps trying to light the burner (3 cycles before shutting system down). Sounds like the gas is being interrupted (gas valve, 12volts). I would have the 12v feed & propane flow checked. Something is sending a signal to shut off the gas valve. I believe if there were and obstruction in the venture tube (insect web or nest) then you wouldn't even get the initial startup. The thermocouple which is located in the chimney flew, if tripped, would shut off ALL power to the refrigerator until the thermocouple is either replaced or reset (similar to a resettable circuit breaker) so, I doubt that is the issue.
You are right about the thermocouple.
I meant spark electrode/flame sensor not thermocouple/flame sensor.
__________________

2007 Surveyor SV230
- 200 Watts Solar/MPPT Controller - 220 AH Battery Bank (Two-GC2) - 600 watt PSW Inverter - (2) 2000 watt Inverter Generators - LED Lighting
2009 F150 - 5.4 Litre with Tow Package

Boon Docking 99% of the time.
boondocking is offline   Reply With Quote
Old 02-17-2024, 05:59 PM   #9
Senior Member
 
Join Date: Sep 2007
Location: In the snow belt
Posts: 430
Does your furnace, stove and hot water tank function correctly? If not then you could have a bad primary propane regulator. Just something else to check.
Odyknuck is online now   Reply With Quote
Old 02-17-2024, 09:00 PM   #10
Senior Member
 
Join Date: Sep 2013
Location: Colorado
Posts: 176
I've had this exact problem a few times so I will tell you what I did to fix. Remove a few screws and take out the sheet metal shield around the burner. The very end of the (my) burner tube is drilled with some tiny holes. I had fine debris and rust accumulate in there, which allowed the gas to ignite but the gas also started to aerosol the fine particles which then plugged up the fire holes which prevented the flame from running long enough to activate the thermocouples. (Whew, that's a long sentence!) Anyway, I removed the burner tube, knocked out the fine rust particles, reassembled, and resolved my problem. Takes 10 minutes. I hope this is your fix too.
metalsideup is offline   Reply With Quote
Old 02-19-2024, 11:07 AM   #11
Junior Member
 
Join Date: Sep 2020
Posts: 23
Thumbs up Dometic problem solved for now

Ok so here is what I did about the problem. I plugged my RV to shore power turned on refrigerator for about ten minutes, then turned refrigerator to gas and to my amazement it has stayed on and is working fine. I cycled it several times from 110v to gas and is working perfectly. The reply about cleaning the flame manifold makes sense so Iím going to do that. Thanks for all of the replies.
K Forbes is offline   Reply With Quote
Old 02-19-2024, 11:11 AM   #12
Senior Member
 
rracer5's Avatar
 
Join Date: Jan 2011
Location: Part Timing It Now
Posts: 3,465
Quote:
Originally Posted by K Forbes View Post
Ok so here is what I did about the problem. I plugged my RV to shore power turned on refrigerator for about ten minutes, then turned refrigerator to gas and to my amazement it has stayed on and is working fine. I cycled it several times from 110v to gas and is working perfectly. The reply about cleaning the flame manifold makes sense so Iím going to do that. Thanks for all of the replies.

Thanks for returning and letting us know you got it working. That's how we all learn and know that our suggestions work.
__________________
"PT Crew Members Since 9/2010"
2011 RAM 2500 HD 6.7L CTD Crew
2014 Prime Time Sanibel 3250
rracer5 is offline   Reply With Quote
Old 02-22-2024, 05:17 PM   #13
Junior Member
 
Join Date: Feb 2024
Posts: 3
I am having this same problem

Hello All,
Sorry I don't mean to hijack this thread.
I am having this same issue with my dometic rm1350.
Runs fine on shore power and generator.
When I try to run is on gas(LP) it will ignite and run for 1 minute then shut off, it does not try to relite. I have done extensive trouble shooting and replaced the thermocouple and boiler housing thermo switch.
Neither has helped still same problem.
I am convinced the rm1350 circuit board is shot however I can not find a replacement.
My board has 12 posts and all the replacements i find have 7-10 not 12.
I did find 2 on ebay with the exact pic of my board and ordered them only to find out it was a scam, GodBless paypal.
Here is a pic of my board.
If anyone can help me out I would be forever in your dept.
Thank you paul Smyth.
Attached Thumbnails
Click image for larger version

Name:	dads RM1350 3851005029 circuit board.jpg
Views:	26
Size:	534.6 KB
ID:	297185  
Whyspir is offline   Reply With Quote
Old 02-22-2024, 10:33 PM   #14
Junior Member
 
Join Date: Sep 2020
Posts: 23
Dometic referator

Quote:
Originally Posted by Whyspir View Post
Hello All,
Sorry I don't mean to hijack this thread.
I am having this same issue with my dometic rm1350.
Runs fine on shore power and generator.
When I try to run is on gas(LP) it will ignite and run for 1 minute then shut off, it does not try to relite. I have done extensive trouble shooting and replaced the thermocouple and boiler housing thermo switch.
Neither has helped still same problem.
I am convinced the rm1350 circuit board is shot however I can not find a replacement.
My board has 12 posts and all the replacements i find have 7-10 not 12.
I did find 2 on ebay with the exact pic of my board and ordered them only to find out it was a scam, GodBless paypal.
Here is a pic of my board.
If anyone can help me out I would be forever in your dept.
Thank you paul Smyth.
Ok check your flame manifold for a healthy blue flame it may be dirtied up. Clear it good check for nice blue flame. Also Dometic will email you a service manual if you call them.
Good luck.Ken
K Forbes is offline   Reply With Quote
Old 02-23-2024, 08:26 AM   #15
Junior Member
 
Join Date: Feb 2024
Posts: 3
Thank You for taking the time Ken,
Sorry I did not post all details. I do have the Dometic service manual.
Here is a link if anyone needs. https://bryantrv.com/docs2/docs/Serv...,%20RM1350.pdf

I have already checked and cleaned the burner tube also checked and cleaned flu pipe also removed and checked roof vent.
Frige runs well on all other sources, Once I switch to Gas(lp) it runs for almost exactly 1 minute perfectly fine then I can hear the gas valve shut and flame goes out.
What I am really looking for now is a new control board. I have already replaced the eyebrow board that did not change anything.
I have spoken with dometic and they have told me that the RM1350 Power circuit board is unavailable.
I have spoken with Dinasaur electric (They make replacement boards) and they have told me that is one of the only boards they cannot replace or rebuild.
I am kind of up the creek without a paddle.
At this point I was hoping somebody had a trick or some backyard knowledge.
I would even just buy a new refrigerator at this point. however, it will not fit out the door. Iam told the only way to do that is by removing the front windshield.
Once again Thank you for reading and taking the time to reply.
Paul Smyth
Whyspir is offline   Reply With Quote
Old 02-23-2024, 10:30 AM   #16
Junior Member
 
Join Date: Sep 2020
Posts: 23
Bummer. The only other thing I can think of is getting your parts out of some wreck. There must be RV junkyards.How about the gas regulator?
K Forbes is offline   Reply With Quote
Old 02-23-2024, 07:31 PM   #17
Junior Member
 
Join Date: Feb 2024
Posts: 3
Thank you once Again for taking the time to reply.
As it stands now I have exausted all research on the internet.
Dometic was no help at all... Sorry for your luck but you did get 14 years out of it, time for a new one lol.
I refuse to stop there... the refrigerator works great on shore power.
Did not think of RV junkyard Thank you for this suggestion.
Now time to find one in central florida. 8)~
Whyspir is offline   Reply With Quote
Reply

Tags
dometic, refrigerator

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



All times are GMT -5. The time now is 08:40 PM.