Reply
 
Thread Tools Display Modes
Old 11-07-2018, 11:38 PM   #1
Junior Member
 
Join Date: Sep 2017
Posts: 12
Dometic refrigerator Inop

Hi Guys, I have a Dometic DMR702 fridge. It has stopped working. The control board functions normal. The power, 120volt, and 12volt shows normal on the back. When propane is selected on the control board it lights off normal. No cooling on either propane or electric. The gas tubes on top warm up and the cooling fans come on like normal. but the lower gas tubes do not heat up. The fridge is 1 year old and has been plugged into AC most of its life. There are no code via flashing lights shown on the control panel. Have not checked the fuse on the power circuit board on the back yet. Does anybody know what the part number is for the power circuit board on the back?
Thanks John
John24RLS is offline   Reply With Quote
Old 11-08-2018, 08:08 AM   #2
Senior Member
 
Join Date: Feb 2015
Posts: 707
If it lights up and stays lit then nothing is wrong with the board. How long has it been running before you checked the temp? If the freezer getting cold at all?
__________________
2019.5 Rockwood 2509S
Toddupton is offline   Reply With Quote
Old 11-08-2018, 08:21 AM   #3
Site Team
 
Flybob's Avatar
 
Join Date: Oct 2014
Posts: 11,839
Quote:
Originally Posted by John24RLS View Post
The fridge is 1 year old and has been plugged into AC most of its life.



Are you saying the fridge has been running continually for a year?
__________________

2015 Freedom Express 248RBS
TV 2015 Silverado HD2500 Duramax
TST Tire Monitors
Honda 2000I + Companion
2 100W solar panels
Flybob is offline   Reply With Quote
Old 11-08-2018, 09:23 AM   #4
Junior Member
 
Join Date: Sep 2017
Posts: 12
Quote:
Originally Posted by Toddupton View Post
If it lights up and stays lit then nothing is wrong with the board. How long has it been running before you checked the temp? If the freezer getting cold at all?
Neither the freezer or the fridge is getting cold.
It has been running at least a week before checking late yesterday evening to find I had a problem.
Yes, been running continually for a year.

I want to go camping thanksgiving week so donít have time to take to a dealer. If I can figure out the problem will repair myself. Itís a 2017 model.
John24RLS is offline   Reply With Quote
Old 11-08-2018, 09:28 AM   #5
Senior Member
 
Join Date: Jul 2017
Posts: 2,363
Quote:
Originally Posted by John24RLS View Post
Neither the freezer or the fridge is getting cold.
It has been running at least a week before checking late yesterday evening to find I had a problem.
Yes, been running continually for a year.

I want to go camping thanksgiving week so donít have time to take to a dealer. If I can figure out the problem will repair myself. Itís a 2017 model.
do you or did you have an ammonia smell. do you see and yellow staining in the back piping ? if not shut off let the boiler cool down and try again .
MR.M is offline   Reply With Quote
Old 11-08-2018, 09:34 AM   #6
Junior Member
 
Join Date: Sep 2017
Posts: 12
Quote:
Originally Posted by MR.M View Post
do you or did you have an ammonia smell. do you see and yellow staining in the back piping ? if not shut off let the boiler cool down and try again .
I’m at work till late afternoon today. Didn’t smell ammonia last night. Turned it off last night, will try it again this afternoon. Will check for yellow staining this afternoon.
What is the fuse for on the rear electric control module?

Thanks
John24RLS is offline   Reply With Quote
Old 11-08-2018, 09:35 AM   #7
Head Rambler
 
Join Date: Mar 2008
Location: Southwest Alabama
Posts: 8,402
It's sounding like the cooling system has leaked, but Mr.M has a good idea of shutting it off for a day and restarting it to see if it will start back.

How level is the RV?
__________________
Salem 29RKSS Pushing a GMC Sierra 2500HD!
Gotta go campin!
Bama Rambler is offline   Reply With Quote
Old 11-08-2018, 09:56 AM   #8
Pickin', Campin', Mason
 
5picker's Avatar
 
Join Date: Aug 2015
Location: South Western PA
Posts: 12,720
Quote:
Originally Posted by John24RLS View Post
I’m at work till late afternoon today. Didn’t smell ammonia last night. Turned it off last night, will try it again this afternoon. Will check for yellow staining this afternoon.
What is the fuse for on the rear electric control module?

Thanks
There should be a couple of fuses... one a 5a automotive blade type fuse for the 12v side of things and a glass tube type fuse for the 120v side of things. You can check them both with a multimeter.
__________________
_________________________________________
2016 Flagstaff 8529IKBS Diamond Package 5th Wheel-Goodyear Endurance Tires
2017 Ford F-Series SCREW 4x4 - Factory Puck B&W Companion
TST Tire Monitor w/Repeater - Sinemate 3500w Gen.

Days Camped: '17=30 '18=51 '19=58 '20=98
5picker is online now   Reply With Quote
Old 11-08-2018, 10:00 AM   #9
Junior Member
 
Join Date: Sep 2017
Posts: 12
Quote:
Originally Posted by Bama Rambler View Post
It's sounding like the cooling system has leaked, but Mr.M has a good idea of shutting it off for a day and restarting it to see if it will start back.

How level is the RV?
It is pretty level. Bubble inside the lines on the four cardinal headings.

Iím going to check the fuses this afternoon.
John24RLS is offline   Reply With Quote
Old 11-08-2018, 10:07 AM   #10
Pickin', Campin', Mason
 
5picker's Avatar
 
Join Date: Aug 2015
Location: South Western PA
Posts: 12,720
Were the tubes warm on electric operation before you switched to LP?
If so, the fuses are fine.

I think you have a bad cooling unit.

If the flue and some of the tubes get warm in both modes of operation but the refrigerator doesn't cool, it likely went bad.
__________________
_________________________________________
2016 Flagstaff 8529IKBS Diamond Package 5th Wheel-Goodyear Endurance Tires
2017 Ford F-Series SCREW 4x4 - Factory Puck B&W Companion
TST Tire Monitor w/Repeater - Sinemate 3500w Gen.

Days Camped: '17=30 '18=51 '19=58 '20=98
5picker is online now   Reply With Quote
Old 11-08-2018, 10:13 AM   #11
Senior Member
 
Join Date: Jul 2017
Posts: 2,363
Quote:
Originally Posted by John24RLS View Post
Iím at work till late afternoon today. Didnít smell ammonia last night. Turned it off last night, will try it again this afternoon. Will check for yellow staining this afternoon.
What is the fuse for on the rear electric control module?

Thanks
there are several fuses . but if it had power and was heating and the upper control panel is on then the fuses are ok . sometimes these unit will get a bubble that stops flow and b y shutting it down it allows the bubble to be absorbed and will start flowing again , not the first time i've seen this happen .
MR.M is offline   Reply With Quote
Old 11-08-2018, 10:02 PM   #12
Junior Member
 
Join Date: Sep 2017
Posts: 12
Thumbs up

Quote:
Originally Posted by 5picker View Post
Were the tubes warm on electric operation before you switched to LP?
If so, the fuses are fine.

I think you have a bad cooling unit.

If the flue and some of the tubes get warm in both modes of operation but the refrigerator doesn't cool, it likely went bad.
5picker was right, mystery solved. Ammonia leak was behind the burner can. The
fridge was under warranty. Called the dealer that installed it about one year ago and he agreed to file a warranty claim with Dometic. Hopefully they will send a new unit. See picks below of the leak area.
Thanks for all your help.
Attached Thumbnails
Click image for larger version

Name:	IMG_4052.jpg
Views:	160
Size:	332.3 KB
ID:	191022   Click image for larger version

Name:	IMG_4057 2.jpg
Views:	163
Size:	348.4 KB
ID:	191023   Click image for larger version

Name:	IMG_4058 2.jpg
Views:	157
Size:	274.0 KB
ID:	191024  
John24RLS is offline   Reply With Quote
Old 11-08-2018, 11:30 PM   #13
Pickin', Campin', Mason
 
5picker's Avatar
 
Join Date: Aug 2015
Location: South Western PA
Posts: 12,720
Well it stinks (literally) that it went bad but glad to hear you have warranty.

Best of luck going forward.
__________________
_________________________________________
2016 Flagstaff 8529IKBS Diamond Package 5th Wheel-Goodyear Endurance Tires
2017 Ford F-Series SCREW 4x4 - Factory Puck B&W Companion
TST Tire Monitor w/Repeater - Sinemate 3500w Gen.

Days Camped: '17=30 '18=51 '19=58 '20=98
5picker is online now   Reply With Quote
Old 11-09-2018, 09:13 AM   #14
Senior Member
 
Join Date: Jul 2017
Posts: 2,363
Quote:
Originally Posted by John24RLS View Post
5picker was right, mystery solved. Ammonia leak was behind the burner can. The
fridge was under warranty. Called the dealer that installed it about one year ago and he agreed to file a warranty claim with Dometic. Hopefully they will send a new unit. See picks below of the leak area.
Thanks for all your help.
That a good picture of the remnants of a leak. I'm sure dometic will send a new cooling unit
MR.M is offline   Reply With Quote
Reply

Tags
refrigerator

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



All times are GMT -5. The time now is 09:15 AM.