Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×


Reply
 
Thread Tools Display Modes
Old 09-22-2021, 09:31 AM   #1
Junior Member
 
Join Date: Sep 2021
Posts: 3
"Drive" media center having issues

Not sure of a model number, but we recently started having issues with the "Drive" media center in our Wildwood. I would have posted a pic, but it is 2 hours away right now.

The first issue noticed was that the sound when playing a DVD (in the unit) was crackling. It seemed to get worse until now where the only sound coming out is static. Sound in all other modes seems to work fine. Tried reset with no change.

Twice this past weekend the unit froze and required reset. Once while connected to Bluetooth it repeated a single tone until reset even after cycling through the modes.

I purchased an iRV31 unit last night on an auction website in case I need to replace the unit entirely.

Anyone know of a fix for the current unit, or have experience swapping them?

I did notice that the screw heads on the current unit are "tamper-proof" with a triangular tool needed.

Also, I don't believe that we have a subwoofer hooked up now, but I would like to install one. Any advice on where to get one and how to run the wiring?
__________________
Started camping in 2020 with a pop-up...that was way too much work to be called recreation!

2017 Wildwood 261BHXL

2021 Ford F-150 XLT
kpipe is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



All times are GMT -5. The time now is 10:32 PM.