Reply
 
Thread Tools Display Modes
Old 09-12-2020, 07:42 AM   #1
Junior Member
 
Join Date: Sep 2020
Posts: 2
Furnace

Turned my furnace on for the first time this year and the fuse immediately blew. This is a two year old camper. Anyone have insight to the possible problem?
Don8 is offline   Reply With Quote
Old 09-12-2020, 08:13 AM   #2
Senior Member
 
Join Date: Mar 2015
Location: Frederica DE
Posts: 1,202
First guess is hot wire is shorted to ground. Quite vague I know, but follow wire likely to be red see if its rubbed though somewhere or pinched. Trying not to move wire too much.
__________________

2016 Ford F250 XLT 4X4 6.2L
2015 Rockwood Signature Ultralite 8329SS
Hensley Arrow
uhduh camping is offline   Reply With Quote
Old 09-12-2020, 09:09 AM   #3
Junior Member
 
Join Date: Sep 2020
Posts: 2
Thanks!
Don8 is offline   Reply With Quote
Old 09-13-2020, 10:45 AM   #4
Senior Member
 
Join Date: Sep 2017
Posts: 117
Maybe fan stuck
loyda is offline   Reply With Quote
Old 09-21-2020, 01:14 AM   #5
Junior Member
 
Join Date: Jul 2019
Posts: 21
Not sure if this is the right place to ask this. All of a sudden when I set the Dometic thermostat to heat the AC blows air not necessarily cold but heat does come on but does not blow at normal force and now can Not select heat on Tstat. AC setting works fine
Is this a replace the Tstat issue or something more serious. My rig is a 2019 Forest River Salem Cruise Lite.
TomatoMan is offline   Reply With Quote
Reply

Tags
furnace

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



All times are GMT -5. The time now is 07:59 PM.