Reply
 
Thread Tools Display Modes
Old 10-09-2018, 05:50 PM   #1
Member
 
Join Date: Aug 2018
Posts: 42
Light not lit on outside power-outlet cover

The light on on this cover is not lit. There is power inside the trailer. Is there something I should check to make sure I'm getting the proper amperage? I checked the fuse box and nothing was tripped. I didn't check all the small fuses though. I've attached a pic. Any help would be greatly appreciated.

Thanks
Attached Thumbnails
Click image for larger version

Name:	IMG_4699.jpg
Views:	74
Size:	314.3 KB
ID:	188750  
RooMan183 is offline   Reply With Quote
Old 10-09-2018, 05:59 PM   #2
Senior Member
 
Join Date: Feb 2015
Posts: 707
Those lights go out all the time. Sometimes they will come back on and sometimes not. Just ignore it not telling you anything is wrong with your power.
__________________
2019.5 Rockwood 2509S
Toddupton is offline   Reply With Quote
Old 10-09-2018, 06:02 PM   #3
Site Team
 
Mr. Dan's Avatar
 
Join Date: Mar 2014
Location: Grayson County, Texas
Posts: 14,921
Quote:
Originally Posted by Toddupton View Post
Those lights go out all the time. Sometimes they will come back on and sometimes not. Just ignore it not telling you anything is wrong with your power.
You should appreciate this help. It is spot on.
__________________
SEARCH is your friend!
FR Wildcat 295RSX / GMC Sierra

Nights Camped: '13 = 49/'14 = 74/'15 = 74/'16 = 85/'17 = 110/'18 = 111/'19 = 86/'20 = 94; booked = 14
Mr. Dan is online now   Reply With Quote
Old 10-09-2018, 09:27 PM   #4
Senior Member
 
Mch5jdm's Avatar
 
Join Date: Feb 2018
Location: US
Posts: 371
I was wondering the same. Worked fine at first then suddenly stopped.
__________________
Letís go camping!
Mch5jdm is offline   Reply With Quote
Old 10-09-2018, 09:33 PM   #5
Pickin', Campin', Mason
 
5picker's Avatar
 
Join Date: Aug 2015
Location: South Western PA
Posts: 12,740
There are lots of reports here of the light failing. Some had the port replaced under warranty only to have it fail again in a few months.

Someone took their's apart to try and fix it but didn't have much luck.

Mine failed at about 10 months.
Never worried about it.
__________________
_________________________________________
2016 Flagstaff 8529IKBS Diamond Package 5th Wheel-Goodyear Endurance Tires
2017 Ford F-Series SCREW 4x4 - Factory Puck B&W Companion
TST Tire Monitor w/Repeater - Sinemate 3500w Gen.

Days Camped: '17=30 '18=51 '19=58 '20=98
5picker is offline   Reply With Quote
Old 10-09-2018, 11:21 PM   #6
Member
 
immecor's Avatar
 
Join Date: Aug 2017
Posts: 80
Yeah mine went out as well after the first couple trips. Had it replaced under warranty. They put a new type on with a half moon light and has been good for about a year so far.
__________________
2017 RW 2304DS
2011 Expedition w/HD tow package
immecor is offline   Reply With Quote
Old 10-10-2018, 05:34 AM   #7
NH Maple Maker
 
russhd1997's Avatar
 
Join Date: Aug 2017
Location: Loudon, New Hampshire
Posts: 395
Quote:
Originally Posted by Toddupton View Post
Those lights go out all the time. Sometimes they will come back on and sometimes not. Just ignore it not telling you anything is wrong with your power.
Mine does the same, sometimes it works and sometimes it doesn't. As long as you've got power inside the camper it's nothing to worry about. The lights at the plug stopped working on mine too.
__________________
Russ

2014 V Cross VIBE 822VRBS

2017 Silverado 1500 crew cab 4x4
russhd1997 is offline   Reply With Quote
Old 10-10-2018, 06:38 AM   #8
Senior Member
 
Join Date: Jul 2010
Location: Waynesville
Posts: 14,236
Our Factory power inlet receptacle is White and has no light, our Factory power cord is Yellow and has a LED light that" works" molded into the Screw Thread end! The newer power supply Receptacle box's and cords are Black and have LED indicator Light issue's,! Youroo! !
__________________
youroo is offline   Reply With Quote
Old 10-10-2018, 06:58 AM   #9
Senior Member
 
jeff64's Avatar
 
Join Date: Mar 2015
Location: N. Illinois
Posts: 1,609
Mine hasn't worked for a long time. No Biggie!
__________________
2016 Flagstaff 27VRL Emerald
14K Equalizer
2020 Silverado 2500HD CC 4X4 6.6L gas 3.73
jeff64 is offline   Reply With Quote
Old 10-10-2018, 07:41 AM   #10
Senior Member
 
Bill and Gail's Avatar
 
Join Date: Jul 2016
Location: NJ
Posts: 450
Mine went out after 1 year. Everything was working, so I just ignored it. It's still out for over a year now.
Bill and Gail is offline   Reply With Quote
Old 10-10-2018, 12:38 PM   #11
StlClay
 
Join Date: Apr 2015
Posts: 117
I was really excited to see this and hoped that I would finally get the answer to the same problem that the writer had. Reluctantly I have the same problem and don’t pay any attention to it
__________________

2014 MiniLite with
Nissan Frontier
Stlcaly is offline   Reply With Quote
Old 10-10-2018, 12:48 PM   #12
Senior Member
 
mudman2's Avatar
 
Join Date: Jan 2015
Location: S Florida
Posts: 287
Quote:
Originally Posted by Stlcaly View Post
I was really excited to see this and hoped that I would finally get the answer to the same problem that the writer had. Reluctantly I have the same problem and donít pay any attention to it
X2
__________________
2019 microlite 25bds
2015 tundra
mudman2 is offline   Reply With Quote
Old 10-10-2018, 01:10 PM   #13
Senior Member
 
rlh1957's Avatar
 
Join Date: May 2017
Location: Southeast
Posts: 1,047
These Furrion power led lights go out quite common. On one unit it went out, Furrion sent a replacement and said they go out. Replacement lasted about 3 months before going out. No problem. Just an indicator led. Not replaceable.
Got a new rig now... that Furrion indicator light lasted 6 months, then dark.
I dont even worry about it.
__________________
2018 Forest River Rockwood Roo
24WS

2019 Ford SD F-350 SRW Lariat
Tow & Gooseneck Prep
FX4 Off Road (4X4)
rlh1957 is offline   Reply With Quote
Old 10-10-2018, 01:28 PM   #14
Senior Member
 
NorSnrub's Avatar
 
Join Date: Aug 2012
Posts: 330
My power cord had 2 they both failed. Still works just look inside an see if tv, microwave, or anything else comes on.
NorSnrub is offline   Reply With Quote
Old 10-10-2018, 02:59 PM   #15
Senior Member
 
Join Date: Jun 2018
Posts: 247
Well it SHOULD work....

Our Rockwood 8311 is 3 months old and the light quit. Just because it happens to everyone, doesn't make it right. I'm planning on getting a replacement under warranty. If enough people complain maybe they'll start supplying a decent one. Just MHO.
Chazman is offline   Reply With Quote
Old 10-11-2018, 02:36 PM   #16
AKA: 'tiredTeacher
 
awellis3's Avatar
 
Join Date: Jan 2013
Location: Richmond, Virginia
Posts: 950
Quote:
Originally Posted by NorSnrub View Post
...just look inside an see if tv, microwave, or anything else comes on.
Or listen for the microwave to go "beep."
__________________
Wright and Penny
(with Fitz and Lizzie, the camping kitties)
Richmond, Va.
2010 Tundra 4X4 5.7L V8
2014 Rockwood 2604WS
Life is a cruel teacher. She gives the test first; the lesson then follows.
awellis3 is offline   Reply With Quote
Old 10-11-2018, 02:47 PM   #17
Senior Member
 
Ejs4029's Avatar
 
Join Date: Apr 2015
Location: Denver, NC
Posts: 1,477
Quote:
Originally Posted by jeff64 View Post
Mine hasn't worked for a long time. No Biggie!
X2.....Mine quit working
__________________
2015 Ram 2500 CTD,CC,SB,4x4
2016 Rockwood 2703 Emerald Edition
Husky CenterLine TS Hitch
TST 507 TPMS
Progressive Industries EMS-PT30C
Ejs4029 is offline   Reply With Quote
Reply

Tags
cover, light, power

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



All times are GMT -5. The time now is 04:43 PM.