Reply
 
Thread Tools Display Modes
Old 02-21-2017, 03:14 PM   #1
Junior Member
 
Join Date: Feb 2017
Posts: 1
Water Heater wont stay lit Suburban SW6DE

I've searched the forum but cant seem to find a solution to the problem so any help, advice or direction would be greatly appreciated.

2016 R Pod 178 with an Airexcel Suburban SW6DE (6gal Water heater with DSI)

DSI fault light is on- the DIS will spark and the gas valve will open and will light and burn for a few seconds (5-6) but will go out-
This will happen 3 times until it goes into lockout- Resetting the unit (rocker switch off for 10 seconds) will allow it to repeat this cycle indefinitely

My sense is that the thermocouple is dead as everything else seems to function correctly. I don't see a typical thermocouple on this unit so I'm confused what is actually sensing that the flame is lit, any ideas? I guess the spark mechanism is also functioning as the thermocouple? If so is there a way to test it instead of buying parts in hopes that it will fix it?

Or is there something else on this heater that senses the flame / burner being lit that I'm missing.
YellowBlackbird is offline   Reply With Quote
Reply

Tags
heater, suburban, water, water heater

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



All times are GMT -5. The time now is 10:21 PM.