Reply
 
Thread Tools Display Modes
Old 10-13-2019, 12:55 PM   #1
Member
 
Join Date: Sep 2017
Posts: 31
Hopkins Insight Trouble

Hello All! Iím on my second Hopkins Insight Brake Controller. Loved the first one. Worked great but left it on the truck when I sold it. So bought another off Amazon (way cheaper than retailers) but with this one it applies the same braking force (which in my opinion is about 40% of maximum) no matter what gain setting I have it on or what percentage setting I set it at. At 99% and on setting 7 it barely grabs. My trailer brakes are auto adjustable and the brakes grabbed just fine with the older controller. Anyone else had this same issue with the Insight brake controller?
Jercole is offline   Reply With Quote
Old 10-13-2019, 01:01 PM   #2
Senior Member
 
RSchleder's Avatar
 
Join Date: Apr 2014
Location: Iowa
Posts: 1,413
Sounds like it's defective. I'd return it for a replacement or your money back if it were me.
__________________
Days camping (2016)----181 days
Days camping (2017) --- 82 days
2016 Wildcat MAXX 28RKX (33' TT), 2007 13' Scamp
2015 Ram Laramie Hemi, w/air suspension
30 years RV'ing
11 different RV's
RSchleder is offline   Reply With Quote
Old 10-13-2019, 03:30 PM   #3
Member
 
Join Date: Sep 2017
Posts: 31
Quote:
Originally Posted by RSchleder View Post
Sounds like it's defective. I'd return it for a replacement or your money back if it were me.
I was thinking the same. I put an email into Hopkins but it’s the weekend. We’re on a trip at Lake Seminole as we speak. Luckily South Georgia is flat and rural. I just went to a local AutoZone where they had an Insight Controller but wanted $149! I got mine on Amazon for a third of that. And they’re listed for even less now at $45! I’ll wait till I get back home and order it.
Jercole is offline   Reply With Quote
Old 10-14-2019, 04:38 PM   #4
Member
 
Join Date: Sep 2017
Posts: 31
Think I figured it out. I had an 02 Suburban before I bought this 06. In the 02 the red wire on the Hopkins brake controller adapter went in slot A. So I assumed the same for the 06. But it didn’t work properly when I first hooked up the brake controller to the 06. I called Hopkins support and they said 03-07 GM models the red wire needed to go into slot D on the adapter. So I changed it. Hopkins says by putting the red wire into slot A the first time it probably damaged the unit. They’re sending a new one at no cost. Very nice people.
Jercole is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



All times are GMT -5. The time now is 03:58 PM.