Reply
 
Thread Tools Display Modes
Old 05-07-2020, 01:15 AM   #1
Junior Member
 
Join Date: Mar 2020
Location: California
Posts: 21
Trickle charger does not work

I installed an RVI trickle charger in my toad to maintain the battery while flat towing. I have an RVI3 brake system installed as well. I was planning on hooking the trickle charger to the brake monitoring pin or the auxiliary power pin at the seven pin harness at the motorhome. However neither pin shows 12V when combined with the ground pin on the harness. I am using the other pins on the harness to control the brakes, turn signals, and lights on the toad.

Any ideas why the brake monitoring pin for the auxiliary pin is not providing a charge?

planning on towing 2009 Subaru Forester
__________________
2020 Sunseeker 2500TS Ford (sold!)
2020 Ram 3500 Laramie
2020 Pinecrest 305
TandM is offline   Reply With Quote
Old 05-07-2020, 10:05 AM   #2
Senior Member
 
Join Date: Jul 2017
Location: North of Seattle, WA
Posts: 9,320
Blown fuse? Blown fusible link? Bad relay? Aux power line not connected to coach charging system/battery?

I'd start at fuse panel and look for a fuse for this circuit that's either blown or not installed.
__________________
"A wise man can change his mind. A fool never will."

"You only grow old when you run out of new things to do"

2018 Flagstaff Micro Lite 25BDS
2004 Nissan Titan
TitanMike is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



All times are GMT -5. The time now is 08:07 PM.