Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×


Reply
 
Thread Tools Display Modes
Old 06-08-2024, 04:30 PM   #1
Junior Member
 
Join Date: Jan 2023
Posts: 5
2017 Sunseeker RVS backup camera

Trying to troubleshoot my backup camera connected to a sony radio that stopped working.
I removed the camera from the rear and pulled the wire out a few feet. It seems to be stuck.
The plug in the radio is RCA yellow (video). Where does it connect to the rear? Is there some interconnect behind a panel?

The camera is labeled CCD Color Camera 12v 15456 with a RVS mount.

Do I keep pulling and risk loosing the connection? Thoughts?
Attached Thumbnails
Click image for larger version

Name:	20240608_160208.jpg
Views:	18
Size:	416.4 KB
ID:	300693   Click image for larger version

Name:	20240608_160157.jpg
Views:	18
Size:	413.1 KB
ID:	300694  
justinvd6 is offline   Reply With Quote
Old 06-08-2024, 08:55 PM   #2
Senior Member
 
Join Date: Oct 2016
Location: SW PA
Posts: 916
The 3 cameras (rear & side x2) connect to a multiplexer switch. This switch will be a small metal box with the 3 camera inputs, trigger inputs and a RCA output (your yellow RCA plug) that connects to the dash radio. The multiplexer will be stuffed somewhere under the dash most likely left of the steering wheel.

The pigtail that is part of the camera will be attached to a long extension that goes forward to the dash area. You may have to remove interior trim to locate that connection.
__________________


2021 Newmar Baystar 3401
2019 Jeep Cherokee Trailhawk toad
2017.5 Forester 3051S Traded 7/2020
Steve-W is offline   Reply With Quote
Old 06-08-2024, 11:42 PM   #3
Site Team
 
bikendan's Avatar
 
Join Date: Jan 2007
Location: Goodyear, Arizona
Posts: 34,592
Moved thread from the Tech and Repair section to the Forester and Sunseeker sub-forum for better help from other Sunseeker owners and possible factory support.
__________________
Dan-Retired California Firefighter/EMT
Shawn-Musician/Entrepreneur/Wine Expert
and Zoe the Wonder Dog(R.I.P.)
2016 PrimeTime TracerAIR 255, pushing a 2014 Ford F150 SCREW XTR 4x4 3.5 Ecoboost w/Max Tow Package
4pt Equal-i-zer WDH and 1828lbs of payload capacity
bikendan is offline   Reply With Quote
Old 06-22-2024, 05:42 PM   #4
Junior Member
 
Join Date: Jan 2023
Posts: 5
Anyone know which way the wire goes down the back? Like which side it's wired on normally? It almost seems like it's pinched somewhere and won't pull out all the way to change the camera. Is the extension 5pin cable connected somewhere else?
justinvd6 is offline   Reply With Quote
Old 06-22-2024, 06:37 PM   #5
Senior Member
 
Join Date: Jan 2018
Location: Raleigh, NC
Posts: 10,096
The least likely failure is in the video cable. Quit tugging on it or you will have TWO problems.

Get a cheap backup camera from eBay or Amazon and plug it in and connect power. If it works, your camera is defective.

If it still doesn't work, find the multiplexer and swap the rear camera cable with the left or right side. If the fault stays with the rear camera, the multiplexer is bad. If the fault moves to the side, the cable is bad (unlikely).
__________________
Larry
"Everybody's RV is not like your RV."
"Always take pictures with the button on the right."
"Always bypass the water heater before opening the low-point drains."
Sticks and Bricks: Raleigh, NC
2008 Cherokee 38P: at Ivor, VA permanently
Larry-NC is online now   Reply With Quote
Old 06-22-2024, 06:54 PM   #6
Junior Member
 
Join Date: Jan 2023
Posts: 5
Yea it's definitely the camera itself. My issue is that I can't get to the 5pin connector on the end of the camera that connects to the extension cable. I'm probably going to have to remove interior trim to find it. I did pull a few of the rear high marker lights to try to follow it and it goes up through the center of the wiring "trough". I might just go wireless temporarily until I have some time to remove trim. I did just have the rear floor repaired and they had the trim open. Of course the camera stopped working about 2 weeks after I picked it up...
justinvd6 is offline   Reply With Quote
Old 06-23-2024, 09:52 AM   #7
Senior Member
 
Join Date: Jan 2018
Location: Raleigh, NC
Posts: 10,096
Let us know

Quote:
Originally Posted by justinvd6 View Post
Yea it's definitely the camera itself. My issue is that I can't get to the 5pin connector on the end of the camera that connects to the extension cable. I'm probably going to have to remove interior trim to find it. I did pull a few of the rear high marker lights to try to follow it and it goes up through the center of the wiring "trough". I might just go wireless temporarily until I have some time to remove trim. I did just have the rear floor repaired and they had the trim open. Of course the camera stopped working about 2 weeks after I picked it up...
I've got the roof off an older unit. On this one, all the wiring is in the roof: marker lights, 12v interior lights, 120 Vac, etc. If yours is strung across the roof trusses like mine, it's not stapled anywhere, but I can see how the connector might be snagged on a truss. You might want to drop the interior shrouds on the fans, vents, and skylights in the appropriate area. You would be amazed at how far you can reach in.

Let us know how it comes out.
__________________
Larry
"Everybody's RV is not like your RV."
"Always take pictures with the button on the right."
"Always bypass the water heater before opening the low-point drains."
Sticks and Bricks: Raleigh, NC
2008 Cherokee 38P: at Ivor, VA permanently
Larry-NC is online now   Reply With Quote
Old 07-11-2024, 08:00 PM   #8
JSaylor
 
Join Date: Sep 2022
Location: Kauai Hawaii
Posts: 42
Quote:
Originally Posted by justinvd6 View Post
Trying to troubleshoot my backup camera connected to a sony radio that stopped working.
I removed the camera from the rear and pulled the wire out a few feet. It seems to be stuck.
The plug in the radio is RCA yellow (video). Where does it connect to the rear? Is there some interconnect behind a panel?

The camera is labeled CCD Color Camera 12v 15456 with a RVS mount.

Do I keep pulling and risk loosing the connection? Thoughts?

I replaced mine on my 2018 Sunseeker MB. The Amazon camera will not work as you need a 5 pin. The connection on mine was probably 5' inside. I just carefully pulled out the wire until I got to the connection. I found the correct camera from Trailer supply.com. More money but just plug and go.
__________________
2018 Sunseeker MBS 2400W
jsay is offline   Reply With Quote
Reply

Tags
camera, sunseeker

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



All times are GMT -5. The time now is 07:27 AM.