RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×


Reply
 
Thread Tools Display Modes
Old 09-07-2016, 12:50 PM   #1
Senior Members
 
Butch & Lena's Avatar
 
Join Date: Dec 2014
Location: Waukee, Iowa
Posts: 134
Power to the king jack power antenna....

I have a 2015 3010DS MH. My king jack power antenna for over the air signals is lacking power. the green power light does not come on in the cabinet above the entry door and the king jack antenna has no power (the blue dot lights will not illuminate on the unit). I probably have a blown fuse but I do not know where the fuse for this would be located. Any help would be appreciated.
Butch & Lena is offline   Reply With Quote
Old 09-07-2016, 01:01 PM   #2
Senior Member
 
brookstone345sa's Avatar
 
Join Date: Oct 2014
Location: Wilmington, De
Posts: 238
I powered mine from the antenna booster switch. I was lucky that wire was already run up to the old antenna. It's the little button you turn on to amplify the stock antenna.
brookstone345sa is offline   Reply With Quote
Old 09-07-2016, 03:30 PM   #3
Senior Members
 
Butch & Lena's Avatar
 
Join Date: Dec 2014
Location: Waukee, Iowa
Posts: 134
I have tried that on/off switch on the side of the king Jack but still no power.
__________________
2015 3010DS Sunseeker

2010 Jeep Wrangler Unlimited

Butch & Lena is offline   Reply With Quote
Old 09-07-2016, 04:27 PM   #4
Senior Member
 
brookstone345sa's Avatar
 
Join Date: Oct 2014
Location: Wilmington, De
Posts: 238
Not the switch on the King Jack itself, you should have a switch near your TV that amplifies the signal. Usually lights up when you push on it. Should be in a cabinet near TV itself, small round plunger type.
brookstone345sa is offline   Reply With Quote
Old 09-07-2016, 04:32 PM   #5
Senior Members
 
Butch & Lena's Avatar
 
Join Date: Dec 2014
Location: Waukee, Iowa
Posts: 134
Yes, I have pushed that too, still no power.
__________________
2015 3010DS Sunseeker

2010 Jeep Wrangler Unlimited

Butch & Lena is offline   Reply With Quote
Old 09-07-2016, 05:25 PM   #6
Senior Member
 
Join Date: Apr 2012
Location: West Michigan/Fort Myers
Posts: 3,927
Quote:
Originally Posted by butchs View Post
Yes, I have pushed that too, still no power.

I had a issue with mine at the rally last year. They replaced the antenna and it didn't fix the issue. It ended up being the board behind the push button in the entertainment center. The board shorted out. I had the same symptoms.



Phil57 is offline   Reply With Quote
Old 09-08-2016, 12:59 PM   #7
Senior Member
 
dalspot's Avatar
 
Join Date: Aug 2015
Posts: 103
we just went thru this with ours. Turned out to be bad ends on most of the coax connections. Had to finally pull the antenna off the roof, and one of the coax ends literally fell off. Hubby went thru a lot of testing to find where the issue was. PM me if you would like to talk to him.
dalspot is offline   Reply With Quote
Old 09-08-2016, 06:08 PM   #8
Senior Member
 
Orion's Avatar
 
Join Date: Oct 2013
Location: Texas
Posts: 172
Just went through this as well. Used a meter to find out we're the VoLTs were missing.




Sent from my iPad 18 using Forest River Forums
__________________
2017 Flagstaff FLT21DS
2011 Tundra Platinum, 5.7l, 2WD, Firestone bags...
Orion is offline   Reply With Quote
Reply

Tags
antenna, power

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



All times are GMT -5. The time now is 12:26 AM.