Reply
 
Thread Tools Display Modes
Old 09-27-2020, 10:43 PM   #1
Junior Member
 
Join Date: Sep 2020
Posts: 4
Hello All, and I have a question slide out

Hello Everybody,

I have been reading the forum and Im sure glad this group is here. I can tell
our Georgetown 378 XL has alot of the common Leak, Rattles and issues I read that you all have had. We have had our GT for 3 years and not used it to travel a whole lot Did live it for 5 months while our home was being built. But just went to the TX Hill country and stayed a couple days did the 3 sisters Motorcycle ride.

Here is a new one. When I park, Motor running activate the Automatic leveling Jacks.... Im still sitting in the seat and the right side slide comes out all by itself.

Anyone else had this happen ?
JMH-TX is offline   Reply With Quote
Old 09-28-2020, 09:08 AM   #2
Senior Member
 
SeaDog's Avatar
 
Join Date: Jan 2016
Location: Idaho
Posts: 7,669
Welcome to the forum its a great place to get your questions answered. I have never heard of this happening before does it happen every time you park and level?
__________________
Retired Navy
Jake my sidekick (yellow Lab) 10/04 - 05/20
2017 RAM 2500 CC 4X4 Cummins Diesel
2016 Flagstaff 26 FKWS
AF&AM & El Korah Shrine of Idaho
SeaDog is offline   Reply With Quote
Old 09-28-2020, 09:18 AM   #3
Junior Member
 
Join Date: Sep 2020
Posts: 4
Quote:
Originally Posted by SeaDog View Post
Welcome to the forum its a great place to get your questions answered. I have never heard of this happening before does it happen every time you park and level?
Just started happening the last 2 times. Im going to get in contact with the
service department today and see if they have any ideas...
JMH-TX is offline   Reply With Quote
Old 09-28-2020, 09:41 AM   #4
Multi-Slacker
 
Join Date: Aug 2017
Location: SoCal
Posts: 1,947
Welcome from SoCal!
I do not have a Georgetown but did want to say welcome.
__________________
2017 Forest River Sonoma 280RKS
2018 Silverado 2500 HD 6.0L, 4:10 rear
CurtPutnam is offline   Reply With Quote
Old 09-28-2020, 09:41 AM   #5
Senior Member
 
Iggy's Avatar
 
Join Date: Jul 2010
Posts: 7,835
If it was me I would make sure the control valves are seated snuggly.
If you know what I'm talking about you need to get a allen wrench. Not sure what size and make sure all the valves are snug in normal mode.
Turn counter clockwise but they don't need a lot of force.

If this isn't the case the rubber seal may have a crack on the one slide.
or
Its just a leaking hose.

Here is a picture and my manual and additional troublesshoot manual to help.
Attached Thumbnails
Click image for larger version

Name:	Screenshot 2020-09-28 073426.jpg
Views:	16
Size:	188.8 KB
ID:	240126  
Attached Files
File Type: pdf 00_Main_Maual.pdf (2.68 MB, 17 views)
File Type: pdf LCI Levelers Troubleshooting Tips.pdf (804.6 KB, 17 views)
__________________
2012 Georgetown XL 378TS
FB Georgetown RV Club
Iggy is offline   Reply With Quote
Old 09-28-2020, 10:00 AM   #6
Junior Member
 
Join Date: Sep 2020
Posts: 4
Quote:
Originally Posted by CurtPutnam View Post
Welcome from SoCal!
I do not have a Georgetown but did want to say welcome.
Thank You !
JMH-TX is offline   Reply With Quote
Old 09-28-2020, 10:03 AM   #7
Junior Member
 
Join Date: Sep 2020
Posts: 4
Quote:
Originally Posted by Iggy View Post
If it was me I would make sure the control valves are seated snuggly.
If you know what I'm talking about you need to get a allen wrench. Not sure what size and make sure all the valves are snug in normal mode.
Turn counter clockwise but they don't need a lot of force.

If this isn't the case the rubber seal may have a crack on the one slide.
or
Its just a leaking hose.

Here is a picture and my manual and additional troublesshoot manual to help.
Thanks Iggy,
Gives me a good place to start.
JMH-TX is offline   Reply With Quote
Old 09-28-2020, 10:15 AM   #8
Senior Member
 
bubbles's Avatar
 
Join Date: Dec 2012
Posts: 5,256
What I find interesting is with the engine running (ignition on) any slide would move because there is an ignition lockout of the slides. Do the slides extend and retract normally otherwise? Iggy's valve seat may cause your issue. Not sure what happens when the allen screws are not fully seated.
bubbles is offline   Reply With Quote
Old 09-30-2020, 07:14 PM   #9
Senior Member
 
Join Date: Aug 2016
Location: Dandridge,TN
Posts: 507
I have a 08 triple slide my slides do not work with engine running or key on. But the E brake must be on. The jacks engine running or key must be on is batterys are full charged.
cfo111 is offline   Reply With Quote
Old 09-30-2020, 07:31 PM   #10
Senior Member
 
bubbles's Avatar
 
Join Date: Dec 2012
Posts: 5,256
Quote:
Originally Posted by bubbles View Post
What I find interesting is with the engine running (ignition on) any slide would move because there is an ignition lockout of the slides. Do the slides extend and retract normally otherwise? Iggy's valve seat may cause your issue. Not sure what happens when the allen screws are not fully seated.
They are locked out for selection electrically (slide switches) but hydraulically not sure if a bad valve could fail in this manner.
bubbles is offline   Reply With Quote
Reply

Tags
slide, slide out

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



All times are GMT -5. The time now is 09:27 AM.