Reply
 
Thread Tools Display Modes
Old 07-07-2018, 04:28 PM   #1
Junior Member
 
Join Date: Jul 2018
Posts: 1
Electrical / Battery Issue

We have a one year old Hyperlite 27fhs. Recently I noticed that the trailer has no power at all when itís not hooked up to either shore power or a generator. Not a light, not an outlet, no 12v or 120v power, no power at all. Even when itís plugged into my truck I donít get any power.

When itís hooked up to shore power or my generator, everything works fine.

I put a fresh battery in and visually checked both the inline fuse by the battery and the fuses in the fuse box, and they all looked all ok. Battery disconnect is in the correct position too.

Any ideas what the issue may be or what to check next?
__________________

Cmj149 is offline   Reply With Quote
Old 07-07-2018, 04:32 PM   #2
Senior Member
 
fonzie's Avatar
 
Join Date: Sep 2010
Location: Eastern Ontario
Posts: 3,897
Look for these under trailer near tongue and reset by pressing small black button, hope that is it. Also make sure your battery connections are right....usually black or red is positive and white is negative and grounded to frame near battery.
Attached Thumbnails
Click image for larger version

Name:	mini-breaker pic.jpg
Views:	67
Size:	30.1 KB
ID:	178630  
Attached Images
 
__________________

__________________
Fonzie
2011 Rockwood 8319SS with ProPride 3P hitch/GoodYear Marathons/TST TPMS 507
2008 F250 Lariat CC SB 6.8L V10 4.10 axle ratio (NITTO TERRA GRAPLER G2 LT275/65R20E)
Yamaha 3000iseb generator:Progressive Ind. EMS-HW30C : Eastern Ontario
Nights Camped:2012(36) 2013 (17) 2014 (18) 2015 (18) 2016 (36) 2017 (32) 2018 (42)
fonzie is offline   Reply With Quote
Old 07-07-2018, 08:00 PM   #3
Site Team
 
bikendan's Avatar
 
Join Date: Jan 2007
Location: Camano Island, Washington
Posts: 20,503
Usually trips when the owner reinstalls the battery .
__________________
Dan-Retired California Firefighter/EMT
Shawn-Musician/Entrepreneur/Wine Expert
and Zoe the Wonder Dog(R.I.P.)
2016 PrimeTime TracerAIR 255, pushing a 2014 Ford F150 SCREW XTR 4x4 3.5 Ecoboost w/Max Tow Package
Equalizer WDH
bikendan is online now   Reply With Quote
Old 07-08-2018, 08:14 PM   #4
Senior Member
 
Join Date: Feb 2015
Location: Minnesota
Posts: 574
Here is an old thread that i had for the same issue. The black reset button was your issue.

http://www.forestriverforums.com/for...ad.php?t=88534
__________________
2015 XLR Hyperlite 29HFS (installing mods...)
2018 Chevy 3500HD 4X4 6.0L
stevejd235 is offline   Reply With Quote
Old 07-09-2018, 02:22 PM   #5
Senior Member
 
Join Date: Jan 2018
Location: Raleigh, NC
Posts: 2,421
If that doesn't do it...

Quote:
Originally Posted by stevejd235 View Post
Here is an old thread that i had for the same issue. The black reset button was your issue.

battery disconnect will not power up - Forest River Forums
If that doesn't do it, look on the converter distribution board for a pair of 30 amp or 40 amp fuses labelled "Reverse Polarity" and replace if necessary.

Larry
Larry-NC is online now   Reply With Quote
Reply

Tags
electrical, battery, electric

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



All times are GMT -5. The time now is 09:57 PM.


×