Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×


Reply
 
Thread Tools Display Modes
Old 05-10-2014, 10:29 AM   #1
Member
 
Rico1971's Avatar
 
Join Date: Apr 2014
Posts: 70
TV/DVD Problems

TV; Click image for larger version

Name:	ImageUploadedByForest River Forums1399735329.748077.jpg
Views:	180
Size:	48.7 KB
ID:	52095 Legend TV; radio with built in DVD player...two issues: (1) DVD only plays in Black and White (tv channels have great color). We tried everything we can think of to get the DVD to play in color and nothing works. (2) Sound comes out if tv speakers, but not the main speakers throughout the TT. Previously we've had the TV on and it played great on the TT speakers. Again, we've tried everything and can't figure out what the issue is.


Help!! Any suggestions. I get that it's camping and we should be enjoying the great outdoors, but after the campfire last night, we had planned a family movie night and it was frustrating that we couldn't get it all working....
Rico1971 is offline   Reply With Quote
Old 05-10-2014, 10:47 AM   #2
Senior Member
 
MagnoliaTom's Avatar
 
Join Date: Oct 2013
Location: Texas
Posts: 337
Have you checked the RCA connections behind the radio?
__________________
2014 Freedom Express 320BHDS Liberty Edition 50th Anniversary
2005 F250 Lariat SuperCrew 6.0 PS Diesel
2004 Excursion Limited 4x4 6.0 PS Diesel
2000 Excursion Limited 7.3 PS Diesel Sold:crying

MagnoliaTom is offline   Reply With Quote
Old 05-10-2014, 06:18 PM   #3
Member
 
Rico1971's Avatar
 
Join Date: Apr 2014
Posts: 70
Just took it apart and all looks correct. Still not working...
Rico1971 is offline   Reply With Quote
Old 05-10-2014, 08:36 PM   #4
Senior Member
 
JonClark's Avatar
 
Join Date: Apr 2014
Posts: 174
I had the same problem with my freedom express 320bhds. Black and white on movies. Try changing input or turning off the antenna. I think it was one of those two for me. Got same thing tho tv doesn't play thru surround sound

kids think tt stands for tan turd.
JonClark is offline   Reply With Quote
Old 05-10-2014, 08:48 PM   #5
Member
 
Rico1971's Avatar
 
Join Date: Apr 2014
Posts: 70
OMG...JonClark, you are a GENIUS!!! It was the input....we kept trying to use 'component' and we should have been using 'AV'!!

Thanks so much!!!

NOW...you are challenged with figuring out the surround sound for both of us!! 👍😀😜
Rico1971 is offline   Reply With Quote
Old 05-10-2014, 08:52 PM   #6
Member
 
Rico1971's Avatar
 
Join Date: Apr 2014
Posts: 70
Dude....I just got the surround sound to work!!!!

You won't believe it....just had to crank the volume WAY UP!!!!! That's all it took!!

Hope your issue is solved as easily!!!

Cheers!! 😀😀😀
Rico1971 is offline   Reply With Quote
Old 05-10-2014, 08:53 PM   #7
Senior Member
 
JonClark's Avatar
 
Join Date: Apr 2014
Posts: 174
Sweet. For the tv just crank it? Will try that tomorrow after work. Glad I could help, enjoy!!

kids think tt stands for tan turd.
JonClark is offline   Reply With Quote
Old 05-10-2014, 08:55 PM   #8
Member
 
Rico1971's Avatar
 
Join Date: Apr 2014
Posts: 70
Yep....turned it up to close to '30' before it started to come thru the surround sound.

Ever see the movie "This is Spinal Tap"?? "But this one goes to 11!!" Lol. 😜😜😜
Rico1971 is offline   Reply With Quote
Old 05-10-2014, 08:58 PM   #9
Senior Member
 
JonClark's Avatar
 
Join Date: Apr 2014
Posts: 174
Haha . enjoy and hope.all things are this easy

kids think tt stands for tan turd.
JonClark is offline   Reply With Quote
Old 05-10-2014, 09:14 PM   #10
Senior Member
 
B and B's Avatar
 
Join Date: Jun 2013
Posts: 10,764
Send a message via AIM to B and B
If you have a HDMI output I would use that. The quality is far better.

Brian
B and B is offline   Reply With Quote
Old 05-29-2014, 11:18 AM   #11
Member
 
Rico1971's Avatar
 
Join Date: Apr 2014
Posts: 70
Quote:
Originally Posted by JonClark View Post
Sweet. For the tv just crank it? Will try that tomorrow after work. Glad I could help, enjoy!!

kids think tt stands for tan turd.

were you able to get your surround sound to work?
Rico1971 is offline   Reply With Quote
Old 05-29-2014, 12:30 PM   #12
Senior Member
 
Witch Doctor's Avatar
 
Join Date: Feb 2012
Location: Clarksville Va.
Posts: 10,376
I hope you got it all working now, sometimes it takes time to learn everything, then you forget the next time you use it to go camping. It happens to me all the time. Have you ever notice that things go in cycles to me on the forum. Today seems to be TV day. Other day's it's A/C day or Furnace day or Refer day.
__________________
Coachmen M/H
Concord
2018 / 300 DSC

Witch Doctor is offline   Reply With Quote
Old 05-29-2014, 01:48 PM   #13
Senior Member
 
Join Date: Feb 2013
Location: Orland Park, IL
Posts: 470
Quote:
Originally Posted by Rico1971 View Post
OMG...JonClark, you are a GENIUS!!! It was the input....we kept trying to use 'component' and we should have been using 'AV'!!
I had the very same problem. You beat me to the punch! I also have a problem with the sound from the TV to the entertainment unit but I believe I have it narrow down to using the SPDIF output from my TV instead of the headphone jack. I am plugging RCA jack on the other end not optical.
__________________
2015 Rockwood Roo 23IKSS
2015 GMC Sierra 1500
Archicamper is offline   Reply With Quote
Reply

Tags
dvd

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



All times are GMT -5. The time now is 09:01 PM.