Reply
 
Thread Tools Display Modes
Old 11-01-2012, 12:57 PM   #1
Junior Member
 
Glamping's Avatar
 
Join Date: Oct 2012
Posts: 14
First trip out

Hello everyone,

Well the first trip out with the new George Town 360 went pretty well. An issue I need to adress today before leaving again this weekend is the rear black tank flush. After opening the black tank valve and letting it empty, I hooked-up the garden hose to the flush port and turned on the water. Water did not come out the dump valve but came out of 2 storage areas and soaked the bathroom. There was water even on top of the counter top between the sinks(hose water not dirty water). After mopping up, ran out of time to really look to see what happened. The toilet lid was closed so I don't think the water came from there. I almost think the flush system is plumbed to the gray tank or maybe the flush hose is disconnected from the tank. Anyone heard of anything like this happening?

Thanks
Rich
__________________
Connie and Rich
Surprise Az
2012 George Town XL 360

2013 Can Am Maverick
Glamping is offline   Reply With Quote
Old 11-01-2012, 02:04 PM   #2
Moderator Emeritus
 
Dave_Monica's Avatar
 
Join Date: Sep 2007
Location: Ontario, Canada
Posts: 4,327
Sounds like a (dreaded) trip to the dealer as it appears that the hose connection to the black spray is loose, disconnected, something like that.

Dave
__________________


Nights camped in 2013 - 55, 2014 - 105, 2015 - 63
Dave_Monica is offline   Reply With Quote
Old 11-01-2012, 07:01 PM   #3
Junior Member
 
Glamping's Avatar
 
Join Date: Oct 2012
Posts: 14
I was lucky. Came home today and started to look around and found the factory never attached the line to the back flow preventer valve. Put the line together, added a hose clamp and we are good to go. Off to see what we encounter this weekend.
__________________
Connie and Rich
Surprise Az
2012 George Town XL 360

2013 Can Am Maverick
Glamping is offline   Reply With Quote
Old 11-01-2012, 07:03 PM   #4
Moderator Emeritus
 
Dave_Monica's Avatar
 
Join Date: Sep 2007
Location: Ontario, Canada
Posts: 4,327
Good to hear that it was a simple fix. Enjoy your camping weekend.

Dave
__________________


Nights camped in 2013 - 55, 2014 - 105, 2015 - 63
Dave_Monica is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



All times are GMT -5. The time now is 09:48 PM.