Reply
 
Thread Tools Display Modes
Old 02-17-2017, 10:13 PM   #1
Junior Member
 
Join Date: Feb 2017
Posts: 18
Need Help! Water Heater

Hello everyone, brand new TT owner here. I purchased a 2016 Surveyor 201RBS. During my walk-through I was shown a switch inside the RV and told this turns the water heater on (I now know this is to run the heater on propane)

I hooked up to shore power for 24 hrs, with an EMPTY WH, before seeing an electric on/off switch on the outside of the heater! It was turned to ON with an empty tank for 24 hrs!

The strange part is that the element seems to work just fine. I connected it to water today. However, we left it today for about 8 hours and there was a pool of water puddling outside the WH and running along the RV on the outside due to some leak.

(1 could this just be a faulty pressure release? (2 could I have burned a hole in my tank, and if so, how would I check? (3 shouldn't the element be burned out? I did have the bypass kit initiated, did this prevent the unit from turning on?
Jordan.Gabriel is offline   Reply With Quote
Reply

Tags
heater, water, water heater

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



All times are GMT -5. The time now is 04:45 PM.


×