RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×


Reply
 
Thread Tools Display Modes
Old 08-23-2020, 08:08 PM   #1
Junior Member
 
Join Date: Aug 2020
Posts: 1
No hot water

Hi, I have a 2019 Coachmen Catalina. Tried to use the hot water for the first time & I can not figure it out. The gas tank is open, the gauge/director on the line is facing the gas tank, hot and cold water valves on the tank are open, water in the tank. I turn on the DSI / water heater switch, it lights and stays lit. Gas is getting to to the stove, the burners light. The hot water burner is not igniting. What step am I missing? Thank you.
rick005241 is offline   Reply With Quote
Old 08-23-2020, 08:36 PM   #2
Senior Member
 
Join Date: Jul 2020
Posts: 133
You didnít state which WH you have but if it is a Suburban you have two resettable ďbreakersĒ on the LH side near the top when you open the panel. They are two black rubber circles. The left one is for the 120V side, the RH for the 12v side. The propane operates off the 12v side. Try pushing in on the center. You do not have to remove the rubber cover.
__________________
2019 RW 2902WS
2019 Ford F-150 CC 4x4 w Max TT
TheMcBees is offline   Reply With Quote
Old 08-24-2020, 09:27 AM   #3
Head Rambler
 
Join Date: Mar 2008
Location: Southwest Alabama
Posts: 8,630
How did you make sure the tank was full of water?

Also on a Suburban there's a switch behind the gas line in the lower left corner for the 120 volt side.

Make sure you're getting 12 volts to the controls.
__________________
Salem 29RKSS Pushing a GMC Sierra 2500HD!
Gotta go campin!
Bama Rambler is offline   Reply With Quote
Old 08-24-2020, 09:43 AM   #4
Senior Member
 
Join Date: Jul 2017
Posts: 2,472
Quote:
Originally Posted by rick005241 View Post
Hi, I have a 2019 Coachmen Catalina. Tried to use the hot water for the first time & I can not figure it out. The gas tank is open, the gauge/director on the line is facing the gas tank, hot and cold water valves on the tank are open, water in the tank. I turn on the DSI / water heater switch, it lights and stays lit. Gas is getting to to the stove, the burners light. The hot water burner is not igniting. What step am I missing? Thank you.
Could be a bad board common with surburbans . be sure the tank is full then call a tech to solve your problems
MR.M is offline   Reply With Quote
Reply

Tags
hot water, water

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



All times are GMT -5. The time now is 04:40 AM.