Reply
 
Thread Tools Display Modes
Old 07-23-2020, 05:25 PM   #1
Senior Member
 
Join Date: Aug 2016
Posts: 189
Pump Losing Prime

Shurflo pump. We hardly ever have used the pump. It is a 2011 V-Lite. I can get it to prime by pushing some water into the antifreeze input. It will then pump up and stay. I can use the toilet, sink, etc and it will work. Leave it sit for a hour, it will lose the prime but hold the pressure in the lines. It primed itself in the spring with no issues. What should I look for? I checked the screen and there was a little debris that I cleaned out.
Where we park the camper in the yard is not level with the back end where the fresh water tank is at is lower than the pump. The camper is nose high. If level, should it not lose its prime?
KKonyha is offline   Reply With Quote
Old 07-23-2020, 05:40 PM   #2
Senior Member
 
Join Date: Jul 2017
Location: North of Seattle, WA
Posts: 8,452
How full is the water tank? If at any angle and tank low, could be that the water level is below the pickup. A lot of tanks are longer and wider than they are high. Makes it possible for there to be a considerable amount of water in the tank but all of it over in the wrong corner.
__________________
"A wise man can change his mind. A fool never will."

"Sometimes you're the dog, sometimes you're the tree"

2018 Flagstaff Micro Lite 25BDS
2004 Nissan Titan
TitanMike is offline   Reply With Quote
Old 07-23-2020, 05:49 PM   #3
Senior Member
 
Join Date: Aug 2016
Posts: 189
The tank is completely full. We are going tomorrow to the camp site so I will level then and see. I am hoping that solves it.
KKonyha is offline   Reply With Quote
Old 07-23-2020, 05:53 PM   #4
Senior Member
 
Join Date: Jul 2017
Location: North of Seattle, WA
Posts: 8,452
Quote:
Originally Posted by KKonyha View Post
The tank is completely full. We are going tomorrow to the camp site so I will level then and see. I am hoping that solves it.
Had to ask.


Also, check the strainer at the inlet of the pump. Bowl may be loose and pump is sucking air. Doesn't take much to keep it from sucking up water from a tank lower than it.
__________________
"A wise man can change his mind. A fool never will."

"Sometimes you're the dog, sometimes you're the tree"

2018 Flagstaff Micro Lite 25BDS
2004 Nissan Titan
TitanMike is offline   Reply With Quote
Old 07-24-2020, 04:17 PM   #5
Senior Member
 
Join Date: Mar 2014
Posts: 2,124
Quote:
Originally Posted by KKonyha View Post
Shurflo pump. We hardly ever have used the pump. It is a 2011 V-Lite. I can get it to prime by pushing some water into the antifreeze input. It will then pump up and stay. I can use the toilet, sink, etc and it will work. Leave it sit for a hour, it will lose the prime but hold the pressure in the lines. It primed itself in the spring with no issues. What should I look for? I checked the screen and there was a little debris that I cleaned out.
Says to me the valve that selects antifreeze or tank is leaking air or is not fully in the "tank" position.

Fred W
pgandw is online now   Reply With Quote
Old 07-29-2020, 11:29 AM   #6
Senior Member
 
Join Date: Aug 2016
Posts: 189
Quote:
Originally Posted by pgandw View Post
Says to me the valve that selects antifreeze or tank is leaking air or is not fully in the "tank" position.

Fred W
Worse yet, or more embarrassing, the valve was in the wrong position. Once it was in the correct position, worked well all week-end. I am impressed that a 10+ year old pump still works even though this is only the 2nd time it has been used in its life.
KKonyha is offline   Reply With Quote
Reply

Tags
pump

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



All times are GMT -5. The time now is 10:06 PM.