Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×


Reply
 
Thread Tools Display Modes
Old 02-21-2014, 03:15 PM   #1
Member
 
Join Date: Sep 2013
Posts: 29
Electrical question

We have a 2012 Crusader 320 RLT, And the lights over the sink continue to blow the 15 amp fuses. I have checked the wiring and do not see any problems.
If you can make a suggestion or have a answer I would appreciate the help.
Thanks, YogiBear
YogiBear is offline   Reply With Quote
Old 02-21-2014, 03:21 PM   #2
Senior Member
 
davel1971's Avatar
 
Join Date: Nov 2013
Location: Seaford, De
Posts: 2,377
try swapping light with another one like it. When you say you checked the wiring, how did you check it?
__________________
David & Lynn
2014 Coachmen Chaparral Signature 327 RLKS
2016 Ford F350 Lariat CC Dually
davel1971 is offline   Reply With Quote
Old 02-21-2014, 03:57 PM   #3
Member
 
Join Date: Sep 2013
Posts: 29
I took the switch out to check it. I have not taken down each light as if yet. Hoping it is not a dead short in the wiring somewhere, but everyone I have talked to, feels that is the problem.
I do not have a voltage meter with me, but probably someone here in campground will have one.
Thanks for your help
YogiBear is offline   Reply With Quote
Old 02-21-2014, 04:05 PM   #4
Senior Member
 
Todouble's Avatar
 
Join Date: Nov 2013
Posts: 849
Swap it with another light. Maybe it's the fixture itself. If your blowing fuses then there's obviously a dead short.
Todouble is offline   Reply With Quote
Old 02-21-2014, 04:09 PM   #5
Member
 
Join Date: Sep 2013
Posts: 29
Thanks, I will do more research.
YogiBear is offline   Reply With Quote
Old 02-21-2014, 04:21 PM   #6
Senior Member
 
davel1971's Avatar
 
Join Date: Nov 2013
Location: Seaford, De
Posts: 2,377
does it only blow when light is turned on? Power is in the wires all the time, so fuse would blow whether or not light is on. If only happening with light on, its in the light.
__________________
David & Lynn
2014 Coachmen Chaparral Signature 327 RLKS
2016 Ford F350 Lariat CC Dually
davel1971 is offline   Reply With Quote
Old 02-21-2014, 04:29 PM   #7
Member
 
Join Date: Sep 2013
Posts: 29
Dave, as soon as I put in a new bulb in either of the 2 hanging lights fuse blows immediately. Does not blow fuse without bulbs in sockets.
YogiBear is offline   Reply With Quote
Old 02-21-2014, 04:53 PM   #8
Senior Member
 
davel1971's Avatar
 
Join Date: Nov 2013
Location: Seaford, De
Posts: 2,377
short most likely in the bulb socket. At least its not looking like a wiring problem.
__________________
David & Lynn
2014 Coachmen Chaparral Signature 327 RLKS
2016 Ford F350 Lariat CC Dually
davel1971 is offline   Reply With Quote
Old 02-21-2014, 04:53 PM   #9
Member
 
Join Date: Sep 2013
Posts: 29
I also have a additional question on the sensors in the storage tanks. Our Galley, and shower grey tanks continue to read 1/3 or 2/3 full, the black tank also seems stuck. We bought the granular tank cleaner and three weeks ago drove 2.5 hours to our new location with fresh water and cleaner in all tanks. Once emptied, didn't change anything.
Any suggestions?
YogiBear is offline   Reply With Quote
Old 02-21-2014, 04:55 PM   #10
Member
 
Join Date: Sep 2013
Posts: 29
Fingers crossed not the wiring. Will have to find a rv dealer that might carry lights like originally installed. Your help is most appreciated.
YogiBear is offline   Reply With Quote
Old 02-21-2014, 04:56 PM   #11
Senior Member
 
Todouble's Avatar
 
Join Date: Nov 2013
Posts: 849
Quote:
Originally Posted by YogiBear View Post
Fingers crossed not the wiring. Will have to find a rv dealer that might carry lights like originally installed. Your help is most appreciated.

Just a thought but are you using the correct bulbs? Can you narrow it down to one light or the other??
Todouble is offline   Reply With Quote
Old 02-21-2014, 05:06 PM   #12
Member
 
Join Date: Sep 2013
Posts: 29
Bought bulbs at rv store, tried one bulb in one fixture at a time, no bulb in the other fixture, as soon as I turned on the switch fuse blew on both fixtures, which does not make much sense that both fixtures would bad at same time.
Do u think it would be worth trying LED bulbs instead?
YogiBear is offline   Reply With Quote
Old 02-21-2014, 05:10 PM   #13
Senior Member
 
Todouble's Avatar
 
Join Date: Nov 2013
Posts: 849
Quote:
Originally Posted by YogiBear View Post
Bought bulbs at rv store, tried one bulb in one fixture at a time, no bulb in the other fixture, as soon as I turned on the switch fuse blew on both fixtures, which does not make much sense that both fixtures would bad at same time.
Do u think it would be worth trying LED bulbs instead?

Just doesn't sound right to me. Very unlikely you had two fixtures fail at the same exact time, although it is possible but very rare. Do you have another bulb in another light somewhere in the RV you can try? I'm thinking it's the bulbs you bought.
Todouble is offline   Reply With Quote
Old 02-21-2014, 05:12 PM   #14
Member
 
Join Date: Sep 2013
Posts: 29
Great idea, I will try that now.
YogiBear is offline   Reply With Quote
Old 02-21-2014, 05:14 PM   #15
Senior Member
 
Join Date: Oct 2013
Location: Georgetown, TX
Posts: 330
Very possibly a faulty breaker.
cadman99 is offline   Reply With Quote
Old 02-21-2014, 05:18 PM   #16
Senior Member
 
davel1971's Avatar
 
Join Date: Nov 2013
Location: Seaford, De
Posts: 2,377
that's what we are here for, to help each other out. As far as your black tank, you can install a tank flush kit that will clean the sensors off. Lots of chemicals available to add to tanks to clean them also. Everyone has their own way they have found that works for them. Here is a link to the tank flusher I installed in my last camper. Worked great.
Camco 40126 RV Tornado Rotary Tank Rinser with Hose : Amazon.com : Automotive
__________________
David & Lynn
2014 Coachmen Chaparral Signature 327 RLKS
2016 Ford F350 Lariat CC Dually
davel1971 is offline   Reply With Quote
Old 02-21-2014, 05:18 PM   #17
Senior Member
 
fonzie's Avatar
 
Join Date: Sep 2010
Location: Eastern Ontario
Posts: 4,073
Most likely these are 6 volts bulbs, no circuit breaker, these are fuses.....
__________________
Fonzie
2011 Rockwood 8319SS with ProPride 3P hitch/GoodYear Marathons/TST TPMS 507
2019 F350 Ruby Red 6.7l diesel 3.31 axle electronic locker
Yamaha 3000iseb generator:Progressive Ind. EMS-HW30C : Eastern Ontario
Nights Camped: 2014 (18) 2015 (18) 2016 (36) 2017 (32) 2018 (42) 2019 (28) 2020 (35)
fonzie is online now   Reply With Quote
Old 02-21-2014, 05:18 PM   #18
Member
 
Join Date: Sep 2013
Posts: 29
Well guys, no luck on bulbs, all other lights use different style bulb. The 2 lights use a automotive signal light style bulb (CEC 1076)
YogiBear is offline   Reply With Quote
Old 02-21-2014, 05:20 PM   #19
Senior Member
 
davel1971's Avatar
 
Join Date: Nov 2013
Location: Seaford, De
Posts: 2,377
is your light the typical style with 2 bulbs and the switch in the center?
__________________
David & Lynn
2014 Coachmen Chaparral Signature 327 RLKS
2016 Ford F350 Lariat CC Dually
davel1971 is offline   Reply With Quote
Old 02-21-2014, 05:22 PM   #20
Member
 
Join Date: Sep 2013
Posts: 29
No it is a automotive single bulb on a hanging pedestal type fixture
YogiBear is offline   Reply With Quote
Reply

Tags
electric, electrical

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



All times are GMT -5. The time now is 05:52 PM.