Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×


Reply
 
Thread Tools Display Modes
Old 06-15-2024, 05:36 AM   #1
Junior Member
 
Rmrock824's Avatar
 
Join Date: Jun 2024
Posts: 10
Half of RV has no power

Greetings I'm at my very first campground and half of my Cardinal Red 31rl has no power to the outlets and the main A/C has no power and last but not least the control panel for the slide outs is blinking where I would select the particular slide out to retract. Thus it won't let me retract any of the slides
Any advice or suggestions would be greatly appreciated

First Timer,Old Timer
Richard R
Rmrock824 is offline   Reply With Quote
Old 06-15-2024, 06:17 AM   #2
Senior Member
 
Oaklevel's Avatar
 
Join Date: Sep 2012
Location: Virginia
Posts: 10,504
Assuming that the trailer is a 50A power supply. It sounds like one leg of the main 50A power is out. If you on a campground pedestal check your breakers. Flip them completely on the pole and the power box in the trailer.

How are you hooked up to the pedestal? To a 50A outlet or a 30A outlet with an adapter?

Can't help with the control panel as we do not have one.


__________________

2005 Dodge 3500 Cummins
2017 Wildwood Lodge 4092 BFL
1966 Mustang GT
1986 Mustang SVO
Lillie Spoiled Rotten Boxer Mix
Oaklevel is offline   Reply With Quote
Old 06-15-2024, 06:21 AM   #3
Junior Member
 
Rmrock824's Avatar
 
Join Date: Jun 2024
Posts: 10
Quote:
Originally Posted by Oaklevel View Post
Assuming that the trailer is a 50A power supply. It sounds like one leg of the main 50A power is out. If you on a campground pedestal check your breakers. Flip them completely on the pole and the power box in the trailer.

Can't help with the control panel as we do not have one.


I'm in a campground connected to a 50 amp all the breakers at the connection point are on. Green lights on the surge protector also. The A/C in the bedroom works but not the main A/C and microwave.
Rmrock824 is offline   Reply With Quote
Old 06-15-2024, 06:22 AM   #4
Junior Member
 
Rmrock824's Avatar
 
Join Date: Jun 2024
Posts: 10
Quote:
Originally Posted by Rmrock824 View Post
I'm in a campground connected to a 50 amp all the breakers at the connection point are on. Green lights on the surge protector also. The A/C in the bedroom works but not the main A/C and microwave.
None of the 120v plugs have power
Rmrock824 is offline   Reply With Quote
Old 06-15-2024, 06:45 AM   #5
Senior Member
 
Oaklevel's Avatar
 
Join Date: Sep 2012
Location: Virginia
Posts: 10,504
Quote:
Originally Posted by Rmrock824 View Post
I'm in a campground connected to a 50 amp all the breakers at the connection point are on. Green lights on the surge protector also. The A/C in the bedroom works but not the main A/C and microwave.
Have you checked your main breakers? in the trailer?

A 50A trailer has two legs one AC is on one side the second AC is on the other side.

__________________

2005 Dodge 3500 Cummins
2017 Wildwood Lodge 4092 BFL
1966 Mustang GT
1986 Mustang SVO
Lillie Spoiled Rotten Boxer Mix
Oaklevel is offline   Reply With Quote
Old 06-15-2024, 06:47 AM   #6
Junior Member
 
Rmrock824's Avatar
 
Join Date: Jun 2024
Posts: 10
Yes I have but the 50amp breaker is only one
Rmrock824 is offline   Reply With Quote
Old 06-15-2024, 07:02 AM   #7
Site Team
 
Flybob's Avatar
 
Join Date: Oct 2014
Posts: 15,423
Turn 50A breaker in trailer off and back on. Also check connection between main power cord and rv.
__________________

2015 Freedom Express 248RBS
TV 2015 Silverado HD2500 Duramax
TST Tire Monitors
Honda 2000I + Companion
2 100W solar panels
Flybob is online now   Reply With Quote
Old 06-15-2024, 07:04 AM   #8
Junior Member
 
Rmrock824's Avatar
 
Join Date: Jun 2024
Posts: 10
Done but no change. I'm thinking the 50amp breaker on the campsite post is defective. I'm going to hook up to the 30amp and see what happens
Rmrock824 is offline   Reply With Quote
Old 06-15-2024, 07:25 AM   #9
Member
 
Join Date: Jun 2024
Location: SW MS
Posts: 85
Do you have a meter to check the voltage at the campsite post?
Baker9713 is offline   Reply With Quote
Old 06-15-2024, 09:37 AM   #10
Site Team
 
Join Date: Sep 2014
Location: Northen IL
Posts: 8,489
Quote:
Originally Posted by Rmrock824 View Post
Done but no change. I'm thinking the 50amp breaker on the campsite post is defective.
Most likely. I had this exact problem once. Had to have the CG change the breaker on the post.
Iwritecode is online now   Reply With Quote
Old 06-15-2024, 10:11 AM   #11
Junior Member
 
Rmrock824's Avatar
 
Join Date: Jun 2024
Posts: 10
After all I found changing to 30amp fixed the problem. Thanks to all for the suggestions and support. Great Forum
Rmrock824 is offline   Reply With Quote
Old 06-15-2024, 10:42 AM   #12
Site Team
 
Mr. Dan's Avatar
 
Join Date: Mar 2014
Location: Grayson County, Texas
Posts: 21,917
Quote:
Originally Posted by Rmrock824 View Post
After all I found changing to 30amp fixed the problem. Thanks to all for the suggestions and support. Great Forum
Except for the fact that you now have a total of 30 amps instead of 100 amps.
__________________
2015 FR Wildcat 295RSX / GMC Sierra

Nights Camped: '13 = 49/'14 = 74/'15 = 74/'16 = 85/'17 = 110/'18 = 111/'19 = 86/'20 =108/'21 = 115/'22 = 135/'23 = 78/'24 = 41; Booked for 2024 = 55
Mr. Dan is online now   Reply With Quote
Old 06-15-2024, 10:51 AM   #13
Junior Member
 
Rmrock824's Avatar
 
Join Date: Jun 2024
Posts: 10
Called the park management and they are on their way with a new breaker
Rmrock824 is offline   Reply With Quote
Old 06-15-2024, 12:54 PM   #14
Senior Member
 
Join Date: Jan 2018
Location: Raleigh, NC
Posts: 10,103
Good job!

Quote:
Originally Posted by Rmrock824 View Post
Called the park management and they are on their way with a new breaker
Good job!
__________________
Larry
"Everybody's RV is not like your RV."
"Always take pictures with the button on the right."
"Always bypass the water heater before opening the low-point drains."
Sticks and Bricks: Raleigh, NC
2008 Cherokee 38P: at Ivor, VA permanently
Larry-NC is offline   Reply With Quote
Old 06-15-2024, 12:59 PM   #15
Senior Member
 
Join Date: Feb 2018
Location: TEXAS
Posts: 9,624
Now that you've found the problem....

Welcome to the forum!
__________________
2015 Dynamax REV 24TB class C
Reverse_snowbird is offline   Reply With Quote
Reply

Tags
no power, power

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



All times are GMT -5. The time now is 10:54 AM.