Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×


Reply
 
Thread Tools Display Modes
Old 05-08-2021, 08:27 AM   #1
Junior Member
 
Join Date: May 2021
Posts: 8
No 12v POWER in Roo 233S

Relatively newbie here and need help from my fellow camper friends with more expertise.

I am at my seasonal campsite with my 2018 Rockwood Roo 233s and arrived last night and no lights and fridge power while plugged into shore power.

Verified shore power connection is good and battery disconnect is not activated. All fuses look good and reset main breaker and converter breaker just in case. Outlets and TV work, just the 12v system is not being converted down from the 120v to operate fridge, heat, and lights?

Perplexed on this one and hoping I can get support from my fellow camping friends here.
RockwoodRoo233s is offline   Reply With Quote
Old 05-08-2021, 08:57 AM   #2
Senior Member
 
SeaDog's Avatar
 
Join Date: Jan 2016
Location: Idaho
Posts: 9,172
welcome to the forum its a great place to get your questions answered It sounds like the converter has gone south and your batteries are dead. First take a multi meter and measure the 12V power from the converter should be something >13V disconnect your batteries and measure the voltage on each to see where they are at. If the converter has failed you can hookup a stand alone charger to your batteries to provide charging and power to your 12V equipment. Let the forum know what you find.
__________________
Retired Navy
Jake my sidekick (yellow Lab) 10/04 - 05/20
2017 RAM 2500 CC 4X4 Cummins Diesel
2016 Flagstaff 26 FKWS
AF&AM & El Korah Shrine of Idaho
SeaDog is online now   Reply With Quote
Old 05-08-2021, 09:06 AM   #3
Senior Member
 
fonzie's Avatar
 
Join Date: Sep 2010
Location: Eastern Ontario
Posts: 4,098
Is your battery hook up properly. If not, then change connections and check reverse polarity fuses in the distribution panel.
__________________
Fonzie
2011 Rockwood 8319SS with ProPride 3P hitch/GoodYear Marathons/TST TPMS 507
2019 F350 Ruby Red 6.7l diesel 3.31 axle electronic locker
Yamaha 3000iseb generator:Progressive Ind. EMS-HW30C : Eastern Ontario
Nights Camped: 2014 (18) 2015 (18) 2016 (36) 2017 (32) 2018 (42) 2019 (28) 2020 (35)
fonzie is online now   Reply With Quote
Old 05-08-2021, 09:22 AM   #4
Junior Member
 
Join Date: May 2021
Posts: 8
The battery is showing 2/3 good on the panel and checked reset button under a frame.
RockwoodRoo233s is offline   Reply With Quote
Old 05-08-2021, 09:24 AM   #5
Senior Member
 
rsdata's Avatar
 
Join Date: Aug 2014
Location: Northern KY
Posts: 4,775
Quote:
Is your battery hook up properly. If not, then change connections and check reverse polarity fuses in the distribution panel.
YES... did you change out or re-hook the battery correctly?

try dis-connecting the battery completely

and while there follow the battery cable to a 4x4 electric box with a small fuse with a small black push button and reset it AFTER disconnecting the battery...

hooked to shore power even without a battery you should get 12V lights inside
Attached Images
 
__________________
"nothing can now be believed which is seen in a newspaper. Truth itself becomes suspicious by being put into that polluted vehicle."
Thomas Jefferson to John Norvell pg. 2, June 11, 1807

2014 Shamrock 183
2014 RAM 1500 Bighorn Crew Cab, HEMI, 3.21 gears, 8 Spd, 4X4 TST TPMS
rsdata is offline   Reply With Quote
Old 05-08-2021, 09:25 AM   #6
Senior Member
 
rsdata's Avatar
 
Join Date: Aug 2014
Location: Northern KY
Posts: 4,775
2/3 good is NOT good... disconnect battery



do you have a volt meter? what is the voltage of the battery when disconnected?

if no meter pick up a $10 one from a hardware store...
__________________
"nothing can now be believed which is seen in a newspaper. Truth itself becomes suspicious by being put into that polluted vehicle."
Thomas Jefferson to John Norvell pg. 2, June 11, 1807

2014 Shamrock 183
2014 RAM 1500 Bighorn Crew Cab, HEMI, 3.21 gears, 8 Spd, 4X4 TST TPMS
rsdata is offline   Reply With Quote
Old 05-08-2021, 09:26 AM   #7
Junior Member
 
Join Date: May 2021
Posts: 8
Hi Seadog, thank you for your response.

The battery is showing 2/3 on the panel and also checked reset switch under the A Frame.
RockwoodRoo233s is offline   Reply With Quote
Old 05-08-2021, 09:32 AM   #8
Site Team
 
Mr. Dan's Avatar
 
Join Date: Mar 2014
Location: Grayson County, Texas
Posts: 16,793
Check the breaker for your converter. If you’re plugged into shore power, the panel monitor for battery should be showing all 4 lights - indicating the converter is charging the battery regardless of the battery’s charge level.
__________________
FR Wildcat 295RSX / GMC Sierra

Nights Camped: '13 = 49/'14 = 74/'15 = 74/'16 = 85/'17 = 110/'18 = 111/'19 = 86/'20 =108/'21 = 42; Booked = 36
Mr. Dan is offline   Reply With Quote
Old 05-08-2021, 09:44 AM   #9
Junior Member
 
Join Date: May 2021
Posts: 8
Ok, disconnected battery and reset switch and still no lights inside ....
RockwoodRoo233s is offline   Reply With Quote
Old 05-08-2021, 09:45 AM   #10
Junior Member
 
Join Date: May 2021
Posts: 8
Thank you, i reset breaker and still no lights...
RockwoodRoo233s is offline   Reply With Quote
Old 05-08-2021, 09:50 AM   #11
Junior Member
 
Join Date: May 2021
Posts: 8
Thank you for your response.

Battery disconnected as suggested
RockwoodRoo233s is offline   Reply With Quote
Old 05-08-2021, 10:06 AM   #12
Junior Member
 
Join Date: May 2021
Posts: 8
Reset breaker and no change... no 12v lights
RockwoodRoo233s is offline   Reply With Quote
Old 05-08-2021, 11:51 AM   #13
Junior Member
 
Join Date: May 2021
Posts: 8
Thank you SeaDog for your insight.

I measured the batteries and reading 5.3 and 7.2 volts on each. When measuring the converter, not getting any measurement reading from the converter. Im at a loss here...
RockwoodRoo233s is offline   Reply With Quote
Old 05-08-2021, 12:16 PM   #14
Senior Member
 
rsdata's Avatar
 
Join Date: Aug 2014
Location: Northern KY
Posts: 4,775
Quote:
I measured the batteries and reading 5.3 and 7.2 volts on each. When measuring the converter, not getting any measurement reading from the converter. Im at a loss here...
First and foremost the batteries are shot... there is no recovering a battery that is that low.

The converter may also be shot... but let's not jump to that yet.

Can you buy or borrow just one battery to put into the trailer?

Make sure it is hooked up right. One battery should power the lights.

I would disconnect from shore power when doing this.
__________________
"nothing can now be believed which is seen in a newspaper. Truth itself becomes suspicious by being put into that polluted vehicle."
Thomas Jefferson to John Norvell pg. 2, June 11, 1807

2014 Shamrock 183
2014 RAM 1500 Bighorn Crew Cab, HEMI, 3.21 gears, 8 Spd, 4X4 TST TPMS
rsdata is offline   Reply With Quote
Old 05-08-2021, 12:18 PM   #15
Site Team
 
bikendan's Avatar
 
Join Date: Jan 2007
Location: Camano Island, Washington
Posts: 25,638
Quote:
Originally Posted by RockwoodRoo233s View Post
Thank you SeaDog for your insight.

I measured the batteries and reading 5.3 and 7.2 volts on each. When measuring the converter, not getting any measurement reading from the converter. Im at a loss here...
Clearly your battery are dead and probably not recoverable. That's why you don't use the battery idiot lights while plugged into shore power.
And if you're plugged into shore power and you measured the converter correctly, then the converter is bad.
__________________
Dan-Retired California Firefighter/EMT
Shawn-Musician/Entrepreneur/Wine Expert
and Zoe the Wonder Dog(R.I.P.)
2016 PrimeTime TracerAIR 255, pushing a 2014 Ford F150 SCREW XTR 4x4 3.5 Ecoboost w/Max Tow Package
4pt Equal-i-zer WDH and 1828lbs of payload capacity
bikendan is offline   Reply With Quote
Old 05-08-2021, 12:42 PM   #16
Senior Member
 
Join Date: Jan 2020
Posts: 1,410
My guess is the converter went bad, then the batteries ran down, and now you have nothing left - bad converter and dead batteries.
NavyLCDR is offline   Reply With Quote
Old 05-08-2021, 12:55 PM   #17
Senior Member
 
Join Date: Jan 2018
Location: Raleigh, NC
Posts: 4,350
Jumper Cables!

Quote:
Originally Posted by rsdata View Post
First and foremost the batteries are shot... there is no recovering a battery that is that low.

The converter may also be shot... but let's not jump to that yet.

Can you buy or borrow just one battery to put into the trailer?

Make sure it is hooked up right. One battery should power the lights.

I would disconnect from shore power when doing this.
For this test, the OP could just use jumper cables from his tow vehicle with the trailer batteries disconnected.
__________________
Larry

Sticks and Bricks: Raleigh, NC
2008 Cherokee 38P: at Ivor, VA permanently
Larry-NC is offline   Reply With Quote
Old 05-08-2021, 02:00 PM   #18
Senior Member
 
Tom48's Avatar
 
Join Date: Apr 2015
Location: Ontario, California
Posts: 1,643
Quote:
Originally Posted by NavyLCDR View Post
My guess is the converter went bad, then the batteries ran down, and now you have nothing left - bad converter and dead batteries.
Did I miss it. Reverse polarity fuses need to both be good.

If the idiot lights showed two thirds, the converter/charger might be trying
__________________
Tom48
In Sunny So Cal /w
Now in 2005 Holiday Rambler Ambassador DP and The Hot Air Balloon RESTLESS
NO MORE Tricked out
2017 Sandstorm 250 T.H.
Tom48 is offline   Reply With Quote
Old 05-08-2021, 02:04 PM   #19
Senior Member
 
Join Date: May 2015
Location: Dunn, NC
Posts: 1,139
12v power

I had a similar problem turned out to be a dirty(crappy) ground from battery to frame. Wire brush and scrape some paint from frame. Re spot paint when all reconnected
pdqparalegal1 is offline   Reply With Quote
Old 05-08-2021, 02:13 PM   #20
RiderBloke
 
RiderBloke's Avatar
 
Join Date: Jan 2014
Location: On the Road
Posts: 443
Quote:
Originally Posted by RockwoodRoo233s View Post
Thank you SeaDog for your insight.

I measured the batteries and reading 5.3 and 7.2 volts on each. When measuring the converter, not getting any measurement reading from the converter. Im at a loss here...

I think the replies have it right; however just another check - have you checked the breaker that powers the converter? It may have been turned off for some reason OR have blown when the batteries being so low were connected. Good luck with fixing this problem.
__________________
Retired Intentional Interim Minister
Member of the BMW MOA
Saginaw Valley BMW Riders
RiderBloke is offline   Reply With Quote
Reply

Tags
233, 233s, power, roo

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



All times are GMT -5. The time now is 06:57 AM.