Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×


Reply
 
Thread Tools Display Modes
Old 08-28-2021, 12:21 AM   #1
Junior Member
 
Join Date: Jul 2016
Posts: 9
USB charging station not working.

My Rockwood Signature Ultralite has a USB charging station in the bedroom.

Very simply, it doesn't work.

Any ideas?
MICHAEL123 is offline   Reply With Quote
Old 08-28-2021, 06:06 AM   #2
Senior Member
 
Join Date: Jan 2020
Posts: 1,960
Remove the screws holding it in place, pull it out, check the wiring going to the unit for 12 volts DC. If the wires have 12 volts DC, then the charging unit itself is bad. If the wires don't have 12 volts DC, then you will need to continue troubleshooting to find out why.
NavyLCDR is offline   Reply With Quote
Old 08-28-2021, 06:48 AM   #3
Senior Member
 
Join Date: May 2018
Location: Odessa
Posts: 115
I had to replace mine last year.
Amazon.
__________________
Clipper 17BH.
Chevy Avalanche 5.3
Chevy Tahoe 5.3
Tblt44 is offline   Reply With Quote
Old 08-28-2021, 07:20 AM   #4
Junior Member
 
Join Date: Jan 2021
Location: Darien Center, NY
Posts: 6
Our USB ports were not working and I found out that they were wired into the ground fault circuit. Reset the breaker and everything worked fine. Good luck.o
CGJT is online now   Reply With Quote
Old 10-19-2021, 08:32 PM   #5
Member
 
Join Date: Nov 2018
Posts: 60
Having the same issue with our "Charging Station" in the bedroom panel. Neither USB or 12V Socket has power. Took the panel off and the wires connecting the have no power.

Where is the Ground Fault Circuit I can reset?
Delnari is offline   Reply With Quote
Old 10-19-2021, 08:50 PM   #6
Senior Member
 
Join Date: Jul 2017
Location: North of Seattle, WA
Posts: 13,435
Some USB charging stations receive power from 120v shore power and some from the 12v battery system.

If from 12volt system resetting a gfci won't help.

The 12v powered ststions will more likely than not have a fuse somewhere. It will be necessary to trace wires to a power source.

The zuSB charging station in my MicroLite quit and I just replaced with a new one I liked better. New one supports fast charging and led illumination to make outlets rasier to see in dark or dim lighting.

Good luck.
__________________
"A wise man can change his mind. A fool never will."

"You only grow old when you run out of new things to do"

2018 Flagstaff Micro Lite 25BDS
2004 Nissan Titan
TitanMike is offline   Reply With Quote
Old 10-19-2021, 09:18 PM   #7
Member
 
Join Date: Nov 2018
Posts: 60
I watched a YouTube video showing there is a fuse block breaker from the battery under the trailer that has a reset switch on it. Will look for that in the morning and see if I reset it from there.
Delnari is offline   Reply With Quote
Old 10-20-2021, 11:18 PM   #8
Member
 
Join Date: Nov 2018
Posts: 60
Quote:
Originally Posted by Delnari View Post
I watched a YouTube video showing there is a fuse block breaker from the battery under the trailer that has a reset switch on it. Will look for that in the morning and see if I reset it from there.
All the power blocks coming from the battery connections are fine. Tested all the terminals with a multimeter today. Moving on the next troubleshooting tasks.
Delnari is offline   Reply With Quote
Old 10-20-2021, 11:21 PM   #9
Member
 
Join Date: Nov 2018
Posts: 60
I was able to trace the non-working issue to no power on the cable connection to the Charging Center (neither 12V socket or USB ports are getting power). I pulled the Charger Center out and tested it with a 12V power source and both socket and USBs are working fine when powered externally. To add, the USB port on the radio front is also not working.

The issue seems to be along the 12V power source cable in the RV. When you look at the connections behind the Charging Center you find 2 sets of power wires spliced together (red/white and orange/white) with the positives connected together and the negatives connected together that feed the 12V power to it. Appears there is another device along the cable that connected; maybe the radio USB port?

I will pull the radio off the wall next and see if maybe there is an inline fuse from this power line to the radio USB that has failed. Will report back what I find.
Delnari is offline   Reply With Quote
Old 10-21-2021, 08:03 PM   #10
Member
 
Join Date: Nov 2018
Posts: 60
The fuse behind the radio was blown. I replaced it and now have USB power at the radio. The Charging Center is still dead. Will need to get Forest River tech on the phone in the future to help troubleshoot.
Delnari is offline   Reply With Quote
Old 11-15-2021, 12:10 PM   #11
Junior Member
 
Join Date: Aug 2021
Posts: 12
Anything ever come of this?

Quote:
Originally Posted by Delnari View Post
The fuse behind the radio was blown. I replaced it and now have USB power at the radio. The Charging Center is still dead. Will need to get Forest River tech on the phone in the future to help troubleshoot.
An old post but I am having the same issue in my Freedom Express... both nightstand USB chargers not working. The one in the radio panel works fine. I have not looked at some of the other things noted in original discussion, but will. Just wondering what the outcome was.
__________________
2018 Coachmen Freedom Express Ultra Lite 246RKS
Towed by 2015 F150 SuperCrew w/2.7L Eco Boost
LonestarGuy is offline   Reply With Quote
Old 11-15-2021, 01:59 PM   #12
Member
 
Join Date: Nov 2018
Posts: 60
Going to pull out the entire fuse panel box this week and see if I can trace the wires back behind the panel to the Charging Station. There is a power disconnect somewhere.
Delnari is offline   Reply With Quote
Old 11-15-2021, 02:26 PM   #13
Senior Member
 
Join Date: Jul 2017
Location: North of Seattle, WA
Posts: 13,435
Quote:
Originally Posted by LonestarGuy View Post
An old post but I am having the same issue in my Freedom Express... both nightstand USB chargers not working. The one in the radio panel works fine. I have not looked at some of the other things noted in original discussion, but will. Just wondering what the outcome was.
Have you pulled the charging station from it's mount and checked to see if there is 12 volt power coming to it from the battery? First step in diagnosing non working electrical devices is checking to see if they actually have power to them.

Quote:
Originally Posted by Delnari View Post
Going to pull out the entire fuse panel box this week and see if I can trace the wires back behind the panel to the Charging Station. There is a power disconnect somewhere.

Most likely an inline fuse hidden from view somewhere in the power supply wire. Perhaps even an internal fuse in the device itself.

I had a charging station stop working after 4 years and checked power wire at the butt connectors. There was 12V power there so I just removed the charging station and replaced it with a new one. New one has more outlets and even a "smart charge" one for newer devices.

Wasn't expensive and I saved a lot of time messing with the old one.
__________________
"A wise man can change his mind. A fool never will."

"You only grow old when you run out of new things to do"

2018 Flagstaff Micro Lite 25BDS
2004 Nissan Titan
TitanMike is offline   Reply With Quote
Old 11-15-2021, 05:02 PM   #14
Member
 
Join Date: Nov 2018
Posts: 60
Quote:
Originally Posted by LonestarGuy View Post
An old post but I am having the same issue in my Freedom Express... both nightstand USB chargers not working. The one in the radio panel works fine. I have not looked at some of the other things noted in original discussion, but will. Just wondering what the outcome was.
Yes, no power on wire pair behind the Charging Station. Will trace the wires to the fuse panel and test for power there.
Delnari is offline   Reply With Quote
Old 11-16-2021, 10:06 AM   #15
KSH
Senior Member
 
Join Date: Jun 2015
Posts: 304
I had this problem on my previous trailer. Pulled the unit out of the wall, called the mfg of the unit and they sent me a new one.
KSH is offline   Reply With Quote
Old 11-16-2021, 10:11 AM   #16
Member
 
Join Date: Nov 2018
Posts: 60
Quote:
Originally Posted by KSH View Post
I had this problem on my previous trailer. Pulled the unit out of the wall, called the mfg of the unit and they sent me a new one.
The unit is fine. Pulled and connected to a 12V source and works fine. There is no power on the wires connected to it in the trailer. Somehow the power was killed to it. Need to find where the power disconnect is.
Delnari is offline   Reply With Quote
Old 11-16-2021, 09:16 PM   #17
Senior Member
 
Join Date: Jul 2017
Location: North of Seattle, WA
Posts: 13,435
Quote:
Originally Posted by Delnari View Post
The unit is fine. Pulled and connected to a 12V source and works fine. There is no power on the wires connected to it in the trailer. Somehow the power was killed to it. Need to find where the power disconnect is.
Look for an inline fuse along the wire feeding the USB charge station. Could also be a broken wire somewhere betwern fuse panel and charge station.

It will be necessary to trace that wire along it's path, including negative wire, to find break or bad connection if there is no blown fuse indicator lit in power distribution center ( where fuses, breakers, and converter are located).
__________________
"A wise man can change his mind. A fool never will."

"You only grow old when you run out of new things to do"

2018 Flagstaff Micro Lite 25BDS
2004 Nissan Titan
TitanMike is offline   Reply With Quote
Old 11-16-2021, 09:36 PM   #18
Member
 
Join Date: Nov 2018
Posts: 60
Quote:
Originally Posted by TitanMike View Post
Look for an inline fuse along the wire feeding the USB charge station. Could also be a broken wire somewhere betwern fuse panel and charge station.

It will be necessary to trace that wire along it's path, including negative wire, to find break or bad connection if there is no blown fuse indicator lit in power distribution center ( where fuses, breakers, and converter are located).
I pulled the cover off the fuse panel and see the color pair of wires that feed the Charging Station. Power is coming out of the fuse panel as it should. There is a break in the wire(s) along the path from the power source to the USB ports. Given the underbelly cover and not sure what the wire path is from the fuse panel back to the USB ports I'm not going to attempt tracing the wire(s).

I can live without the USB ports for a while. Once I get back to my home location I will run a new set of 12V power leads with an inline fuse from the power block coming from the battery. It measure about 5 feet of total run from the power block to the USB ports, so it's the easy fix.
Delnari is offline   Reply With Quote
Reply

Tags
charging

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



All times are GMT -5. The time now is 07:26 AM.