Free 7 Day Trial RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Free 7 Day Trial ×


Reply
 
Thread Tools Display Modes
Old 05-19-2015, 09:26 PM   #1
KBS
Junior Member
 
Join Date: May 2015
Posts: 2
Brakes not working

2007 Salem 26'.

This might be an old topic, but my Salem has sat idle for a few seasons, and now the trailer brakes are not working. The green indicator light on the brake controller is not lighting up. There is power to all terminals in the wiring harness at the hitch.

What are some troubleshooting suggestions?

Karl
KBS is offline   Reply With Quote
Old 05-19-2015, 09:32 PM   #2
Senior Member
 
Stormrider151's Avatar
 
Join Date: Sep 2011
Location: South East
Posts: 995
I have had corrosion of the terminals at the plug. I take a small file and clean the corrosion away. If has been unused that could be the problem.
__________________
Retired Fire Dept Battalion Chief
2016 Ever-Lite 232RBS
2012 F150 FX4 W/Max tow & Ecoboost (Best tv ever)
2018 F250 Lariat (ok but I miss my F150)

Getting old ain't for wimps!!!
Stormrider151 is offline   Reply With Quote
Old 05-19-2015, 09:52 PM   #3
KBS
Junior Member
 
Join Date: May 2015
Posts: 2
I sprayed some WD40 on the plug ends, but I'll go at it with a wire toothbrush; see if that helps.
KBS is offline   Reply With Quote
Reply

Tags
brakes

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



All times are GMT -5. The time now is 02:35 AM.