Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×


Reply
 
Thread Tools Display Modes
Old 04-22-2021, 08:07 PM   #1
Junior Member
 
Join Date: Apr 2021
Posts: 4
No heat

So i went to turn on my Suburban furnace NT30SP for the first time this year and no heat i can hear clicking and smell gas but it wont light any help would be greatly appreciated this camper is new to me it is a Rockwood
robertbm is offline   Reply With Quote
Old 04-23-2021, 07:50 AM   #2
Senior Member
 
SeaDog's Avatar
 
Join Date: Jan 2016
Location: Idaho
Posts: 11,401
welcome to the forum its a great place to get your questions answered. Use the internet and pull down the troubleshooting guide for your furnace. It could be a problem caused by spider webs or the sail switch . I use air to blow out my combustion air and exhaust before each season to eliminate webs and such
__________________
Retired Navy
Jake my sidekick (yellow Lab) 10/04 - 05/20
2017 RAM 2500 CC 4X4 Cummins Diesel
2016 Flagstaff 26 FKWS
AF&AM & El Korah Shrine of Idaho
SeaDog is offline   Reply With Quote
Old 04-23-2021, 08:40 AM   #3
Junior Member
 
Join Date: Apr 2021
Posts: 4
thank you i will give that a try
robertbm is offline   Reply With Quote
Old 04-23-2021, 11:43 AM   #4
Junior Member
 
Join Date: Apr 2021
Posts: 4
i took the furnace out and checked the sail switch and all was good cleaned everything
still no a no go on it lighting my stove also has low flame
robertbm is offline   Reply With Quote
Old 04-23-2021, 11:48 AM   #5
Fully COVID-19 vaccinated
 
Join Date: Apr 2016
Location: About 30 miles west of Beantown.
Posts: 3,937
Did you purge the air out of the propane lines? I typically turn on a stove burner and hold a lighter next to it until it lights.
__________________

2021 Transcend Xplor 247BH
Husky WDH with Sway Control
2021 Chevy Silverado 2500HD LT 6.6L V8 Duramax
Forever in my memory. Forever in my heart.
Laurie J. Wood 3/22/67 - 8/23/19
timfromma is offline   Reply With Quote
Old 04-23-2021, 11:59 AM   #6
Senior Member
 
Join Date: Feb 2018
Location: TEXAS
Posts: 5,738
Quote:
Originally Posted by robertbm View Post
still no a no go on it lighting my stove also has low flame
You need to keep that stove lit until all the air is purged from the system and you get a good flame. If the stove doesn't get a good flame, then you've got a propane supply problem.
__________________
2015 Dynamax REV 24TB class C
Reverse_snowbird is online now   Reply With Quote
Old 04-23-2021, 12:01 PM   #7
Pickin', Campin', Mason
 
5picker's Avatar
 
Join Date: Aug 2015
Location: South Western PA
Posts: 15,942
Quote:
Originally Posted by robertbm View Post
i took the furnace out and checked the sail switch and all was good cleaned everything
still no a no go on it lighting my stove also has low flame
Big LP use items like the furnace and the water heater require that you be able to light all the burners on the stove on high and have a good flame before considering the possibility there is something wrong with them.

If you don't have good flame at the stove you should start by investigating whether you have a LP supply issue.
__________________
_________________________________________
2016 Flagstaff 8529IKBS Diamond Package 5th Wheel•Goodyear Endurance Tires•2017 Ford F-Series SCREW 4x4•Factory Puck•B&W Companion•TST Tire Monitor w/Repeater•Sinemate 3500w Gen.
F&AM Lodge 358 Somerset, PA - JAFFA Shrine - Altoona, PA

Days Camped: '17=38 '18=49 '19=58 '20=110 '21=116 '22=90
5picker is offline   Reply With Quote
Old 04-23-2021, 12:03 PM   #8
Kanadian Kamper
 
kenandterry's Avatar
 
Join Date: Sep 2010
Location: Southern Ontario
Posts: 6,008
Quote:
Originally Posted by robertbm View Post
i took the furnace out and checked the sail switch and all was good cleaned everything
still no a no go on it lighting my stove also has low flame
So.....we’re assuming you have lots of propane right?
Turn the valve closed. Wait a minute. Then open it slowly to full open.
Make sure all stove burners work properly for at least 1 minute.
Assuming battery is good....try furnace again.
If you have water in your system, try your propane water heater, and test for hot water.
__________________

Ken and Terry
2018 Sunseeker 2430S-CD carried by a 2017 Ford E450
Former Georgetown 330TS owner for 10 years with more mods than I can count.
kenandterry is offline   Reply With Quote
Old 04-23-2021, 02:35 PM   #9
Senior Member
 
Tombsy's Avatar
 
Join Date: Sep 2015
Posts: 750
When my built in regulator (motorhome) got stuck in low flow mode the furnace wouldn’t light but I had one burner that would light and a second burner that had a low flame.
The first time it happened I replaced the regulator but the second time hot water got it to reset.
I believe the low flow is built into your tank valves and Kenandterry gave you the procedure to reset them.
__________________
Brian
2015 Forester 2801QS GTS
TOAD-Hobie Mirage Pro Angler 14 kayak and Yamaha Zuma 50cc scooter on a custom trailer.
Tombsy is offline   Reply With Quote
Old 04-24-2021, 09:44 PM   #10
Junior Member
 
Join Date: Apr 2021
Posts: 4
I would like to thank you all for your input . I got it all fixed all is good now camping hear we come .
robertbm is offline   Reply With Quote
Old 04-24-2021, 11:11 PM   #11
Site Team
 
bikendan's Avatar
 
Join Date: Jan 2007
Location: Goodyear, Arizona
Posts: 28,744
Quote:
Originally Posted by robertbm View Post
I would like to thank you all for your input . I got it all fixed all is good now camping hear we come .
It would help others if you posted what the fix/solution was.
__________________
Dan-Retired California Firefighter/EMT
Shawn-Musician/Entrepreneur/Wine Expert
and Zoe the Wonder Dog(R.I.P.)
2016 PrimeTime TracerAIR 255, pushing a 2014 Ford F150 SCREW XTR 4x4 3.5 Ecoboost w/Max Tow Package
4pt Equal-i-zer WDH and 1828lbs of payload capacity
bikendan is offline   Reply With Quote
Old 04-25-2021, 07:34 AM   #12
Pickin', Campin', Mason
 
5picker's Avatar
 
Join Date: Aug 2015
Location: South Western PA
Posts: 15,942
Quote:
Originally Posted by robertbm View Post
I would like to thank you all for your input . I got it all fixed all is good now camping hear we come .
Glad everything is in order and thanks for letting us know.

Could you possibly share what fixed it so if others have a similar issue, maybe your fix will help them?
__________________
_________________________________________
2016 Flagstaff 8529IKBS Diamond Package 5th Wheel•Goodyear Endurance Tires•2017 Ford F-Series SCREW 4x4•Factory Puck•B&W Companion•TST Tire Monitor w/Repeater•Sinemate 3500w Gen.
F&AM Lodge 358 Somerset, PA - JAFFA Shrine - Altoona, PA

Days Camped: '17=38 '18=49 '19=58 '20=110 '21=116 '22=90
5picker is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



All times are GMT -5. The time now is 08:22 PM.