Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×


Reply
 
Thread Tools Display Modes
Old 12-28-2020, 11:34 AM   #1
Junior Member
 
Join Date: Nov 2020
Location: Chicagoland
Posts: 3
21 Cruise Lite Slide Out Unplugger

Good morning RV'ers!

I had an issue when I tried to bring in my slide out. The right side (front side) motor stopped functioning when I tried to bring it in. I investigated and discovered that the motor came unplugged from the wire that's run along the bottom of the slide and up the side seal. I reconnected the wire but it still seems like it can come disconnected very easily. Is this wire supposed to snap together in a more firm fashion and maybe the clip on mine has broken? Seems like a kind of poor design if not. Let me know what you think.

Jason
CleverName is offline   Reply With Quote
Old 12-28-2020, 02:56 PM   #2
Site Team
 
Join Date: Mar 2008
Location: Southwest Alabama
Posts: 9,211
Sounds like you have a Schwintek slide system. Those conncetors are friction fit, but there's nothing stopping you from putting a little wire tie or some electrical tape around it to keep it from pulling apart.
__________________
Salem 29RKSS Pushing a GMC Sierra 2500HD!
Gotta go campin!
Bama Rambler is online now   Reply With Quote
Reply

Tags
lite, slide, slide out

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



All times are GMT -5. The time now is 02:35 PM.