Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×


Reply
 
Thread Tools Display Modes
Old 06-27-2021, 12:30 AM   #1
Junior Member
 
Join Date: May 2021
Posts: 14
one-connect/slide issue

2021 epro E20BHS
I have a brand new E20BHS, I'm prepping to go on the first camping trip with it and the slide wouldn't retract.

The behavior is: when I press retract (using phone or switch), all of the internal lights flash and I can hear a click in the one-connect box, but the slide doesn't retract. There are no codes on the controller box in the slide, although my phone says there is a "fault".

Now, I think the phone says fault, but it's not getting a code from the slide controller, one-connect is giving a fault.

So, after a bunch of troubleshooting... I got the slide to retract buy disconnecting the wire from the retract terminal and connecting the send wire. Then press extend on the switch and it retracts. Switch the wire again and I can extend. So camping trip saved.

My thought is that the one-connect controller is bad or possibly it can be programmed? Maybe just use one of the other 30 amp circuits since I only have the one slide, there are 2 other 30 amp circuits.

The other option is to take the 2 wires that go from the one connect box to the slide controller and connect them to the switch directly and then it will work normally, I just won't be able to control it from my phone.

Of course this is all under warranty, so I guess I should take it in after my camping trip.

Any other ideas?
stecz is offline   Reply With Quote
Old 06-27-2021, 07:28 AM   #2
Senior Member
 
SeaDog's Avatar
 
Join Date: Jan 2016
Location: Idaho
Posts: 9,487
Have you considered it may be the switch?
__________________
Retired Navy
Jake my sidekick (yellow Lab) 10/04 - 05/20
2017 RAM 2500 CC 4X4 Cummins Diesel
2016 Flagstaff 26 FKWS
AF&AM & El Korah Shrine of Idaho
SeaDog is online now   Reply With Quote
Old 06-27-2021, 07:50 AM   #3
Junior Member
 
Join Date: May 2021
Posts: 14
Is it the switch?

a few reasons it's not the switch...
1: I swapped the switch for the awning switch, which works fine, no change in behavior
2: When I activate retract on the slide, it flashes all of the interior lights, not just dims them as if there isn't enough power, also there is plenty of power to run the front jack
3: When I activate the slide from my phone, I get the exact same behavior, click and all interior lights flash.

Based on my late-night troubleshooting, I really think it's the one-connect box.
stecz is offline   Reply With Quote
Old 07-23-2021, 09:16 AM   #4
Junior Member
 
Join Date: May 2021
Posts: 14
I figured I would follow up on this... After I got the slide to go in, I decided to connect the wires correctly, and the slide has never acted up again. It's worked perfectly. So I'm not sure what the deal was. I'm still convinced it has something to do with the one-connect controller.

Oh well.
stecz is offline   Reply With Quote
Old 07-23-2021, 04:55 PM   #5
Junior Member
 
Join Date: May 2021
Posts: 14
of course it happens...

Right after I posted that the slide had been in and out multiple times without an issue, it does the exact same thing as I'm getting ready to leave Carlsbad, NM. I switched the wires, used the extend button and it came right in. So it's not mechanical.

It's got to b something with one-connect.
stecz is offline   Reply With Quote
Reply

Tags
slide

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



All times are GMT -5. The time now is 09:26 PM.