Reply
 
Thread Tools Display Modes
Old 10-10-2016, 10:17 PM   #1
7 Year Class A RV'er
 
Join Date: Oct 2014
Location: Winter Park, FL
Posts: 1,064
Transmission Issues Anyone?

Just a heads up that may save someone some trouble down the line. For a while now, I've been having a minor issue with difficulty in putting the transmission on the Legacy into D. Trouble was intermittent and always resolved with a little messing with the electronic shifter. I mentioned it to the Freightliner folks last time I was in for maintenance but I was in a hurry and they needed to keep it if they were going to figure out the problem. Fast forward now to last Saturday afternoon, coming west on I-40 in West Memphis, AR. This stretch of road is AWFUL! Drove over a rough section and suddenly I gave a message up on the display indicating TRANS COMM FAILED. The speedometer quit working and the system dropped into Limp Home mode. Luckily, we found a KOA about 12 miles away with an opening, limped over and sat out the weekend until Freightliner in Memphis opened (Monday). Had it towed in this morning and found the problem. The data cable from the transmission to the main computer failed due to water infiltration at the transmission end causing corrosion of the connector pins. Tech says 36 of the 72 pins in the connector broke, apparently when driving over the rough roadway. New cable is ordered and will be in the morning, couple of hours to install and then hopefully we'll get back on the road. Long story short, if you start having any problems getting into gear, you may want to get this checked. Just glad we weren't another hour into our trip and in the middle of nowhere when things came down. Nobody's fault, just one of those things to watch out for. Stay safe.


Sent from my iPad using Forest River Forums
2015 Legacy SR340 360RB with 2014 Wrangler Unlimited Toad
Gigi, Poppy and Sadie the Jack Russell (all 14 lbs of her)
__________________
2015 Legacy SR340 360RB
2014 Jeep Wrangler Unlimited Toad

Gigi, Poppy and Sadie Lady...On the road, but not full time!
conceptumator is offline   Reply With Quote
Old 10-10-2016, 11:46 PM   #2
Senior Member
 
rsdata's Avatar
 
Join Date: Aug 2014
Location: Northern KY
Posts: 3,779
with all of the computer related electrical connections to sensors, engines, transmissions, brakes, and whatnot, I am surprised there is not more corroded connections making intermittent electrical problems like this reported...
__________________
ďToo much of anything is bad, but too much good whiskey is barely enough.Ē Ė Mark Twain



2014 Shamrock 183
2014 RAM 1500 Bighorn Crew Cab, HEMI, 3.21 gears, 8 Spd, 4X4 TST TPMS
rsdata is offline   Reply With Quote
Old 10-11-2016, 08:21 AM   #3
Senior Member
 
DrJAG's Avatar
 
Join Date: Apr 2015
Posts: 210
Sorry to hear about your trouble. Glad you were relatively close to campground and Freightliner shop. Let us know if Freightliner does anything to new cable to prevent this from happening again.


2015 Legacy RB, 2013 CRV toad. Retired USAF. Sent from my iPad using Forest River Forums
__________________
-DrJAG
2015 Legacy 360RB with 2013 CRV toad. Retired USAF.
DrJAG is offline   Reply With Quote
Old 10-11-2016, 10:21 PM   #4
7 Year Class A RV'er
 
Join Date: Oct 2014
Location: Winter Park, FL
Posts: 1,064
I was just posting a shout out for the great service the TAG Truck Center Freightliner folks gave us. Had us on the road within a couple of hours of receiving the part this morning. Great folks! As far as preventing the problem, it appears there are seals on the plug that caused the issue and those seals simply failed. No idea why, just something that happened. All fixed now and going great. If you need service in Memphis, go to a TAG Truck Center on Brooks Ave.


Sent from my iPad using Forest River Forums
2015 Legacy SR340 360RB with 2014 Wrangler Unlimited Toad
Gigi, Poppy and Sadie the Jack Russell (all 14 lbs of her)
__________________
2015 Legacy SR340 360RB
2014 Jeep Wrangler Unlimited Toad

Gigi, Poppy and Sadie Lady...On the road, but not full time!
conceptumator is offline   Reply With Quote
Old 10-12-2016, 06:20 AM   #5
Senior Member
 
DrJAG's Avatar
 
Join Date: Apr 2015
Posts: 210
Good to hear you are are on the road again.


2015 Legacy RB, 2013 CRV toad. Retired USAF. Sent from my iPad using Forest River Forums
__________________
-DrJAG
2015 Legacy 360RB with 2013 CRV toad. Retired USAF.
DrJAG is offline   Reply With Quote
Old 10-12-2016, 10:34 AM   #6
7 Year Class A RV'er
 
Join Date: Oct 2014
Location: Winter Park, FL
Posts: 1,064
Thanks, DrJAG - Enjoyed meeting you guys in Nashville. Hope all went well on your trip home. We've still got about three weeks on the road before we get home for two nights, then off to Fort Wilderness for four more nights. Got to make good use of the RV while we can! ��
__________________
2015 Legacy SR340 360RB
2014 Jeep Wrangler Unlimited Toad

Gigi, Poppy and Sadie Lady...On the road, but not full time!
conceptumator is offline   Reply With Quote
Old 10-13-2016, 04:04 PM   #7
Senior Member
 
aeroshots's Avatar
 
Join Date: Jun 2015
Location: Florida
Posts: 169
Man, you are correct about those roads in West Memphis. They've been awful since the early 70's. Thanks for the heads up. On the to do list for inspection.
__________________
..2016 Legacy 340KP SR340, 10,500 Miles..
aeroshots is offline   Reply With Quote
Old 10-13-2016, 05:56 PM   #8
7 Year Class A RV'er
 
Join Date: Oct 2014
Location: Winter Park, FL
Posts: 1,064
Yep, those roads are terrible! It was interesting talking to the wrecker driver that brought us in. He seemed to know every bump, dip, hole, etc. for miles around. His suggestion? When driving I-40, stay in the left lane and just let some folks be upset about it. Better than destroying your coach. On the westbound side, watch out between MM 268 and 271...that right lane is like a mountain range!


Sent from my iPad using Forest River Forums
2015 Legacy SR340 360RB with 2014 Wrangler Unlimited Toad
Gigi, Poppy and Sadie the Jack Russell (all 14 lbs of her)
__________________
2015 Legacy SR340 360RB
2014 Jeep Wrangler Unlimited Toad

Gigi, Poppy and Sadie Lady...On the road, but not full time!
conceptumator is offline   Reply With Quote
Old 10-19-2016, 07:02 PM   #9
Junior Member
 
Join Date: Sep 2015
Location: Pennsylvania
Posts: 8
Now you have me worried. I've been having same kind of intermittent problem of getting transmission into D. I keep hitting D and nothing happens. After sitting there a few minutes wondering what I'm doing wrong it goes into gear. It didn't leave me sitting yet but I guess I need to look into this issue. Have 2016 Legacy 340KP. At this point nothing surprise's me, although all my complaints to this point are with the coach builder, not the chassis. My 5th RV and absolutely worst experience with an RV. A little quality control would go a long way. Thanks for the heads up.
Jimmybob is offline   Reply With Quote
Old 10-19-2016, 07:34 PM   #10
7 Year Class A RV'er
 
Join Date: Oct 2014
Location: Winter Park, FL
Posts: 1,064
Same transmission and same probl I've been having. The cable replacement didn't fix it, so I'm taking it to the shop when we get home. In the interim, I seem to have found a workaround for the issue. Try putting it in R, then on D. Works every time for me. I'll post what I find out once I get it in the shop at home.
__________________
2015 Legacy SR340 360RB
2014 Jeep Wrangler Unlimited Toad

Gigi, Poppy and Sadie Lady...On the road, but not full time!
conceptumator is offline   Reply With Quote
Old 10-19-2016, 09:05 PM   #11
Senior Member
 
aeroshots's Avatar
 
Join Date: Jun 2015
Location: Florida
Posts: 169
I don't know if this will help, but... the technician that walked me around my camper when I purchased it said to always select neutral between shifts. In other words, don't go from d to R or R to d without selecting N first. Y'all might be doing that already. Just throwing it out there.
__________________
..2016 Legacy 340KP SR340, 10,500 Miles..
aeroshots is offline   Reply With Quote
Old 10-19-2016, 09:17 PM   #12
7 Year Class A RV'er
 
Join Date: Oct 2014
Location: Winter Park, FL
Posts: 1,064
That's the problem, though....it won't engage to D from N most times. Doesn't seem to be a problem going from N to R, do I go N to R, pause for a second at idle, then go R to D.
__________________
2015 Legacy SR340 360RB
2014 Jeep Wrangler Unlimited Toad

Gigi, Poppy and Sadie Lady...On the road, but not full time!
conceptumator is offline   Reply With Quote
Old 10-20-2016, 06:52 AM   #13
Senior Member
 
aeroshots's Avatar
 
Join Date: Jun 2015
Location: Florida
Posts: 169
Quote:
Originally Posted by conceptumator View Post
That's the problem, though....it won't engage to D from N most times. Doesn't seem to be a problem going from N to R, do I go N to R, pause for a second at idle, then go R to D.
Sounds like it still needs work. I'd try any combination if n between d and R or R and d did not work. I despise intermittent issues like this. Sorry you are having it.
aeroshots is offline   Reply With Quote
Old 10-20-2016, 10:05 AM   #14
7 Year Class A RV'er
 
Join Date: Oct 2014
Location: Winter Park, FL
Posts: 1,064
Quote:
Originally Posted by aeroshots View Post
Sounds like it still needs work. I'd try any combination if n between d and R or R and d did not work. I despise intermittent issues like this. Sorry you are having it.
Thanks. Intermittent issues are a pain. That's why they couldn't fix it before this trip; Freightliner needed to keep it a few days. I was getting frustrated with it until I discovered the R to D thing worked. Now if it just keeps working!
__________________
2015 Legacy SR340 360RB
2014 Jeep Wrangler Unlimited Toad

Gigi, Poppy and Sadie Lady...On the road, but not full time!
conceptumator is offline   Reply With Quote
Old 10-22-2016, 05:58 PM   #15
Senior Member
 
captnrick3's Avatar
 
Join Date: Feb 2015
Location: Lake Havasu City, AZ
Posts: 576
Quote:
Originally Posted by conceptumator View Post
Thanks. Intermittent issues are a pain. That's why they couldn't fix it before this trip; Freightliner needed to keep it a few days. I was getting frustrated with it until I discovered the R to D thing worked. Now if it just keeps working!
Interesting thread, thanks for posting. Always nice to hear of good service from the Freightliner dealers. So far no issues like this for me, but it's always nice to read everything just in case.
__________________
2015 Legacy 340KP
2012 Wrangler Sport
captnrick3 is offline   Reply With Quote
Old 12-27-2016, 11:34 AM   #16
Junior Member
 
Join Date: Apr 2016
Location: Huffman TX.
Posts: 26
What was the fix?

I have a 2015 Legacy 360RB and having same issue. I have found the bounce from R to D works sometimes however at a rest area just east of El Paso that did not want to work. I tried many combos and finally got to engage. We drove home to Houston without taking out of gear. The bad part is now at home it seems to be working fine! I called Freightliner and they seemed like that has never been brought to the table before. Please let me know if this problem gets resolved by anyone.

Thanks!
Englund is offline   Reply With Quote
Old 12-27-2016, 11:41 AM   #17
7 Year Class A RV'er
 
Join Date: Oct 2014
Location: Winter Park, FL
Posts: 1,064
I have an appointment to drop it off with Freightliner next week. I'll try to post their "fix" when I get it back.
__________________
2015 Legacy SR340 360RB
2014 Jeep Wrangler Unlimited Toad

Gigi, Poppy and Sadie Lady...On the road, but not full time!
conceptumator is offline   Reply With Quote
Old 12-27-2016, 05:07 PM   #18
Senior Member
 
captnrick3's Avatar
 
Join Date: Feb 2015
Location: Lake Havasu City, AZ
Posts: 576
Quote:
Originally Posted by conceptumator View Post
I have an appointment to drop it off with Freightliner next week. I'll try to post their "fix" when I get it back.
I'm looking forward to see what their fix is. I have not had any issues, but ever since this thread was started, it goes through my mind as I am maneuvering. Just this morning I took the MH out for fuel and I thought of it as the gas station. Heading out in the AM for a month of fun & games in Arizona.
__________________
2015 Legacy 340KP
2012 Wrangler Sport
captnrick3 is offline   Reply With Quote
Old 12-28-2016, 08:34 AM   #19
Senior Member
 
DrJAG's Avatar
 
Join Date: Apr 2015
Posts: 210
Are you still getting the Trans Comm Failed message (or some other message)? I had a similar issue once last summer. I had stopped for gas and when I was ready to leave, it would not shift into D. Of course there were two RVs behind me waiting for the pump. I got a shift inhibited message or something similar, don't remember exactly (but not Trans Comm Failed). The way I was parked, the rear wheels were resting on a speed bump. It did go into Reverse and I backed up a foot or so to get wheels off of the speed bump, then I was able to get it to go to D. I assumed my problem had something to do with the wheels being on the speed bump, but now I wonder. So I too am interested what Freightliner finds/says. Hope you all are having a good holiday season.


2015 Legacy RB, 2013 CRV toad. Retired USAF. Sent from my iPad using Forest River Forums
__________________
-DrJAG
2015 Legacy 360RB with 2013 CRV toad. Retired USAF.
DrJAG is offline   Reply With Quote
Old 12-29-2016, 07:23 AM   #20
Member
 
dndnva's Avatar
 
Join Date: Sep 2014
Location: Northern VA
Posts: 99
This happened to our 2016 Legacy last December while on a 2200 mile trip. Had to trick it into gear using R then D. Turned out Freightliner had to replace the Selector Switch and harness. Haven't had any problems since then. I am careful to put it into N before changing gears now although I don't really know if I was doing that before or not.
__________________
2016 Legacy SR340 KP (340HP, 2500 Allison)
Toad: 2013 Wrangler Unlimited
dndnva is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



All times are GMT -5. The time now is 01:54 AM.