Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×


Reply
 
Thread Tools Display Modes
Old 08-13-2022, 09:46 PM   #1
Junior Member
 
Join Date: Apr 2018
Posts: 1
Infotainment system

I lost power today to my infotainment display which includes backup camera and side cameras. Rig is 2018 Isata 3. Checked everything I could think of, but no results. Anyone else have same problem, and if so, the solution.
Thanks
Jerry
JDB51 is offline   Reply With Quote
Old 08-13-2022, 11:12 PM   #2
Site Team
 
bikendan's Avatar
 
Join Date: Jan 2007
Location: Goodyear, Arizona
Posts: 29,540
Quote:
Originally Posted by JDB51 View Post
I lost power today to my infotainment display which includes backup camera and side cameras. Rig is 2018 Isata 3. Checked everything I could think of, but no results. Anyone else have same problem, and if so, the solution.

Thanks

Jerry
Moved thread to the Dynamax sub-forum for better help and factory support.
__________________
Dan-Retired California Firefighter/EMT
Shawn-Musician/Entrepreneur/Wine Expert
and Zoe the Wonder Dog(R.I.P.)
2016 PrimeTime TracerAIR 255, pushing a 2014 Ford F150 SCREW XTR 4x4 3.5 Ecoboost w/Max Tow Package
4pt Equal-i-zer WDH and 1828lbs of payload capacity
bikendan is online now   Reply With Quote
Old 08-14-2022, 09:41 AM   #3
Commercial Member
 
Join Date: Nov 2007
Location: Bristol, IN
Posts: 17,303
Radio fuse on the chassis would be first.

See if you can confirm power to the radio. If you can, then the radio is likely bad.
__________________
If "Search this Forum" does not yield an answer, please post questions as a "New Thread" (instead of sending a private message) so that others can benefit from the answers. Use Private Messages for sensitive information only.

Don't forget to subscribe to our YouTube page for "How To" videos and updates https://www.youtube.com/c/DynamaxRVs/
bclemens is offline   Reply With Quote
Old 08-15-2022, 09:10 AM   #4
Junior Member
 
Join Date: Oct 2018
Location: Reno
Posts: 14
Ours did that on our way home. Blank screen, wouldn’t turn on. Half way through the trip it would turn on and then go off again. I have no clue.
DanandMary is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



All times are GMT -5. The time now is 02:31 PM.