Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×


Reply
 
Thread Tools Display Modes
Old 09-19-2021, 09:32 AM   #1
Senior Member
 
Join Date: Apr 2018
Posts: 945
Onan auto-gen

I know I've brought this up before but it worked and not it's back to the way it was.

When I first got my DX3, the first couple of years, I would just flip the auto-gen switch to the "on" position. Nothing more. When the batteries got low (I had the voltage set to 12), the generator would kick on and then shut itself off when it was fully charged.

Over the last year, I've noticed if I leave the RV with no shore power (as I have done in the past), the auto-gen is hit or miss whether it comes on.

I believe Brian told me I had to flip the switch from off to on every time I shut the RV off. (which I had never done before)

A few weekends ago I was in FL and had to leave the RV for a couple of days unplugged. I had everything off except the power to the microwave, refrigerator and whatever necessities we don't know are always running. I shut the RV off, flipped the switch from on to test to off and then back to on.

Within a few minutes, the generator kicked on, ran for about 10 minutes and shut off. I walked away feeling everything was working.

I came back the next morning and it was down to 10 volts. I got everything back to snuff and repeated the same steps I did the night before. The generator immediately started (was it did the night before) and I drove off thinking it would kick itself off.

When I came back in the morning, the generator was still running. I checked the hours before I left to make sure if it was running when I came back in the morning, it just hadn't happened to start up before I got there. I was disappointed to see the generator was running all night.

Does anyone have any suggestions? Like I mentioned, for the first two years, I never did any special routine to make the auto-gen work. Flip the switch to on and never touched it.

Now, it's hit or miss.... seems like sometimes it works correctly, other times it doesn't work at all. Is there a procedure or reset or something that I'm missing or do I just need to take it to the dealer (UGH)

Thanks,

Mark
Orangecrush is offline   Reply With Quote
Old 09-20-2021, 11:51 AM   #2
Norwood Auto Italia
 
Join Date: Aug 2020
Location: Montana & TX
Posts: 836
Just from what you have posted, it sounds like the voltage sensor circuit for the AGS has failed. The serendipity of its behavior and then its inability to detect that it has reached target is a big clue.

Does your set up require you to specify how long the generator should run once it reaches target? That logic board may also be faulty.

Typically these boards are not individually serviceable or testable by an RV service operation and you will need to replace the whole control unit.
__________________
2000 Sportsmobile E350 EB
2006 Renegade/Peterbilt K1854 and T1220
2021 Isata 5 28SS Explorer
vlamgat is offline   Reply With Quote
Old 09-20-2021, 03:40 PM   #3
Senior Member
 
Join Date: Apr 2017
Posts: 849
Ours exhibited this erratic behavior as well. After WAAAAAY too much time spent troubleshooting, I finally gave in and ordered a new Magnum AGS module. It's worked perfectly since then.

Not saying this is the issue you're running into, but, if you've exhausted most other options, it's a relatively inexpensive thing to try next.

Good luck!
JT
__________________
2018 DX3 37BH
mookieblaylock is offline   Reply With Quote
Old 09-21-2021, 08:59 AM   #4
Senior Member
 
Join Date: Apr 2018
Posts: 945
Thanks guys, I'll look into it. It's the actual control unit/panel that you set your parameters up that I need to replace, right?

Thanks,

Mark
Orangecrush is offline   Reply With Quote
Old 09-21-2021, 09:12 AM   #5
Senior Member
 
Join Date: Apr 2017
Posts: 849
I replaced this guy in the electrical bay:
Attached Images
 
__________________
2018 DX3 37BH
mookieblaylock is offline   Reply With Quote
Old 09-22-2021, 08:50 AM   #6
Senior Member
 
CyberShanks's Avatar
 
Join Date: May 2014
Location: Top of a hill (in Iowa) surrounded by corn. Dynaquest XL 3400KD getting built for us right now!
Posts: 161
If that is it, here's a link to where one can be purchased:


https://invertersrus.com/product/magnumenergy-meags-s/



Jim
CyberShanks is offline   Reply With Quote
Old 09-22-2021, 04:14 PM   #7
Senior Member
 
Join Date: Apr 2017
Posts: 849
Wow...that's pretty much exactly what I paid for mine back in January of 2019. I figured they'd be bringing twice that now.
__________________
2018 DX3 37BH
mookieblaylock is offline   Reply With Quote
Old 09-22-2021, 06:07 PM   #8
Senior Member
 
Invisibleman's Avatar
 
Join Date: Jul 2020
Location: Phoenix
Posts: 499
I've had very similar problem on my 21 Force. I started a thread on it. Eventually gave up, as you said, it was hit or miss and I no longer walk away with AGS on. The only thing I use it for is durimg.the night when boon docking.
__________________

2020 Isata-5 36DS (traded in)
2021 Jeep Grand Cherokee Trailhawk
2021 Force 37TS (Detroit DD8)
Invisibleman is offline   Reply With Quote
Old 09-27-2021, 11:28 AM   #9
Senior Member
 
Join Date: Apr 2018
Posts: 945
Quote:
Originally Posted by mookieblaylock View Post
Wow...that's pretty much exactly what I paid for mine back in January of 2019. I figured they'd be bringing twice that now.
They might be.....lol. I just ordered it and they charged and credited my card 3 times. Turns out they can't get it.

I'll look elsewhere...

Mark
Orangecrush is offline   Reply With Quote
Old 09-27-2021, 12:14 PM   #10
Senior Member
 
CyberShanks's Avatar
 
Join Date: May 2014
Location: Top of a hill (in Iowa) surrounded by corn. Dynaquest XL 3400KD getting built for us right now!
Posts: 161
I tried..

Jim
CyberShanks is offline   Reply With Quote
Old 09-27-2021, 04:41 PM   #11
Senior Member
 
Join Date: Apr 2018
Posts: 945
Quote:
Originally Posted by CyberShanks View Post
I tried..

Jim
I appreciate it. I found one even cheaper. 169 bucks.

Thanks so much for your time and effort.


Mark
Orangecrush is offline   Reply With Quote
Old 09-27-2021, 05:59 PM   #12
Senior Member
 
CyberShanks's Avatar
 
Join Date: May 2014
Location: Top of a hill (in Iowa) surrounded by corn. Dynaquest XL 3400KD getting built for us right now!
Posts: 161
Awesome, hopefully it fixes the issue for ya.


Jim
CyberShanks is offline   Reply With Quote
Old 09-29-2021, 07:24 AM   #13
Norwood Auto Italia
 
Join Date: Aug 2020
Location: Montana & TX
Posts: 836
Quote:
Originally Posted by CyberShanks View Post
Awesome, hopefully it fixes the issue for ya.


Jim
Let us know...
__________________
2000 Sportsmobile E350 EB
2006 Renegade/Peterbilt K1854 and T1220
2021 Isata 5 28SS Explorer
vlamgat is offline   Reply With Quote
Reply

Tags
onan

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



All times are GMT -5. The time now is 12:13 AM.