Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×


Reply
 
Thread Tools Display Modes
Old 07-30-2022, 11:49 PM   #1
Member
 
Join Date: Jul 2022
Posts: 61
Backup camera STOPPED working

Backup and side camera STOPPED working.
2016 Mercedes Sunseeker 2400S MBS 11,600 miles.

Had it inspected before purchase and it worked on the way to the Campground which was only about 5 miles away from where we bought it.

When I backed into my spot it worked fine I tried to give as far back as I could until I reach a curb spot I did hear a very slight scraping so I stopped and pulled forward and parked there.

later on I looked at what might have scraped and it was too hangar exhaust bolts that were about one and a 1/2 inches too long.

I do not think this could have affected the camera but I am new to this whole RV experience.

I did take it to the place it was inspected and the technician looked at it and could not figure it out and said it would take some time which I did not have as I am vacationing and need to get back to The Valley and they were closing in 30 minutes.

They would not cover it as it was not part of the inspection and they do not cover labor.
azmotoman is offline   Reply With Quote
Old 07-31-2022, 04:55 AM   #2
Senior Member
 
Mikegjax's Avatar
 
Join Date: Aug 2013
Location: Orange Park Fl.
Posts: 1,829
If RVS is the system, they are helpful in troubleshooting. Give them a call. The controller should be located just above the Fuse box behind a small dash panel held in by one #2 torn head screw.
__________________
2014 Solera 24R
USN Retired
Mikegjax is online now   Reply With Quote
Old 07-31-2022, 04:58 AM   #3
Senior Member
 
Mikegjax's Avatar
 
Join Date: Aug 2013
Location: Orange Park Fl.
Posts: 1,829
Did both side cameras stop?
__________________
2014 Solera 24R
USN Retired
Mikegjax is online now   Reply With Quote
Old 07-31-2022, 07:52 AM   #4
Junior Member
 
Join Date: Oct 2020
Posts: 19
do you have any pictures of the location please.
rgt3000 is offline   Reply With Quote
Old 07-31-2022, 09:39 AM   #5
Member
 
Join Date: Jul 2022
Posts: 61
Quote:
Originally Posted by Mikegjax View Post
If RVS is the system, they are helpful in troubleshooting. Give them a call. The controller should be located just above the Fuse box behind a small dash panel held in by one #2 torn head screw.

New to ALL THIS
What is RVS
Where is the Fuse Box

Thanks
azmotoman is offline   Reply With Quote
Old 07-31-2022, 09:41 AM   #6
Member
 
Join Date: Jul 2022
Posts: 61
Quote:
Originally Posted by Mikegjax View Post
Did both side cameras stop?
Yes NOTHING works, black screen. When I press the POWER button it beeps
azmotoman is offline   Reply With Quote
Old 07-31-2022, 11:42 AM   #7
2012 Solera
 
Join Date: May 2012
Posts: 1,700
RVS is the company name - often used by Forest River for this purpose:

https://www.rearviewsafety.com/safet...YaApIsEALw_wcB

My 2012 only has the rear camera, so my experience may not be very applicable.

On mine, the control box was stuffed up among other wires to the left of the steering wheel under the dash - as Mikegjax described. Aluminum metal box about 3X4X1.5 inches, as I remember. As you are hearing a “beep”, it is getting power - so unlikely a fuse.

One time that mine quit, it was corrosion or mold on the controller circuit board. Took the controller out and disassembled, scrubbed the boards with alcohol using a toothbrush- fixed. The most recent time it was s short in the cable. I suspect a staple wore through (after 10 years and 110K miles).

FYI, Jim
__________________
JLeising
2012 Solera "S"
Calif SF Bay Area
JLeising is offline   Reply With Quote
Old 07-31-2022, 11:59 AM   #8
Senior Member
 
Join Date: Apr 2022
Location: Tarpon Springs FL
Posts: 477
any buttons for switching cameras.... on the screen


my screen was black with wording ... no input
pressed the cameras button until the camera / pic was showing
__________________
Tarpon Springs FL
2022 Salem 24RLXL
Aussieguy is online now   Reply With Quote
Old 07-31-2022, 08:55 PM   #9
Senior Member
 
Mikegjax's Avatar
 
Join Date: Aug 2013
Location: Orange Park Fl.
Posts: 1,829
Quote:
Originally Posted by azmotoman View Post
New to ALL THIS

What is RVS

Where is the Fuse Box



Thanks
The cover for the fuse box is under the dash just forward of where the driver door is hinged on the inside. The access cover for the camera controller is the first under dash access panel. It's held in place by one #2 torx head screw at the bottom. The camera controller is stuffed in behind that cover.
__________________
2014 Solera 24R
USN Retired
Mikegjax is online now   Reply With Quote
Old 07-31-2022, 08:58 PM   #10
Senior Member
 
Mikegjax's Avatar
 
Join Date: Aug 2013
Location: Orange Park Fl.
Posts: 1,829
BTW, make sure your camera monitor/rear view mirror is set on proper source. There are arrows on the front above the on off switch that allow for source selection.
__________________
2014 Solera 24R
USN Retired
Mikegjax is online now   Reply With Quote
Old 07-31-2022, 11:43 PM   #11
Member
 
Join Date: Jul 2022
Posts: 61
I am still up in the mountains heading home tomorrow so haven't been able to do too much with it.

I did try to troubleshoot and look at the fuses by the driver but none are for the camera.

I did find a fuse Box by the stairs in the coach but none of them have a camera fuse either and by the way those are weird looking fuses what happens when one of those goes bad? I've never seen a fuse like those where do you get them.

And yes the side cameras do not work either the screen is totally black I've tried the different modes I've tried every button on that screen nothing works but it does beep so like someone else said it can't be a fuse if I'm getting power correct?

Thanks
azmotoman is offline   Reply With Quote
Old 08-01-2022, 12:58 AM   #12
Member
 
Join Date: Jul 2022
Posts: 61
Reverse and Side camera STOPPED working

Fusebox on seat base.
2016 Mercedes Sunseeker 2400S Forest River

FIRST PICTURE


I think there's a couple that are in the wrong place number 34 and 35 should be reversed. According to the owners manual they are in wrong but don't want to take a chance with a 4 hour drive in a steep canyon EARLY tomorrow. They have been driving it like this. I don't think I switched them, been a long day...
Every other fuse checks out according to the manual PICTURES 2 AND 3





By the way this has nothing to do with my camera issue but I know the previous owners had issues with the fuses and something about the Dev system and the Mercedes dealer charged them A lot of $$ and said they were missing a fuse. I guess the old man was messing with it.



PICTURES 4 AND 5


I can't find this Fuse Block 55/7 for fuse # 38 .
Is this for the camera?

Thanks

azmotoman is offline   Reply With Quote
Old 08-01-2022, 06:31 AM   #13
Senior Member
 
Mikegjax's Avatar
 
Join Date: Aug 2013
Location: Orange Park Fl.
Posts: 1,829
Here are photos of the dash panel where the controller should be.Click image for larger version

Name:	20220801_072553.jpg
Views:	28
Size:	99.7 KB
ID:	277280Click image for larger version

Name:	20220801_072547.jpg
Views:	26
Size:	63.2 KB
ID:	277281
__________________
2014 Solera 24R
USN Retired
Mikegjax is online now   Reply With Quote
Old 08-02-2022, 01:17 PM   #14
Member
 
Join Date: Jul 2022
Posts: 61
Thanks For all the replies we got back late yesterday and it was a 105゚ out it's tough to work on stuff when it's so hot.

Now I'm at work the rest of the week somebody said that it might be the controller for the camera as I am getting voltage cause it beeps when I hit the power button on the camera screen.
azmotoman is offline   Reply With Quote
Old 08-08-2022, 06:57 PM   #15
Senior Member
 
raptor's Avatar
 
Join Date: Jul 2016
Location: Washington State
Posts: 308
Quote:
Originally Posted by azmotoman View Post
Backup and side camera STOPPED working.
2016 Mercedes Sunseeker 2400S MBS 11,600 miles.

Had it inspected before purchase and it worked on the way to the Campground which was only about 5 miles away from where we bought it.

When I backed into my spot it worked fine I tried to give as far back as I could until I reach a curb spot I did hear a very slight scraping so I stopped and pulled forward and parked there.

later on I looked at what might have scraped and it was too hangar exhaust bolts that were about one and a 1/2 inches too long.

I do not think this could have affected the camera but I am new to this whole RV experience.

I did take it to the place it was inspected and the technician looked at it and could not figure it out and said it would take some time which I did not have as I am vacationing and need to get back to The Valley and they were closing in 30 minutes.

They would not cover it as it was not part of the inspection and they do not cover labor.
My 2016 2401R rear view quitted working about the same mileage you got on your rig. I replaced new screen from RVS that can connect to all three cameras. Our old unit has a control box under the dash. There is no need for this control box because new screen came with control box builded into circuit board inside. Now it's working as it should. I hope it will work for you.
__________________
raptor
2016 Forester MBS 2401R
America is great
raptor is offline   Reply With Quote
Old 08-08-2022, 11:47 PM   #16
Member
 
Join Date: Jul 2022
Posts: 61
Thumbs up

Quote:
Originally Posted by raptor View Post
My 2016 2401R rear view quitted working about the same mileage you got on your rig. I replaced new screen from RVS that can connect to all three cameras. Our old unit has a control box under the dash. There is no need for this control box because new screen came with control box builded into circuit board inside. Now it's working as it should. I hope it will work for you.
WoW great info! Just really mystified me as I had it inspected by a RV maintenance biz before I purchased this a few weeks ago.

Previous owner drove it home as she lived close by

it worked then and it worked on the way to the campground.

on the way back is when I noticed it was no longer working much to my dismay.

Did you install it yourself, was it hard I'm an OK mechanic but electrical gurus give me the Willie's!!!

is it basically plug and play, thanks for the info.
azmotoman is offline   Reply With Quote
Old 08-09-2022, 10:02 AM   #17
Senior Member
 
raptor's Avatar
 
Join Date: Jul 2016
Location: Washington State
Posts: 308
Yes I installed it myself. I'm retired machinist, so you would not have any problem install it. First I replaceed control box under the dash ($50), but it was not working than I bought new screen (RVS-619N-NM). This one is exact like the old one except control box is build in. Hope it work for you. Good luck.
__________________
raptor
2016 Forester MBS 2401R
America is great
raptor is offline   Reply With Quote
Old 08-09-2022, 10:51 AM   #18
Member
 
Join Date: Jul 2022
Posts: 61
Thumbs up

Quote:
Originally Posted by raptor View Post
Yes I installed it myself. I'm retired machinist, so you would not have any problem install it. First I replaceed control box under the dash ($50), but it was not working than I bought new screen (RVS-619N-NM). This one is exact like the old one except control box is build in. Hope it work for you. Good luck.
Awesome!
Replies like this and many others I have received are what make this a great and INFORMATIVE site.

Thanks everyone!
azmotoman is offline   Reply With Quote
Old 08-11-2022, 09:22 PM   #19
Senior Member
 
Join Date: Oct 2014
Location: Central Florida
Posts: 584
I have a 2021 Sunseeker and my backup camera and side view cameras quit. I'll give you a tip that cost me $400 to find out. The fuse was in a small control box located under the plastic trim on the driver side windshield post.
poppytoymaker is offline   Reply With Quote
Old 08-12-2022, 01:05 AM   #20
Junior Member
 
Join Date: Jul 2016
Posts: 9
A Porsche mechanic once told me, if an electrical problem shows up - look into the ground wires 1st. When my rear view camera system (certainly not same as yours) quit after having been reliable, I started tracing the ground wires within the system and sure enough it was a ground wire. Good luck.
__________________
2007 Forest River Lexington GTS (2006 E-450-SD), 27', Hellwig HD sway F&R, 4 KONI FSD, "-40" SUMO's: f-Solo, r-Maxim, SS450 Trac Bar, Safe-T-Plus awaiting alignment.
smlange is offline   Reply With Quote
Reply

Tags
camera

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



All times are GMT -5. The time now is 05:19 AM.