Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×


Reply
 
Thread Tools Display Modes
Old 02-08-2021, 10:06 AM   #1
Junior Member
 
Join Date: Feb 2021
Posts: 2
Brake problems

First post on this forum-looking forward to new friendships!
2015 Sunseeker MBS 2400 WS Towing 2008 Honda CRV. After several hours of towing-ABS/anti-slip/ and tire light come on. Sometimes makes weird buzzing surging noise and brakes may pulse when applied and act only about 30% effective. After stopping for short time everything seems to reset and work fine. Donít know if it is Sprinter or tow car issue but I think the lights came on once when tow car was not hooked up. Any suggestions? Thanks in advance.
Woodsjs is offline   Reply With Quote
Old 02-08-2021, 10:46 AM   #2
Senior Member
 
Join Date: May 2019
Posts: 4,330
Quote:
Originally Posted by Woodsjs View Post
First post on this forum-looking forward to new friendships!
2015 Sunseeker MBS 2400 WS Towing 2008 Honda CRV. After several hours of towing-ABS/anti-slip/ and tire light come on. Sometimes makes weird buzzing surging noise and brakes may pulse when applied and act only about 30% effective. After stopping for short time everything seems to reset and work fine. Don’t know if it is Sprinter or tow car issue but I think the lights came on once when tow car was not hooked up. Any suggestions? Thanks in advance.
There is a Mercedes-Benz Sprinter chassis subforum. https://www.forestriverforums.com/forums/f242/ You might get some answers about your MBS if you post your questions there.

You can also use the forum search to see of your problem has already been discussed on the forum. I searched for you and here is a thread about MBS wheel sensors that might be helpful: https://www.forestriverforums.com/fo...es-171024.html

Welcome to the FR forum!
__________________
2020 Sunseeker 2440DS on 2019 Ford E-450, Trekker cap, Topaz paint
BehindBars is offline   Reply With Quote
Old 02-08-2021, 11:08 AM   #3
Site Team
 
Mr. Dan's Avatar
 
Join Date: Mar 2014
Location: Grayson County, Texas
Posts: 21,897
Quote:
Originally Posted by BehindBars View Post
There is a Mercedes-Benz Sprinter chassis subforum. https://www.forestriverforums.com/forums/f242/ You might get some answers about your MBS if you post your questions there.
Since this thread is more of a technical nature and not a new member introduction, it has been moved by the site team to the suggested sub-forum. Thanks.
__________________
2015 FR Wildcat 295RSX / GMC Sierra

Nights Camped: '13 = 49/'14 = 74/'15 = 74/'16 = 85/'17 = 110/'18 = 111/'19 = 86/'20 =108/'21 = 115/'22 = 135/'23 = 78/'24 = 41; Booked for 2024 = 55
Mr. Dan is offline   Reply With Quote
Old 02-08-2021, 02:25 PM   #4
2012 Solera
 
Join Date: May 2012
Posts: 1,837
As has been noted on this forum previously, the abs warning light (at least on my 2012 MBS and on others who have posted) is occasionally triggered by wind sway. It will only reset after a full engine shutdown. When this has happened to me, I have not noticed any braking performance reduction (though I suspect antilock may be disabled). Also, I don’t pull a toad.

https://www.forestriverforums.com/fo...hts-78006.html

FYI, Jim
__________________
JLeising
2012 Solera "S"
Calif SF Bay Area
JLeising is offline   Reply With Quote
Old 02-08-2021, 05:16 PM   #5
Senior Member
 
Mikegjax's Avatar
 
Join Date: Aug 2013
Location: Orange Park Fl.
Posts: 1,878
You could have a wheel speed sensor starting to fail. Could be as simple as a loose sensor connection. They connect under the chassis and access is not difficult. I have to replace one of mine. I have the part, just waiting for a little better weather.
__________________
2014 Solera 24R
USN Retired
Mikegjax is offline   Reply With Quote
Old 02-09-2021, 01:59 PM   #6
Senior Member
 
Mikegjax's Avatar
 
Join Date: Aug 2013
Location: Orange Park Fl.
Posts: 1,878
Quote:
Originally Posted by Woodsjs View Post
First post on this forum-looking forward to new friendships!
2015 Sunseeker MBS 2400 WS Towing 2008 Honda CRV. After several hours of towing-ABS/anti-slip/ and tire light come on. Sometimes makes weird buzzing surging noise and brakes may pulse when applied and act only about 30% effective. After stopping for short time everything seems to reset and work fine. Don’t know if it is Sprinter or tow car issue but I think the lights came on once when tow car was not hooked up. Any suggestions? Thanks in advance.
Received a notice in the mail today that the wheel speed sensor warranty has been extended to 10 years regardless of mileage. Good time to contact your MB Sprinter dealer in your area.

Applies to model years 2012-2018.
__________________
2014 Solera 24R
USN Retired
Mikegjax is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



All times are GMT -5. The time now is 12:27 PM.