Reply
 
Thread Tools Display Modes
Old 03-07-2020, 04:19 PM   #1
Junior Member
 
Join Date: Aug 2019
Posts: 3
2020 hemisphere has no power to level system

I have no power, no lights to the leveling system. The one control no longer shows a app on its screen. Canít figure out why. Everything looks good!!!!
__________________

Bloodlan is offline   Reply With Quote
Old 03-09-2020, 03:20 PM   #2
Junior Member
 
Join Date: Aug 2019
Posts: 3
Dead forum I guess
__________________

Bloodlan is offline   Reply With Quote
Old 03-10-2020, 09:23 AM   #3
Boss Ox & Drovergirl
 
oxcamper's Avatar
 
Join Date: Feb 2014
Location: N.E. Ohio Snow Belt
Posts: 782
Is it only the remote functions or both the control panel and the remote?
__________________
Mark, Vicki, & Scout THE dog
2015 Hemisphere 282RK
2011 2500HD Silverado
1992 Goldwing Aspencade
oxcamper is offline   Reply With Quote
Old 03-10-2020, 09:31 AM   #4
Senior Member
 
Join Date: Apr 2016
Location: Port Charlotte Fl/Hinsdale Ma
Posts: 4,824
Have you looked at the fuse panel using a volt meter?
cavie is offline   Reply With Quote
Old 03-10-2020, 09:54 AM   #5
Junior Member
 
Join Date: Aug 2019
Posts: 3
So after testing everything. I found a factory splice between the power supply and the control box to be poorly connected. They didn’t take off enough to expose the wires correctly. After making a better connection the levelers worked and the one control panel showed the level app again. What a pain in the rear side.
Bloodlan is offline   Reply With Quote
Old 03-10-2020, 09:59 AM   #6
Boss Ox & Drovergirl
 
oxcamper's Avatar
 
Join Date: Feb 2014
Location: N.E. Ohio Snow Belt
Posts: 782
Happy to hear you found the problem!

__________________
Mark, Vicki, & Scout THE dog
2015 Hemisphere 282RK
2011 2500HD Silverado
1992 Goldwing Aspencade
oxcamper is offline   Reply With Quote
Old 03-10-2020, 10:02 AM   #7
Senior Member
 
NMWildcat's Avatar
 
Join Date: Jun 2012
Location: Southern NM
Posts: 5,608
Quote:
Originally Posted by Bloodlan View Post
Dead forum I guess
Well, not much info in your request.
First thing to do is reboot everything. Turn off all power, 12v and 110v. Turn it all back on.
If nothing, then check all fuses and resettable circuit breakers. Check batteries. Use a multimeter to check power.
If still nothing, call Lippert tech support or a mobile RV tech.
__________________
Scott and Liz - Southern NM
2012 Wildcat Sterling 32RL - w/level up (best option ever)
2007 Chevy 2500HD 4dr short bed Duramax w/allison
Reese Fifth Airborne air ride king pin coupler with Sidewinder
NMWildcat is online now   Reply With Quote
Old 03-10-2020, 10:04 AM   #8
Senior Member
 
NMWildcat's Avatar
 
Join Date: Jun 2012
Location: Southern NM
Posts: 5,608
Ah, guess we posted at the same time. Glad you found your power problem.
__________________

__________________
Scott and Liz - Southern NM
2012 Wildcat Sterling 32RL - w/level up (best option ever)
2007 Chevy 2500HD 4dr short bed Duramax w/allison
Reese Fifth Airborne air ride king pin coupler with Sidewinder
NMWildcat is online now   Reply With Quote
Reply

Tags
hemisphere, power

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



All times are GMT -5. The time now is 07:14 AM.


×