Reply
 
Thread Tools Display Modes
Old 03-01-2017, 09:32 AM   #1
Junior Member
 
Join Date: Feb 2017
Posts: 28
2017 2811vs smoke alarm

Just turned on heat for first time with temp in mid 40s. Smoke/ carbon monoxide with off. Turned heat off and alarm went off. Also heard a whistle sound in v nose. I read in this forum that possibly elec problem but all had going was coffee pot. Any ideas?
__________________

Camping_RLT is offline   Reply With Quote
Old 03-01-2017, 09:57 AM   #2
Senior Member
 
BooBoo23's Avatar
 
Join Date: Apr 2014
Location: West Atlanta Metro
Posts: 1,228
Is this a brand new RV? If this is the first time the furnace has been used there will be smoke from oil on the metal in the furnace. It will burn off after a few minutes and everything will be ok. Smoke detector works!
__________________

__________________
2014 Palomino Puma 25RS
2011 F-150 Super Crew XLT
Days camped in 2014 - 23 Camped 2015-47
Camped 2016-71, 2017-33, 2018-29 booked
KT4W
BooBoo23 is offline   Reply With Quote
Old 03-01-2017, 10:07 AM   #3
Junior Member
 
Join Date: Feb 2017
Posts: 28
Quote:
Originally Posted by BooBoo23 View Post
Is this a brand new RV? If this is the first time the furnace has been used there will be smoke from oil on the metal in the furnace. It will burn off after a few minutes and everything will be ok. Smoke detector works!


Yep brand new from yesterday. Installed screens on outside for wasps etc. would that cause? Gets hot. I am rookie and had a small jayco before but it used and really never used heat.
Camping_RLT is offline   Reply With Quote
Old 03-01-2017, 10:33 AM   #4
Senior Member
 
BooBoo23's Avatar
 
Join Date: Apr 2014
Location: West Atlanta Metro
Posts: 1,228
Yes, the exhaust from the furnace gets very hot, it's a shame to waste it. Don't turn on the water heater until you have filled it.
__________________
2014 Palomino Puma 25RS
2011 F-150 Super Crew XLT
Days camped in 2014 - 23 Camped 2015-47
Camped 2016-71, 2017-33, 2018-29 booked
KT4W
BooBoo23 is offline   Reply With Quote
Old 03-01-2017, 10:53 AM   #5
Site Team
 
Flybob's Avatar
 
Join Date: Oct 2014
Posts: 10,711
This should have been covered by the dealer during PDI. There is residual oil and other contaminants on the metal in the furnace from the manufacturing process. You need to run the furnace for about 20-30 minutes with the doors and windows open and smoke detector removed ( or battery removed) to burn off the oils. I would not be concerned about the screen on the exhaust post. Once you burn off the oil you will be fine. You might also run the furnace for a few minutes with the windows open at the beginning of each heating season to bun off the dust that will collect on the heat exchanger.
__________________

2015 Freedom Express 248RBS
TV 2015 Silverado HD2500 Duramax
TST Tire Monitors
Honda 2000I + Companion
2 100W solar panels
Flybob is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



All times are GMT -5. The time now is 10:28 PM.


×